Closed Bug 880281 Opened 6 years ago Closed 6 years ago

Make Marketplace more discoverable in about:apps

Categories

(Firefox for Android :: General, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox27 --- verified
fennec + ---

People

(Reporter: ibarlow, Assigned: Margaret)

References

Details

Attachments

(3 files, 1 obsolete file)

We should apply the design styling in bug 722902 to about:apps as well.

1. Add an arrow next to the icon in the title bar
2. Add a content row that links to the Marketplace
tracking-fennec: --- → ?
tracking-fennec: ? → +
This is the styling I am referring too from the add-ons manager btw https://bug722902.bugzilla.mozilla.org/attachment.cgi?id=697951
This should be implemented much as the same way that AMO discoverability was fixed (bug 722902)
We probably need some assets, right?
Assignee: nobody → margaret.leibovic
about:apps is styled differently than about:addons (there's a grid of app icons, rather than a list), so we'll need a different design for the content row.

Also, if you have no apps installed, we already include a link to the marketplace, so maybe this content row is unnecessary (says the lazy engineer).

However, we can still put the arrow next to the marketplace icon in the top-right corner.
Flags: needinfo?(ibarlow)
I agree that if you have no apps installed, no changes are necessary since we already direct users to the MP. 

I think we just need to fix / add a line (Ian can provide the correct verbiage here) for when a user does have an app installed and wants to install / browse more.
Duplicate of this bug: 923822
(In reply to :Margaret Leibovic from comment #4)
> about:apps is styled differently than about:addons (there's a grid of app
> icons, rather than a list), so we'll need a different design for the content
> row.
> 
> Also, if you have no apps installed, we already include a link to the
> marketplace, so maybe this content row is unnecessary (says the lazy
> engineer).
> 

I'd still like to put a row here, whether there are apps installed or not. We do this on about:addons too.


> However, we can still put the arrow next to the marketplace icon in the
> top-right corner.

Great. The assets that are used for about:addons should be reusable here, no?
Flags: needinfo?(ibarlow)
(In reply to Ian Barlow (:ibarlow) from comment #7)
> (In reply to :Margaret Leibovic from comment #4)
> > about:apps is styled differently than about:addons (there's a grid of app
> > icons, rather than a list), so we'll need a different design for the content
> > row.
> > 
> > Also, if you have no apps installed, we already include a link to the
> > marketplace, so maybe this content row is unnecessary (says the lazy
> > engineer).
> > 
> 
> I'd still like to put a row here, whether there are apps installed or not.
> We do this on about:addons too.

But what should this look like? For about:apps, we put app icons in a grid in a white box that has rounded corners, not in a list like we do on about:addons. So adding a row at the bottom just like about:addons would look awkward... Or maybe we should try unifying the design of about:apps and about:addons? Although that feels like more effort than it would be worth, since we may want to replace these with native UI at some point in the (near?) future.

> > However, we can still put the arrow next to the marketplace icon in the
> > top-right corner.
> 
> Great. The assets that are used for about:addons should be reusable here, no?

Yes, should be reusable. I can work on a patch for that.
We're more likely to just remove this page entirely sometime. With synthetic apk's its getting close to being useless. But moving it to use a layout that is more like about:addons should be fairly simple (they already both inherit from a common style, about:apps just overrides a lot of it).
(In reply to :Margaret Leibovic from comment #8)

> But what should this look like? For about:apps, we put app icons in a grid
> in a white box that has rounded corners, not in a list like we do on
> about:addons. So adding a row at the bottom just like about:addons would
> look awkward... Or maybe we should try unifying the design of about:apps and
> about:addons? 

I think for the purposes of keeping things simple, I would start by removing the white background and rounded border, so that the apps look like they just sit on that pale blue background. Let me know if you need visuals to work from, or if that's enough to get started with.
Attached image WIP screenshot (obsolete) —
This is my attempt to turn the comment conversation into a patch... what do you think? I feel like the bar at the bottom looks kinda awkward, but I do like getting rid of that rounded white background.
Attachment #816849 - Flags: feedback?(ibarlow)
That's a little better, yeah. Maybe use a lighter background behind the icon, that matches the row below?

http://cl.ly/image/3y3n0G18111A
Attached image screenshot - no apps
Attachment #816849 - Attachment is obsolete: true
Attachment #816849 - Flags: feedback?(ibarlow)
Attached patch patchSplinter Review
wesj is on vacation, so I'll let mfinkle review this :)
Attachment #820512 - Flags: review?(mark.finkle)
Comment on attachment 820512 [details] [diff] [review]
patch

>diff --git a/mobile/android/locales/en-US/chrome/aboutApps.dtd b/mobile/android/locales/en-US/chrome/aboutApps.dtd

> <!-- LOCALIZATION NOTE (aboutApps.noApps.pre): include a trailing space as needed -->
> <!-- LOCALIZATION NOTE (aboutApps.noApps.middle): avoid leading/trailing spaces, this text is a link -->
> <!-- LOCALIZATION NOTE (aboutApps.noApps.post): include a starting space as needed -->
>-<!ENTITY aboutApps.noApps.pre "No web apps installed. Get some from the ">
>-<!ENTITY aboutApps.noApps.middle3 "Firefox Marketplace">
>-<!ENTITY aboutApps.noApps.post ".">

Looks like you can remove the LOCALIZATION NOTEs

r+ with nit
Attachment #820512 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/3e9c2f29f4ca
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Status: RESOLVED → VERIFIED
Depends on: 932694
You need to log in before you can comment on or make changes to this bug.