If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RR][ABS POS]inherited font styles lost on resize

VERIFIED FIXED in mozilla1.0

Status

()

Core
CSS Parsing and Computation
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: alex.dent, Assigned: dbaron)

Tracking

({css1, testcase})

Trunk
mozilla1.0
css1, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P1] [ruletree][CSS1-5.2.7])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
mozilla 20010627
see the testcase. the inherited font styles on the absolute and fixed positioned
disappear if an ancestors size is changed. it looses font-family on width
changes, and it looses font-family and (on the fixed div only) line-height as
well on height changes. the "normal" div is not affected by this. i have not
checked what else is affected under what circumstances.

and now the magic part: everything is layouted correctly after changing display
to none and then back to block.

sorry if this is a duplicate, i couldn't find any reference to this behaviour.
the problem did not exist in earlier mozillas.
(Reporter)

Comment 1

17 years ago
Created attachment 40418 [details]
testcase font.html
(Reporter)

Comment 2

17 years ago
is this maybe related to/a duplicate of bug 87485?
Bound to be some more fallout of the style landing
Assignee: jst → hyatt
Keywords: css1, mozilla0.9.2, mozilla0.9.3, nsbeta1, rtm, testcase
OS: Mac System 9.x → All
Hardware: Macintosh → All
Whiteboard: [Hixie-P1]
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Whiteboard: [Hixie-P1] → [Hixie-P1] [ruletree]

Updated

16 years ago
Blocks: 91672

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: mozilla0.9.2
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Blocks: 104166

Comment 4

16 years ago
->098
Target Milestone: mozilla1.0 → mozilla0.9.8

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.2
Whiteboard: [Hixie-P1] [ruletree] → [Hixie-P1] [ruletree][CSS1-5.2.7]
*** Bug 128076 has been marked as a duplicate of this bug. ***
This also shows up when changing themes, so it looks like a problem with
ReResolveStyleContext.  Marking [RR].
Summary: inherited font styles lost on resize → [RR]inherited font styles lost on resize
Component: DOM Style → Style System
Summary: [RR]inherited font styles lost on resize → [RR][ABS POS]inherited font styles lost on resize
This is fixed by the patch I'm about to attach to bug 129350.  I'm going to dupe
the other ReResolve-through-placeholder bugs against this one, but it's really a
separate issue from bug 129350 so I won't dupe this one against that.
Depends on: 129350
Taking.
Assignee: hyatt → dbaron
Status: ASSIGNED → NEW
Target Milestone: mozilla1.2alpha → mozilla1.0
*** Bug 113558 has been marked as a duplicate of this bug. ***
*** Bug 122346 has been marked as a duplicate of this bug. ***
*** Bug 124631 has been marked as a duplicate of this bug. ***
*** Bug 132953 has been marked as a duplicate of this bug. ***
*** Bug 122348 has been marked as a duplicate of this bug. ***
Fix checked in 2002-03-26 18:38 PST.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.