Update Firefox Branding

RESOLVED FIXED in Firefox 23

Status

()

Firefox
General
--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: shorlander, Assigned: shorlander)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {verifyme})

23 Branch
Firefox 24
verifyme
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 fixed, relnote-firefox 23+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 763760 [details] [diff] [review]
Update Firefox Branding - 01

This is mostly an image swap, however I did change a few things for retina displays:

- Unified the about:home and about dialog logos and changed the size
- Switched the wordmark with an SVG version of the most recent wordmark

Currently building this on Linux and Windows to test. Seems to work fine on OS X regular DPI and HiDPI, Snow Leopard through Mountain Lion.

Some of these bugs are confidential so marking for now. Can't keep it confidential once we check it in though :)
Attachment #763760 - Flags: review?(gavin.sharp)
(Assignee)

Comment 1

5 years ago
Oh, also cleaned up the disk image stuff. Lined up icons, wordmark and arrow, made it larger and updated the graphic. Tried to make it retina ready however we can't do that and have it work on Snow Leopard.
Comment on attachment 763760 [details] [diff] [review]
Update Firefox Branding - 01

Review of attachment 763760 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/aboutDialog.css
@@ +6,5 @@
>    width: 620px;
>  }
>  
>  #rightBox {
> +  background-image: url("chrome://branding/content/about-wordmark.svg");

You'll to add this file to Nightly + Aurora + Unofficial.

::: browser/base/content/abouthome/aboutHome.css
@@ +44,5 @@
>  #brandLogo {
> +  height: 192px;
> +  width: 192px;
> +  margin: 22px auto 31px;
> +  background-image: url("chrome://branding/content/about-logo.png");

If this file is changing size, can you update the other branding version of this file so they don't end up scaled funny? Ideally we should keep the various branding flavors as similar as possible.

@@ +361,5 @@
>   */
>  @media not all and (max-resolution: 1dppx) {
> +  #brandLogo {
> +    background-image: url("chrome://branding/content/about-logo@2x.png");
> +  }

Also need Nightly + Aurora + Unofficial versions of this new file, or there won't be any logo.
Attachment #763760 - Flags: review?(gavin.sharp) → review-
(Assignee)

Comment 3

5 years ago
Created attachment 763966 [details] [diff] [review]
Update Firefox Branding - 02

Added additional about-wordmark.svg files, about-logo@2x for all and made sizes consistent.
Attachment #763760 - Attachment is obsolete: true
Attachment #763966 - Flags: review?(dolske)
(Assignee)

Updated

5 years ago
Attachment #763966 - Attachment is patch: true
Attachment #763966 - Attachment mime type: text/x-patch → text/plain

Updated

5 years ago
Blocks: 884885
Attachment #763966 - Flags: review?(dolske) → review+
(Assignee)

Updated

5 years ago
Group: mozilla-corporation-confidential
(Assignee)

Comment 4

5 years ago
Comment on attachment 763966 [details] [diff] [review]
Update Firefox Branding - 02

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Updating Firefox Icons across properties, also fixes low-res icons on retina screens
User impact if declined: Will have outdated icons
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk, mostly image swaps some CSS tweaks
String or IDL/UUID changes made by this patch:
Attachment #763966 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Duplicate of this bug: 734133

Updated

5 years ago
Blocks: 881290
Attachment #763966 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
Created attachment 766163 [details]
Update Firefox Branding - 03

Removed the Firefox® from about-wordmark.svg Will handle that in bug 833943
https://hg.mozilla.org/mozilla-central/rev/f0d1677cc3e8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
Hi,

out of sheer curiosity: what's the reason for the new/improved Firefox logo? Is there an announcement or a newsgroup discussion or anything else you can point me?

Thanks!
https://hg.mozilla.org/releases/mozilla-aurora/rev/ebfdc93638dd
status-firefox23: --- → fixed
Target Milestone: Firefox 23 → Firefox 24

Updated

5 years ago
relnote-firefox: --- → ?
relnote-firefox: ? → 23+
(Assignee)

Comment 11

5 years ago
(In reply to Sören Hentzschel from comment #9)
> Hi,
> 
> out of sheer curiosity: what's the reason for the new/improved Firefox logo?
> Is there an announcement or a newsgroup discussion or anything else you can
> point me?
> 
> Thanks!

http://blog.seanmartell.com/2013/06/27/rebuilding-a-simplified-firefox-logo/
Depends on: 891353
Keywords: verifyme

Updated

5 years ago
Depends on: 901292

Updated

5 years ago
Depends on: 904454
You need to log in before you can comment on or make changes to this bug.