Closed Bug 889417 Opened 8 years ago Closed 8 years ago

New Firefox icon on taskbar/launchpad is smaller than both old icon and the other browsers' icon

Categories

(Firefox :: General, defect)

23 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 25
Tracking Status
firefox23 + verified
firefox24 + fixed
firefox25 + fixed

People

(Reporter: masayuki, Assigned: shorlander)

References

(Depends on 1 open bug)

Details

(Keywords: verifyme)

Attachments

(4 files)

The new Firefox icon on the Windows taskbar is smaller than the old icon and the other browsers' icon. I'm not sure if this is intentional, though.

I think that the new icon should be a little bit larger than current Beta's icon because the color became lighter. So, the contrast between the icon and taskbar may become lower. Therefore, perhaps, larger icon might look better.
Steven: should we make the logo bigger?
Flags: needinfo?(shorlander)
This is not Windows specific, I see a smaller-than-our-old-logo on Mac too.
OS: Windows 8 → All
Hardware: x86_64 → All
Summary: New Firefox icon on taskbar on Windows is smaller than both old icon and the other browsers' icon → New Firefox icon on taskbar/launchpad is smaller than both old icon and the other browsers' icon
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Justin Dolske [:Dolske] from comment #2)
> Steven: should we make the logo bigger?

The logo should always be bigger.

Beta patch for just the Official branding.
Flags: needinfo?(shorlander)
Attachment #778663 - Flags: review?(dolske) → review+
Attachment #778664 - Flags: review?(dolske) → review+
Comment on attachment 778663 [details] [diff] [review]
Make the Firefox 32 x 32 icon fill more space

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 884011
User impact if declined: Smaller visual target on Taskbar
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk icon swap. Alternative is just ship a slightly smaller icon for one release.
String or IDL/UUID changes made by this patch:
Attachment #778663 - Flags: approval-mozilla-beta?
Comment on attachment 778663 [details] [diff] [review]
Make the Firefox 32 x 32 icon fill more space

Approved for Beta, let's get this fixed asap.  Also need this on other branches too so please land to central and nominate for Aurora.
Attachment #778663 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 778664 [details] [diff] [review]
Make all Branding 32 x 32 icons fill more space

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 884011
User impact if declined: Smaller visual target on Taskbar
Risk to taking this patch (and alternatives if risky): Low risk icon swap. Alternative is just ship a slightly smaller icon for one release.
Attachment #778664 - Flags: approval-mozilla-aurora?
Attachment #778664 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assignee: nobody → shorlander
Verified as fixed on Firefox 23 Beta 10 (build ID: 20130729175331)

User Agents:
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
https://hg.mozilla.org/mozilla-central/rev/c2dc8dbb77ef
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Depends on: 901565
The 16x16 icon is still one pixel shorter than the old icon, and you can see the difference in comparison to the other icons in the taskbar.
http://i.imgur.com/0qF6dy7.png
left 23, right 22, enlarged to 1500%
Depends on: 904454
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0

As per comment 13, I also confirm that the Firefox icon is still shorter: http://oi44.tinypic.com/k00qvk.jpg. Is this intended? 
If yes, I confirm the fix on Firefox 24 beta 7 (Build ID: 20130829135643).
Flags: needinfo?
Flags: needinfo?
Can anyone please answer my question in comment 14 ?
Flags: needinfo?
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #15)
> Can anyone please answer my question in comment 14 ?

Needinfo requests that don't have a specific requestee will be ignored. You need to always set a requestee.

Stephen can correct me if I'm wrong, but I don't think the height difference in comment 14 matters.
Flags: needinfo?
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #16)

> Needinfo requests that don't have a specific requestee will be ignored. You
> need to always set a requestee.
Sorry, will do.

> Stephen can correct me if I'm wrong, but I don't think the height difference
> in comment 14 matters.
Stephen, what's your opinion?
Flags: needinfo?(shorlander)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #17)
> > Stephen can correct me if I'm wrong, but I don't think the height difference
> > in comment 14 matters.
> Stephen, what's your opinion?

I think we are currently fine here.
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.