Last Comment Bug 884122 - Fireplace login is broken for desktop users
: Fireplace login is broken for desktop users
Status: RESOLVED DUPLICATE of bug 873228
:
Product: Marketplace
Classification: Server Software
Component: Consumer Pages (show other bugs)
: 1.0
: x86 Mac OS X
: P1 normal (vote)
: 2013-06-20
Assigned To: Kumar McMillan [:kumar] (needinfo all the things)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 16:50 PDT by Kumar McMillan [:kumar] (needinfo all the things)
Modified: 2013-06-17 16:53 PDT (History)
0 users
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Kumar McMillan [:kumar] (needinfo all the things) 2013-06-17 16:50:53 PDT
Persona deployed a change today that acknowledged experimental flags. Our code has a bug in it that passed these to the UI on desktop:

experimental_allowUnverified
experimental_forceIssuer

The bug was never triggered until today so logins broke on desktop in all environments: dev, stage, prod, and local development
Comment 1 Kumar McMillan [:kumar] (needinfo all the things) 2013-06-17 16:51:50 PDT
Fixed https://github.com/mozilla/fireplace/commit/415e3f1fc18bc7ce2487cac43e521503f3e107c5

This was originally intended for bug 873228 so I cherry picked the part we need. Hot fix is going to prod right now.
Comment 2 Kumar McMillan [:kumar] (needinfo all the things) 2013-06-17 16:53:19 PDT
oops, ignore everything, nothing to see!

*** This bug has been marked as a duplicate of bug 873228 ***

Note You need to log in before you can comment on or make changes to this bug.