Bug 887834 (apkshrink)

Fennec APK is too big

RESOLVED DUPLICATE of bug 942609

Status

()

RESOLVED DUPLICATE of bug 942609
5 years ago
2 years ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I had some fennec APKs lying around on my machine and observed that Fennec 14 was almost half the size of a recent try build:

  15467012  5 Jun 14:24 fennec-14.0.en-US.android-arm.apk
  16743439  5 Jun 14:24 fennec-15.0.en-US.android-arm.apk
  17399441  5 Jun 14:24 fennec-16.0.en-US.android-arm.apk
  17843917  5 Jun 14:24 fennec-17.0.en-US.android-arm.apk
  17993500  5 Jun 14:21 fennec-18.0.en-US.android-arm.apk
  18299156  5 Jun 14:20 fennec-19.0.en-US.android-arm.apk
  18282506  5 Jun 14:19 fennec-20.0.en-US.android-arm.apk
  21219787  5 Jun 14:33 fennec-21.0.en-US.android-arm.apk
  21737974 10 Jun 17:34 fennec-22.0b4.en-US.android-arm.apk
  30811174 27 Jun 11:20 fennec-25.0a1.en-US.android-arm.apk

This is pretty bad.
Also:

  21738703 27 Jun 11:26 fennec-22.0.en-US.android-arm.apk
  27288665 27 Jun 11:36 fennec-23-latest-beta.en-US.android-arm.apk
  30823478 27 Jun 11:39 fennec-24.0a2.en-US.android-arm.apk

Unzipping the 22 and 23 APKs shows that libxul went from 22348744 in the fennec-22 APK to 47072268 in the fennec-23 APK, that's more than double. Somebody's got some explainin' to do.

The regression should be bisectable by looking at the APK sizes on ftp.
I thought we (qa) had filed a bug about the Fonts causing a 3-5 MB file size increase but I cannot find it.
Depends on: 760653
Duplicate of this bug: 890413
* Comment 1 was found to be INVALID in bug 888012
* Fonts are still an issue. We want them where we can support it, but maybe we should remove them from ARMv6 builds?
* Hyphenation files are sizable too, and might be worth removing on ARMv6 builds too
* Can we remove layouts and assets that are not used in ARMv6 builds?
  * Do we need XHDPI and XXHDPI?
  * Do we need tablet assets?
(In reply to Mark Finkle (:mfinkle) from comment #4)
> * Comment 1 was found to be INVALID in bug 888012
> * Fonts are still an issue. We want them where we can support it, but maybe
> we should remove them from ARMv6 builds?
> * Hyphenation files are sizable too, and might be worth removing on ARMv6
> builds too
> * Can we remove layouts and assets that are not used in ARMv6 builds?
>   * Do we need XHDPI and XXHDPI?
>   * Do we need tablet assets?
there are ARMv6 tablets

But I'd also like us not to focus solely on ARMv6. Perhaps these non-essential thins (the fonts especially) could be uploaded to google play as OBB files, and then not requested if we're on device with limited memory.

http://developer.android.com/google/play/expansion-files.html
I think we can dupe this as a 'yes we know' issue to our known fatfennec project.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942609
You need to log in before you can comment on or make changes to this bug.