If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Nefzaoui, Assigned: Nefzaoui)

Tracking

(Blocks: 1 bug)

unspecified
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [rtl-meta])

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130630 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130630031138

Steps to reproduce:

When using an RTL language, Time stamp is messed up and being shown in the same area of the notification text. Patch fixing it.
(Assignee)

Comment 1

4 years ago
Created attachment 769582 [details]
RTL Patch
(Assignee)

Comment 2

4 years ago
Damn.. Still can't make a working redirecting page in bugzilla..
Blocks: 906270

Updated

4 years ago
Attachment #769582 - Attachment mime type: text/plain → text/html

Comment 3

4 years ago
Comment on attachment 769582 [details]
RTL Patch

Per chat in irc, marking this obsolete, the PR has also been closed a while ago.
Attachment #769582 - Attachment is obsolete: true
Ugh, I’m afraid I hadn’t seen this patch in time. :-/

As the problem seems to persist, a new PR would be nice to see. Please make sure to use the r? flag this time.
Confirming with Boot2Gecko 1.5.0.0-prerelease 20140407024544 on Geeksphone Keon
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

3 years ago
Ahmed, can you resubmit another patch per comment #4? I am trying to get a long list of RTL fixes in line for 2.1 and it would be great if this could be on it. Thanks!
Flags: needinfo?(nefzaoui.ahmed)
(Assignee)

Comment 7

3 years ago
Sure :)
Assignee: nobody → nefzaoui.ahmed
Flags: needinfo?(nefzaoui.ahmed)
(Assignee)

Comment 8

3 years ago
Created attachment 8441953 [details] [review]
PR to Github

This one solves all about notifications issues (even in lockscreen, since they all share the same file; notifications.css) in RTL mode, though still don't know who to ask for a r?
Stephany, little help?
Thanks :)

Comment 9

3 years ago
Comment on attachment 8441953 [details] [review]
PR to Github

Flagging Fernando on review? and Rob on ui-review?. Please reassign to other reviewers if necessary/as appropriate.
Attachment #8441953 - Flags: ui-review?(rmacdonald)
Attachment #8441953 - Flags: review?(ferjmoreno)

Comment 10

3 years ago
Comment on attachment 8441953 [details] [review]
PR to Github

I am probably not the best reviewer for this change :).
Attachment #8441953 - Flags: review?(ferjmoreno) → review?(timdream)
Comment on attachment 8441953 [details] [review]
PR to Github

Francis, can you review this while I'm out tomorrow?
Attachment #8441953 - Flags: ui-review?(rmacdonald) → ui-review?(fdjabri)
Flags: needinfo?(fdjabri)
Attachment #8441953 - Flags: review?(timdream) → review?(etienne)
Comment on attachment 8441953 [details] [review]
PR to Github

Looking good! r=me with the 2 small comments on github addressed.

I took some screenshot I'll attach them for ui-review.
Attachment #8441953 - Flags: ui-review?(fdjabri)
Attachment #8441953 - Flags: review?(etienne)
Attachment #8441953 - Flags: review+
Created attachment 8442806 [details]
Screenshot - in tray
Attachment #8442806 - Flags: ui-review?(fdjabri)
Created attachment 8442809 [details]
Screenshot - on lockscreen
Attachment #8442809 - Flags: ui-review?(fdjabri)
This seems ok to me. However, on the lockscreen, it seems as if the text "لآن" is being cut off at the bottom.  

Also, I'm not sure if this is in the scope of this bug, but on the lockscreen it seem strange that the time and date are off-center and not right aligned with everything else. 

Finally, I'm a little confused as to why Western numerals are being used instead of Arabic ones in the utility tray notification time stamp. I speak a little Arabic but I'm no localization expert, so I'm not sure if this would be strange for an Arabic speaker.
Flags: needinfo?(fdjabri)
Comment on attachment 8442809 [details]
Screenshot - on lockscreen

It seems as if the text "لآن" It seems as if the text "لآن" is is being cut off at the bottom.  

Also, I'm not sure if this is in the scope of this bug, but on the lockscreen it seem strange that the time and date are off-center and not right aligned with everything else.
Attachment #8442809 - Flags: ui-review?(fdjabri) → ui-review-
Comment on attachment 8442806 [details]
Screenshot - in tray

This seems ok to me but I'm a little confused as to why Western numerals are being used instead of Arabic ones in the utility tray notification time stamp. I speak a little Arabic but I'm no localization expert, so I'm not sure if this would be strange for an Arabic speaker. From a UI perspective though this seems ok.
Attachment #8442806 - Flags: ui-review?(fdjabri) → ui-review+
(Assignee)

Comment 18

3 years ago
(In reply to Etienne Segonzac (:etienne) from comment #12)
> Comment on attachment 8441953 [details] [review]
> PR to Github
> 
> Looking good! r=me with the 2 small comments on github addressed.
> 
> I took some screenshot I'll attach them for ui-review.

Addressed. :)

(In reply to Francis Djabri [:djabber] from comment #17)
> Comment on attachment 8442806 [details]
> Screenshot - in tray
> 
> This seems ok to me but I'm a little confused as to why Western numerals are
> being used instead of Arabic ones in the utility tray notification time
> stamp. I speak a little Arabic but I'm no localization expert, so I'm not
> sure if this would be strange for an Arabic speaker. From a UI perspective
> though this seems ok.

AFAIK there are no plans until now to make region-specific builds or such changes.. I've suggested making this. However Not all the countries in the MENA region use arabic numerals. I've put down a pad* detailing all this + some suggestions for the future of Firefox OS.

(*) https://etherpad.mozilla.org/RTL-UX

And Etienne, may you please merge that for me if everything's good? I can't do it on my own.. :)

Thanks!
Flags: needinfo?(etienne)
https://github.com/mozilla-b2g/gaia/commit/41cc1de26e4edbe12add0009cdc0bd292f2e94fe

Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(etienne)
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1010471

Comment 21

3 years ago
Thank you, Etienne! Hope this rides the train to release now.
This issue is verified fixed on Flame 2.1 and 2.2.

Result: The notification text truncates in RTL language, and the timestamps are displayed properly without overlapping issues.

Device: Flame 2.1 (319mb, KK, Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Full Flash)
BuildID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → verified
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Mass Edit: adding the [rtl-meta]
Whiteboard: [rtl-meta]

Comment 24

3 years ago
Sorry, Peter - what's the [rtl-meta] for? Thanks!
Stephany, the [rtl-meta] tag is being added to bugs for better tracking
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15574/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.