ICO as image doesn't pick the best resolution

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
--
enhancement
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: Greg Edwards, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 769589 [details]
Shows the issue alongside a mockup of how it ought to work

When using an ICO as an image (img tag or CSS background), 16x16 is always assumed unless a media fragment is appended to the URL. (See Bug 419588 for details.)

Ideally, Firefox should be able to autodetect the best resolution to use based on the image size and the DPI scale of the device.

This especially has benefits to Firefox themes where (fav)icons are used.
(Reporter)

Updated

4 years ago
Depends on: 419588

Comment 1

4 years ago
Confirmed on Nightly 28.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 25 Branch → Trunk
(Reporter)

Comment 2

4 years ago
Please note that Bug 972134 (when implemented) will break my testcase.
Depends on: 977459
Duplicate of this bug: 1007078
Hi Greg, is this still an issue for you after the improvements in bug 977459 and related bugs?
Flags: needinfo?(edwardsgreg)
(Reporter)

Comment 5

a year ago
I ran my testcase and it does appear to be fixed. Nice work!
Flags: needinfo?(edwardsgreg)
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Depends on: 1201796
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.