Last Comment Bug 889484 - Permanent Orange: TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed (content-tabs/test-plugin-blocked.js)
: Permanent Orange: TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpe...
Status: RESOLVED FIXED
: intermittent-failure, regression
Product: Thunderbird
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 25.0
Assigned To: Mark Banner (:standard8)
:
:
Mentors:
Depends on: 882339
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 11:18 PDT by Mark Banner (:standard8)
Modified: 2013-08-16 16:32 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
The fix (2.08 KB, patch)
2013-07-02 11:21 PDT, Mark Banner (:standard8)
acelists: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2013-07-02 11:18:59 PDT
We're currently seeing this, which I've tracked down as being caused by bug 882339:

https://tbpl.mozilla.org/php/getParsedLog.php?id=24827942&tree=Thunderbird-Trunk

TEST-START | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-blocked.js | test_blocklisted_plugin_notification
Timeout: bridge.execFunction("3069ba0e-e30d-11e2-895f-34159e18d332", bridge.registry["{1d806bea-7ea6-404a-8993-8a6ae4abcb3d}"]["runTestDirectory"], ["/home/cltbld/talos-slave/test/build/mozmill/content-tabs"])

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed
Comment 1 Mark Banner (:standard8) 2013-07-02 11:21:45 PDT
Created attachment 770301 [details] [diff] [review]
The fix

This is a test-only fix, that ports the relevant change from https://hg.mozilla.org/mozilla-central/rev/4fb8fa8668c5

It has cleared the failures on try server:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=da4f0924a59b

Note, tryserver has a failure about "test-plugin-outdated.js" on Mac 10.6, but I think that's unrelated possible random orange. I've triggered a couple more builds for that, but I suspect that's a different bug as this bug covers all platforms.
Comment 2 :aceman 2013-07-02 11:58:50 PDT
Comment on attachment 770301 [details] [diff] [review]
The fix

Review of attachment 770301 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this does solve the problem for me locally on linux.
Comment 3 Mark Banner (:standard8) 2013-07-02 12:25:20 PDT
https://hg.mozilla.org/comm-central/rev/4fb6a496ca3f
Comment 4 Mark Banner (:standard8) 2013-07-03 00:37:51 PDT
Comment on attachment 770301 [details] [diff] [review]
The fix

[Triage Comment]
Ok, taking this onto Aurora. Although there's potentially bug 889745, I don't think that was directly caused by this bug (I suspect it may have been hidden due to this issue), and it is Mac only. It also gives a much more readable failure on tbpl, so its an improvement.
Comment 5 Mark Banner (:standard8) 2013-07-03 00:40:20 PDT
https://hg.mozilla.org/releases/comm-aurora/rev/d8edf862ddae
Comment 6 Treeherder Robot 2013-08-16 16:32:57 PDT
Neil
https://tbpl.mozilla.org/php/getParsedLog.php?id=26639289&tree=Thunderbird-Trunk
TB Rev3 Fedora 12x64 comm-central opt test mozmill on 2013-08-16 07:54:00
revision: e99c2bc2eda1
slave: talos-r3-fed64-053

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed
OSError: [Errno 2] No such file or directory
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run

Note You need to log in before you can comment on or make changes to this bug.