Closed Bug 889882 Opened 7 years ago Closed 7 years ago

Mail compose window on a reply will not allow change of To, CC, etc, nor entry of text

Categories

(SeaMonkey :: MailNews: Composition, defect)

defect
Not set

Tracking

(seamonkey2.21 fixed)

RESOLVED DUPLICATE of bug 881588
Tracking Status
seamonkey2.21 --- fixed

People

(Reporter: base12, Unassigned)

References

Details

(Whiteboard: [workaround: comment #4])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0 SeaMonkey/2.22a1 (Beta/Release)
Build ID: 20130702003001

Steps to reproduce:

1) Open an e-mail
2) Click Reply or Reply All button
3) Try to edit (delete, add, change) any of the recipients (To, CC, BCC), which are greyed out, incidentally
4) Try to add text into body of e-mail


Actual results:

I'm unable to make any changes to recipients. Sometimes I'm unable to add text to the body of the e-mail.

I restarted SM in safe mode in case an extension was causing the problem. After restarting, the problem didn't appear with the first reply, but the second and later replies showed the problem again. The Error Console shows this.

Timestamp: 7/3/2013 11:28:58 AM
Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIInlineSpellChecker.ignoreWords]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2081


Expected results:

I should have been able to change the recipients and edit the body of the e-mail.
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Version: SeaMonkey 2.22 Branch → Trunk
xref Thunderbird bug 671530 or (more recent) bug 881588.
The mail header become editable only if you open a second time the message via reply or reply to all.
Then it is possible to edit the to/cc/bcc and the subjet.
The second message window has not the (no subjet)  title too.
Does setting mail.compose.max_recycled_windows to 0 in about:config fix the issue?
Yes it does !
it works for me (SM nightly 20130704).
Ok, so that's probably the SeaMonkey version of bug 881588, given the reference to the spell-checker issue in the opening description.
Whiteboard: [workaround: comment #4]
See Also: → 881588
Duplicate of this bug: 890988
SeaMonkey 2.21 should be affected as well as Bug 881588 was filed against TB 24.
So this bug here has now been fixed by Bug 881588?
Flags: needinfo?(base12)
Whiteboard: [workaround: comment #4] → [workaround: comment #4][closeme INCO 2013-09-01]
I'm no longer seeing the bug. Currently using

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1
Build identifier: 20130811003001
Thanks for confirming, marking as duplicate of the Thunderbird bug fixing both.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(base12)
Resolution: --- → DUPLICATE
Whiteboard: [workaround: comment #4][closeme INCO 2013-09-01] → [workaround: comment #4]
Duplicate of bug: 881588
You need to log in before you can comment on or make changes to this bug.