Last Comment Bug 881588 - message header is read-only when compose window is reused
: message header is read-only when compose window is reused
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: Trunk
: All All
: -- major with 3 votes (vote)
: Thunderbird 25.0
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
: 887323 887458 889882 890603 896191 897644 (view as bug list)
Depends on: 880595 887010
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 19:28 PDT by Jonathan Kamens
Modified: 2013-08-11 10:06 PDT (History)
27 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
unaffected
+
fixed
fixed


Attachments
Proposed patch (2.76 KB, patch)
2013-07-18 13:52 PDT, neil@parkwaycc.co.uk
standard8: review-
Details | Diff | Review
Alternative approaches (4.44 KB, patch)
2013-07-22 03:13 PDT, neil@parkwaycc.co.uk
standard8: feedback+
Details | Diff | Review
Alternative patch (2.91 KB, patch)
2013-07-25 11:38 PDT, neil@parkwaycc.co.uk
standard8: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Jonathan Kamens 2013-06-10 19:28:48 PDT
With current trunk, just pulled and rebuilt less than an hour ago, if I reply to a message and then reply to another message, thus reusing the compose window from the previous reply, then the message header (addresses, subject) is read-only in the second reply.
Comment 1 WADA 2013-06-11 02:04:46 PDT
Confirmed in Tb/24.0a1 (Application Build ID : 20130610030658) on Win-XP.
- if mail.compose.max_recycled_windows=0, no problem.
- Reply/Reply All only problem. No problem in new mail, forward.
- When problem occurred, "Shift+Reply" + "immediate window close"
  + "Reply/Replay All again" (open/close with different mode once)
  is a simple recovery procedure.
Comment 2 Magnus Melin 2013-06-12 13:27:52 PDT
Possibly due to bug 880595 - at least i don't see it with spellchecking diabled, and see it when it's on.
Comment 3 Ludovic Hirlimann [:Usul] 2013-06-12 23:11:41 PDT
(In reply to Magnus Melin from comment #2)
> Possibly due to bug 880595 - at least i don't see it with spellchecking
> diabled, and see it when it's on.

Same time frame for the regression - making bug depedant.
Comment 4 gene c 2013-06-16 11:37:30 PDT
I confirm turning spell check off so far has made the problem go away. It was pretty bad - sometimes the 'send' button was not clickable even.
Comment 5 Patrick Brunschwig 2013-06-26 09:45:56 PDT
*** Bug 887323 has been marked as a duplicate of this bug. ***
Comment 6 Joe Sabash [:JoeS1] 2013-06-26 18:33:32 PDT
*** Bug 887458 has been marked as a duplicate of this bug. ***
Comment 7 Mike Cloaked 2013-06-27 02:07:36 PDT
Confirm the comment from Gene C - including the "Send" button being greyed out.
Comment 8 Mike Cloaked 2013-07-03 12:42:01 PDT
The comment #4 at https://bugzilla.mozilla.org/show_bug.cgi?id=880595 will hopefully mean that this associated bug will be closed at the same time when and if the patch referred to is confirmed to fix this problem?
Comment 9 Joe Sabash [:JoeS1] 2013-07-06 09:27:51 PDT
*** Bug 890603 has been marked as a duplicate of this bug. ***
Comment 10 Mitra Ardron 2013-07-07 06:08:45 PDT
COnfirming - I'm seeing this pretty much continually, (Reported in duplicate Bug#890603) and Send is always disabled which makes it impossible to reply. 

For anyone caught by it ... the work around is 
Reply - get unusable window, but you won't notice till you look for Send.
Copy the message you just typed
Go back to message - 
hit Reply again - get usable window
Past message into it.
Hit Send
Close orginal window without saving Draft. 

You have to do it in this order or mostly it just reuses the screwed up window again. 

If someone wants help tracking it let me know - otherwise I'm going to have to do a reinstall to see if that makes it go away.
Comment 11 rsx11m 2013-07-07 15:54:17 PDT
Reinstallation won't help. Go into the Config Editor (that's in the Options or Preferences menu item in the [≡] application button on the right-hand side of the main toolbar, then the Advanced > General tab, click Config Editor there).

Per comment #1, enter or copy-paste mail.compose.max_recycled_windows into the search bar and double-click on the entry that remains to change it to 0.
Comment 12 Jason Merrill 2013-07-08 09:17:43 PDT
I'm seeing the Send problem even with max_recycled_windows at 0.  The way I work around it is to save and close the draft, then go to my Drafts mailbox, open the message again, and send it.
Comment 13 Wayne Mery (:wsmwk, NI for questions) 2013-07-18 08:32:51 PDT
max_recycled_windows at 0 resolves it so far for me.
Is it known yet whether  attachment 773324 [details] [diff] [review] of bug 880595 resolves this?
Comment 14 neil@parkwaycc.co.uk 2013-07-18 13:52:13 PDT
Created attachment 778041 [details] [diff] [review]
Proposed patch

Since I couldn't work out how bug 887010 was going to help us, I took a different approach. Note: I tested the code in SeaMonkey and then ported it without testing on Thunderbird. Thus this patch also fixes bug 889882.
Comment 15 Joe Sabash [:JoeS1] 2013-07-18 19:28:58 PDT
Tested on a local build:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Thunderbird/25.0a1 ID:20130718210143 CSet: d7237cd27263 
Built from http://hg.mozilla.org/mozilla-central/rev/0d0263a58f06
After importing this patch, it seemed to take care of the message header greyed out problem, but the inline spellcheck problem is still there when
mail.compose.max_recycled_windows=1
(but maybe this patch wasn't intended to address that issue)
Comment 16 neil@parkwaycc.co.uk 2013-07-19 01:47:45 PDT
(In reply to Joe Sabash from comment #15)
> the inline spellcheck problem is still there when
> mail.compose.max_recycled_windows=1
> (but maybe this patch wasn't intended to address that issue)

That's attachment 773324 [details] [diff] [review] in bug 880595.
Comment 17 neil@parkwaycc.co.uk 2013-07-22 03:13:02 PDT
Created attachment 779118 [details] [diff] [review]
Alternative approaches

This demonstrates two alternative uses of the spellCheckPending property although I haven't actually tested this version yet.
Comment 18 Mark Banner (:standard8) 2013-07-25 08:48:01 PDT
Comment on attachment 779118 [details] [diff] [review]
Alternative approaches

Review of attachment 779118 [details] [diff] [review]:
-----------------------------------------------------------------

I think I prefer this version best. It seems more deterministic.

::: mail/components/compose/content/MsgComposeCommands.js
@@ +3145,5 @@
>    if (gSpellChecker.enabled)
>    {
> +    if (gSpellChecker.mInlineSpellChecker.spellCheckPending)
> +    {
> +      setTimeout(addRecipientsToIgnoreList, 100, aAdressesToAdd);

I think I'd prefer this to use the observer method as you have done further down.
Comment 19 rsx11m 2013-07-25 08:51:54 PDT
*** Bug 897644 has been marked as a duplicate of this bug. ***
Comment 20 neil@parkwaycc.co.uk 2013-07-25 11:38:34 PDT
Created attachment 781120 [details] [diff] [review]
Alternative patch
Comment 21 Mark Banner (:standard8) 2013-07-25 13:49:30 PDT
Comment on attachment 781120 [details] [diff] [review]
Alternative patch

Review of attachment 781120 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r+a=me for the CLOSED TREE and for aurora.

Thanks.
Comment 22 neil@parkwaycc.co.uk 2013-07-25 15:30:25 PDT
Pushed comm-central changeset 55edd6e9957e.
Pushed comm-aurora changeset d4eb28c60ab5, but I typo'd the bug#. Oops!
Comment 23 Thomas D. (currently busy elsewhere; needinfo?me) 2013-07-27 07:15:46 PDT
*** Bug 896191 has been marked as a duplicate of this bug. ***
Comment 24 rsx11m 2013-08-11 10:06:37 PDT
*** Bug 889882 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.