Closed Bug 890218 Opened 6 years ago Closed 6 years ago

[MMS] If reboot device while downloading MMS attachment, the message will be empty and will not be deleted anymore.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
firefox23 --- wontfix
firefox24 --- wontfix
firefox25 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: echu, Assigned: ctai)

References

Details

(Whiteboard: [u=commsapps-user c=messaging p=0])

Attachments

(5 files, 2 obsolete files)

Please check attached video, this exception case is trying to reboot device when mms attachment is being downloaded, the message will be empty even receiving new one, and it cannot be deleted unless reset device.

* Build Number (Both Gecko and Gaia)                 
Gaia:     1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
  B-D     2013-06-25 17:04:16
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
BuildID   20130625070217
Version   18.0

* Reproduce Steps
1. Set mms auto-retrieve to off
2. Send a mms to device
3. Press download button of the message then reboot device while download is still ongoing.

* Expected Result
The message can be downloaded again.

* Actual Result
No way to download the message and unable to delete the message as well.
Attached video video
Attached file logcat before reboot
Attached file logcat after reboot
Gene, could you take a look here? Thanks!!!
Flags: needinfo?(gene.lian)
Assignee: nobody → gene.lian
Blocks: b2g-mms
blocking-b2g: --- → leo?
Flags: needinfo?(gene.lian)
I cannot reproduce this bug. Every time I restart the FFOS (via long-pushing the power button and tap the "Restart") during downloading, all the MMS files can be successfully downloaded and displayed after rebooting.

Hi Eric, do you have a more stable set of steps to reproduce this bug? Thanks!
Hi Gene,

I had reproduced the issue for 3 times, so at this moment I assume it's 100% reproducible, but yes I didn't reproduce it more than the 3 times. All I did is after press download button, before attachment is downloaded, I long press power key and select reboot item to restart device.

Anything I can do(ex: filming steps, capturing extra log) to assist debugging procedure?

Enpei
Thanks for the reply. No bother. :) I think I'll try to download bigger pictures or add some hard codes to reproduce this. I'll let you know if it's still not working for me.
Sure, let me know anything I can help.

Enpei
Pretty nasty bug, blocking for sure since we need messages to be deletable and re-downloadable if interrupted.
blocking-b2g: leo? → leo+
Whiteboard: [u=commsapps-user c=messaging p=0]
Hi Vicamo and Chia-hung, do you have time to support this? I'm occupied with other bugs. Please feel free to take this over from me. Thanks!
I can take it.
Assignee: gene.lian → ctai
Duplicate of this bug: 882642
Flags: in-testsuite?
Flags: in-testsuite? → in-moztrap?
Attached patch Patch v1.0 (obsolete) — Splinter Review
Attachment #773160 - Flags: review?(gene.lian)
Depends on: 891785
Comment on attachment 773160 [details] [diff] [review]
Patch v1.0

Review of attachment 773160 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/mobilemessage/src/gonk/MobileMessageDatabaseService.js
@@ +779,5 @@
>            let part = parts[i];
>            if (DEBUG) {
>              debug("MMS: part[" + i + "]: " + JSON.stringify(part));
>            }
> +          if (!part) {

Could you please add one comment before this condition? Thanks!

// Sometimes the part is incomplete because the device reboots when
// downloading MMS. Don't need to expose this part to the content.
Attachment #773160 - Flags: review?(gene.lian) → review+
Attached patch Patch v1.1Splinter Review
Attachment #773160 - Attachment is obsolete: true
Priority: -- → P1
Target Milestone: --- → 1.1 QE5
This issue also appears to happen if the SMS app gets killed. Is there an ETA of when this patch will be landed? I've run in to this issue again and I don't want to have to reset my phone.
Target Milestone: 1.1 QE5 → 1.1 QE4 (15jul)
Attached patch b2g18-Patch1.0 (obsolete) — Splinter Review
Attached patch b2g18-Patch1.0Splinter Review
Attachment #775404 - Attachment is obsolete: true
Patch for uplift to b2g18 branch.
(In reply to Chia-hung Tai [:ctai :ctai_mozilla :cht] from comment #18)
> Created attachment 775405 [details] [diff] [review]
> b2g18-Patch1.0
https://hg.mozilla.org/mozilla-central/rev/9cd23670d3a3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: in-moztrap?
Hi Ryan,

I can still reproduce the issue with following steps, yet the failure rate is lower(no logcat logging, from 3/3 to 1/5. It's hard to reproduce while logging)

Gaia:     f1d2e3fd806dc55f167c72ac8ef7a3b6baed915e
  B-D     2013-07-18 03:52:52
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/d38580e20aa2
BuildID   20130716230202
Version   18.1

Is the patch already in this build?

Enpei
Blocks: 897893
Duplicate of this bug: 897893
You need to log in before you can comment on or make changes to this bug.