Closed Bug 890272 Opened 6 years ago Closed 6 years ago

crash in SkScalerContext::MakeRec

Categories

(Core :: Graphics, defect, critical)

25 Branch
All
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla25
Tracking Status
firefox24 --- unaffected
firefox25 + verified
fennec 25+ ---

People

(Reporter: u421692, Assigned: gw280)

References

()

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7b04972b-4721-4285-8324-77ac52130704 .
 ============================================================= 
Environment:
Samsung Galaxy Tab(Android 4.0.4)/LG Nexus 4(Android 4.2.2)
Firefox 25.0a1 (2013-07-04)

Steps to reproduce:
1. Play any type of flash content.

Expected result:
Flash content is played without any issues.

Actual result:
Flash content never starts playing, Firefox crashes.

https://crash-stats.mozilla.com/report/index/7b04972b-4721-4285-8324-77ac52130704

Crashing Thread
Frame 	Module 	Signature 	Source
0 	libxul.so 	SkScalerContext::MakeRec(SkPaint const&, SkDeviceProperties const*, SkMatrix const*, SkScalerContextRec*) 	/builds/slave/m-in-and-000000000000000000000/build/obj-firefox/gfx/skia/../../../gfx/skia/include/core/SkTypeface.h
1 	libxul.so 	SkPaint::descriptorProc(SkDeviceProperties const*, SkMatrix const*, void (*)(SkTypeface*, SkDescriptor const*, void*), void*, bool) const 	/builds/slave/m-in-and-000000000000000000000/build/obj-firefox/gfx/skia/../../../gfx/skia/src/core/SkPaint.cpp
2 	libxul.so 	SkPaint::getFontMetrics(SkPaint::FontMetrics*, float) const 	/builds/slave/m-in-and-000000000000000000000/build/obj-firefox/gfx/skia/../../../gfx/skia/src/core/SkPaint.cpp
3 	libxul.so 	anp_getFontMetrics 	/builds/slave/m-in-and-000000000000000000000/build/obj-firefox/other-licenses/skia-npapi/../../../other-licenses/skia-npapi/ANPPaint.cpp
4 	libflashplayer.so 	NP_Shutdown 	
5 	dalvik-mark-stack (deleted) 	dalvik-mark-stack (deleted)@0x4064553 	
6 	libicuuc.so 	libicuuc.so@0x90553 	
7 	libflashplayer.so 	NP_Shutdown 	
8 	libflashplayer.so 	NP_Shutdown 	
9 	libflashplayer.so 	NP_Shutdown 	
10 	libflashplayer.so 	NP_Shutdown 	
11 	dalvik-mark-stack (deleted) 	dalvik-mark-stack (deleted)@0x4064553 	
12 	libicuuc.so 	libicuuc.so@0x90553 	
13 	libflashplayer.so 	NP_Shutdown 	
14 		@0x7fffffd 	
15 	libflashplayer.so 	NP_Shutdown 	
16 	libflashplayer.so 	libflashplayer.so@0x5009df 	
17 	libc.so 	libc.so@0x12232 	
18 	libflashplayer.so 	NP_Shutdown 	
19 		@0x5ced73ae 	
20 	libflashplayer.so 	NP_Shutdown 	
21 	libflashplayer.so 	NP_Shutdown
Hit by three users in 25.0a1/20130704. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b48e06621dc9&tochange=dcbbfcdf7bb4
It might be a regression from bug 848491.
Component: Graphics, Panning and Zooming → Graphics
Keywords: regression
Product: Firefox for Android → Core
Summary: crash in SkScalerContext::MakeRec(SkPaint const&, SkDeviceProperties const*, SkMatrix const*, SkScalerContextRec*) → crash in SkScalerContext::MakeRec
Whiteboard: [native-crash]
Version: Firefox 25 → 25 Branch
Assignee: nobody → gwright
tracking-fennec: --- → ?
Keywords: topcrash
Hardware: ARM → All
Looks like it's caused by bug 736276 landing. I will get it fixed.
Blocks: 736276
Duplicate of this bug: 892085
tracking-fennec: ? → 25+
Attachment #774233 - Flags: review?(matt.woodrow)
Attachment #774233 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/c460559cdf97
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Verified fixed on:
Build: Firefox for Android 25.0a1
Device: LG Nexus 4
OS: Android 4.2.2
Verified fixed on:
Build: Firefox for Android 25.0a1(2013-07-17)
Device: LG Nexus 4
OS: Android 4.2.2
Status: RESOLVED → VERIFIED
Depends on: 903993
You need to log in before you can comment on or make changes to this bug.