Closed Bug 903993 Opened 6 years ago Closed 6 years ago

Firefox 25 spike in Android crash @ libflashplayer.so@0x75...

Categories

(Firefox for Android Graveyard :: Plugins, defect, critical)

25 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox24 unaffected, firefox25+ fixed, firefox26 fixed, firefox27 fixed, fennec25+)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox24 --- unaffected
firefox25 + fixed
firefox26 --- fixed
firefox27 --- fixed
fennec 25+ ---

People

(Reporter: scoobidiver, Assigned: gw280)

References

()

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(2 files, 1 obsolete file)

With combined signatures, it's #9 crasher in 23.0, #7 in 24.0b1, #1 in 25.0a2, and #1 in 26.0a1.

It started spiking in 25.0a1/20130717. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5976b9c673f8&tochange=0888e29c83a3

Here is the breakdown per device:
+ Aurora:
*libflashplayer.so@0x75be5e 	10
Samsung GT-N8000 	10

+ Nightly:
* libflashplayer.so@0x759e5e 	8
ASUS Transformer Pad TF300T 	7
unknown cm_tenderloin 	1
* libflashplayer.so@0x75c0a6 	8
Samsung GT-I9300 	3
Samsung GT-P5110 	3
Samsung Galaxy Nexus 	2
* libflashplayer.so@0x75be5e 	7
Amazon KFTT 	4
Samsung Nexus 10 	2
Samsung GT-N7000 	1

Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0x18a9c 	
1 	libflashplayer.so 	libflashplayer.so@0x75be5e 	
2 	libflashplayer.so 	libflashplayer.so@0x40524d 	
3 	libflashplayer.so 	libflashplayer.so@0x6dbfd1 	
4 	libflashplayer.so 	libflashplayer.so@0x75be5e 	
5 	libflashplayer.so 	libflashplayer.so@0x145c55 	
6 	libflashplayer.so 	libflashplayer.so@0x75be5e
...

More reports at:
https://crash-stats.mozilla.com/query/?product=FennecAndroid&query_search=signature&query_type=contains&query=libflashplayer.so%400x75
QA wanted to investigate comment 1.
tracking-fennec: --- → ?
Keywords: qawanted
Crashed on first-attempt at loading the URL (Samsung Galaxy SIV, Android 4.3) Flash (11.1.115.69).

d57dc6ac-f6c1-4a9f-b40c-8b7b42130819

https://crash-stats.mozilla.com/report/index/d57dc6ac-f6c1-4a9f-b40c-8b7b42130819
Looks like the inbound builds are gone. Will manually bisect this soon
Flags: needinfo?(kbrosnan)
user:        George Wright <gw@gwright.org.uk>
date:        Thu Jul 11 16:41:15 2013 -0400
summary:     Bug 890272 - Use SkFontHost_linux to provide SkFontHost factories on Android for use by skia-npapi r=mattwoodrow
Blocks: 890272
Flags: needinfo?(kbrosnan)
Leaving a need info to George so there will be a flag outside the vacation bugmail.
Flags: needinfo?(gwright)
This fixes this crash for now and the flash works fine, but we should investigate further as to why we aren't getting an SkFILEStream. This will be affected by a rebase of Skia as SkStream::getFileName() no longer exists upstream.
Attachment #797307 - Flags: review?(snorp)
Flags: needinfo?(gwright)
Attachment #797307 - Flags: review?(snorp) → review+
Assignee: nobody → gwright
tracking-fennec: ? → 25+
Ask for uplift approval when ready
https://hg.mozilla.org/mozilla-central/rev/c04bbc49869f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Poking this for Firefox 25 Beta uplift. This is already fixed in Firefox 26.
gw280/snorp - uplift request for Beta please
Flags: needinfo?(snorp)
Flags: needinfo?(gwright)
Comment on attachment 797307 [details] [diff] [review]
0001-Bug-903993-null-check-the-SkStream-s-getFileName-bef.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 848491
User impact if declined: Crashes.
Testing completed (on m-c, etc.): m-c and aurora for a few weeks, no issues
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #797307 - Flags: approval-mozilla-beta?
Comment on attachment 797307 [details] [diff] [review]
0001-Bug-903993-null-check-the-SkStream-s-getFileName-bef.patch

Approving as this is low risk and help avoid a reproducible crash.

Request to land asap so this can get into beta which is going to build today.
Attachment #797307 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(gwright)
This is showing up on 29 beta again did this code change during the release?
Flags: needinfo?(snorp)
(In reply to Kevin Brosnan [:kbrosnan] from comment #17)
> This is showing up on 29 beta again did this code change during the release?

Nope.
Flags: needinfo?(snorp)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #18)
> (In reply to Kevin Brosnan [:kbrosnan] from comment #17)
> > This is showing up on 29 beta again did this code change during the release?
> 
> Nope.

Wait, maybe. George?
Flags: needinfo?(gwright)
This patch is commented out on trunk, presumably because latest Skia doesn't even support the required API. I would say the new crash must be different than this one?
Comment on attachment 8412859 [details] [diff] [review]
Don't use __fork, it's gone in newer bionic

Wrong bug.
Attachment #8412859 - Attachment is obsolete: true
Attachment #8412859 - Flags: review?(mwu)
Filed 1001624.
Yeah, the code is commented out. Is there a stacktrace anywhere?
Flags: needinfo?(gwright)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.