[User story][CDMA] Emergency call back mode

RESOLVED FIXED in Firefox 26

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: khu, Assigned: itsay)

Tracking

unspecified
1.2 C4(Nov8)
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 fixed)

Details

(Whiteboard: [ucid:CDMA11, FT:RIL, POVB, KOI:P1], URL)

Attachments

(7 attachments)

(Reporter)

Description

5 years ago
User story: 

"As a user I need a UI support for showing that the phone in in emergency call back 
mode. Emergency call back mode should have an option for user to end the
 end the emergency call back mode."

Acceptance criteria: 

User should be able to use emergency call back  mode.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi+
Depends on: 881863, 887690
(Reporter)

Updated

5 years ago
Flags: in-moztrap?
QA Contact: echu

Comment 1

5 years ago
Could following items be part of acceptance criteria?

1. User can exit emergency call back mode via UI in anytime they want during the mode active time.
2. User cannot access data call service during ECM.

Comment 2

5 years ago
Modified suggestion 2.
2. User cannot access data call and send and receive messages during ECM.

Please confirm are the 2 suggestions be accepted or not.
Flags: needinfo?(skamat)
As I know, disabling the data call access in ECM is controlled by modem. (See Bug 881863 Comment 3)

Suggest to add
1. Enter ECM after dialing an emergency call.
2. (In ECM) Exit ECM after dialing an non-emergency call.
3. (In ECM) Exit ECM after timeout (ex: 5 mins)

Comment 4

5 years ago
There are several items here that are controlled by modem that the user should not be able to access. Anshul: is there a list we can use?
Flags: needinfo?(anshulj)

Updated

5 years ago
Flags: needinfo?(skamat)

Updated

5 years ago
Flags: needinfo?(anshulj)

Comment 5

5 years ago
set need info again.

Sandip, some acceptance criteria suggestions already provided. Once Anshul confirms the modem question, could you update the acceptance criteria based on your final conclusion? Thank you so much.
Flags: needinfo?(anshulj)
(Reporter)

Updated

5 years ago
Priority: -- → P1

Comment 6

5 years ago
Sandip I don't have a list of items that modem shouldn't expose for Emergency Callback mode. Is there a specific question you guys have?
Flags: needinfo?(anshulj)

Comment 7

5 years ago
(In reply to Anshul from comment #6)
> Sandip I don't have a list of items that modem shouldn't expose for
> Emergency Callback mode. Is there a specific question you guys have?

yes from 3gpp perspective, what use cases (data etc) the user should be prohibited from during ECB?

Comment 8

5 years ago
Sandip, I am trying to find a spec; will update the bug when I have more information.

Comment 9

5 years ago
If the phone is in ECBM, only the emergency call is allowed. So dialing a non-emergency call shouldn't automatically bring the phone out of ECBM.

No SMS/Data is allowed while in ECBM mode.
(Reporter)

Updated

5 years ago
Flags: in-moztrap? → in-moztrap?(echu)
Anshul, 
In Bug 881863 Comment 3, you have mentioned that disabling data is controlled in modem. How about the SMS? Is it also handled by modem?
Flags: needinfo?(anshulj)

Comment 11

5 years ago
Szu-Yu, yes that is the case.
Flags: needinfo?(anshulj)
(Reporter)

Updated

5 years ago
Whiteboard: [ucid:CDMA11] → [ucid:CDMA11], [FT:RIL]

Updated

5 years ago
Whiteboard: [ucid:CDMA11], [FT:RIL] → [ucid:CDMA11], [FT:RIL], [Test case ETA:8/19]

Comment 12

5 years ago
Hi Anshul,

Suppose cell broadcast will not be received during ECM, right?

Thanks.
Flags: needinfo?(anshulj)

Comment 13

5 years ago
Yes because it is received as SMS which is not allowed during ECBM.
Flags: needinfo?(anshulj)
(Reporter)

Updated

5 years ago
Whiteboard: [ucid:CDMA11], [FT:RIL], [Test case ETA:8/19] → [ucid:CDMA11, FT:RIL, KOI:P1], [Test case ETA:8/19]

Comment 14

5 years ago
Update test case URL but will do minor revise when UX is ready.
Flags: in-moztrap?(echu) → in-moztrap+

Comment 15

5 years ago
Hi Neo,

Couple UX questions that need your help to clarify, thanks.

1.      Dialing non-emergency call to exit has no confirm window on reference phone. Is there any reason we have it? 
2.      Confirm message says “Telecom service and internet are disable…”, but actually it only blocks text message and data call connection, I think the wording is not fully correct if Telecom here including voice call.
3.      Are trying to texting and using data call apps methods to exit ECM? I didn’t find this in related bugs. Are we going to provide these methods for sure?

4.p.6, step 2
The emergency notification will
hide when time out, and an
emergency call back icon will
show on status bar.
To turn the mode off, scroll
down the notification bar.

The description is ambiguous here. When timeout, it will automatically exit emergency callback mode.

5. p.6, step 4 confirm dialog
I think the confirm dialog should tell the user why you are in the mode and what is the purpose of the mode.
Otherwise, the current message only show the drawbacks and the restrictions of the mode.
Flags: needinfo?(nhsieh)
(Reporter)

Comment 16

5 years ago
Created attachment 790716 [details]
[CDMA]UX Emergency call back_20130814.pdf

Comment 17

5 years ago
Please check the attachment. Thanks
Flags: needinfo?(nhsieh)

Comment 18

5 years ago
Created attachment 791120 [details]
[CDMA]Emergency call back_20130816_V0.2.pdf

Comment 19

5 years ago
Hi Neo,

I have 2 questions about v0.2 UX spec, could you help to check them?

1. P.6, item 1, "Once the user make an emergency call, there will be a notification..." - Is ECM UI shown "after" emergency call is ended or after making the call?

2. P.8, item 4/ p.9, item 4 "....by 3G or wi-fi" - Wifi should not in the blocking list. It still can be used even in ECM.
Flags: needinfo?(nhsieh)

Comment 20

5 years ago
1. After an emergency call is ended.
2. OK. We will fix it. Did you checked this behavior with Ken/Kevin Hu too ?
Flags: needinfo?(nhsieh)

Comment 21

5 years ago
Hi Neo, no, but Wifi will not impact telephony and I've tried on other reference phone as well.

Hi Ken, could you help to confirm this? Wifi should not be blocked by ECM, right?
Flags: needinfo?(kchang)

Comment 22

5 years ago
(In reply to echu from comment #21)
> Hi Ken, could you help to confirm this? Wifi should not be blocked by ECM,
> right?
Yes. WIFI doesn't blocked by ECM.
Flags: needinfo?(kchang)

Comment 23

5 years ago
Hi Ken, 

How about LTE & WiMax ? Will they be blocked in ECM ?
Flags: needinfo?(kchang)

Comment 24

5 years ago
(In reply to Neo Hsieh from comment #23)
> Hi Ken, 
> 
> How about LTE & WiMax ? Will they be blocked in ECM ?
No, LTE & WiMax aren't blocked in ECM.
Flags: needinfo?(kchang)
Anshul,
In ECM, data service is blocked. Will we receive any error from modem side if we try to use the data during ECM. Ex: get fail result when setup data call? Moreover, will it indicates the fail is cause by ECM.
Flags: needinfo?(anshulj)

Comment 26

5 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #25)
> Anshul,
> In ECM, data service is blocked. Will we receive any error from modem side
> if we try to use the data during ECM. Ex: get fail result when setup data
> call? Moreover, will it indicates the fail is cause by ECM.
I am not sure if there would be a specific failure reason. I don't see any in the RIL interface defined by Android so my guess is no.
Flags: needinfo?(anshulj)

Comment 27

5 years ago
(In reply to Anshul from comment #26)
> I am not sure if there would be a specific failure reason. I don't see any
> in the RIL interface defined by Android so my guess is no.
But this setup data call procedure will be failed. right?
Flags: needinfo?(anshulj)

Comment 28

5 years ago
(In reply to Ken Chang from comment #27)
> (In reply to Anshul from comment #26)
> > I am not sure if there would be a specific failure reason. I don't see any
> > in the RIL interface defined by Android so my guess is no.
> But this setup data call procedure will be failed. right?
Yes, a 100%.
Flags: needinfo?(anshulj)
(In reply to Anshul from comment #28)
> (In reply to Ken Chang from comment #27)
> > (In reply to Anshul from comment #26)
> > > I am not sure if there would be a specific failure reason. I don't see any
> > > in the RIL interface defined by Android so my guess is no.
> > But this setup data call procedure will be failed. right?
> Yes, a 100%.

Our UX would like to show an error prompt when user try to use the data service in ECM. Then, if they really want to use it at the moment, they could leave the ECM manually.

The problem is that what is the better way to trigger that prompt. Data traffic might go through 3G, wifi or others. Therefore, I think that gaia should know
(1) current data traffic goes through 3g and it fails
(2) fails is caused by ECM

For (2) and the comment above. Seems that gaia could knows that it is in ECM. However, we don't know the failure is indeed caused by ECM. Will this cause some problems?

Hi Steve,

Could you help complete my comment and tell us how could we help for you to work on that prompt problem. Thanks.
Flags: needinfo?(schung)
Thanks for raising this issue here. For the better solution, an error event with error code dispatched from gecko would be great(EX: DataError event from mobileConnection). We can make sure the connection error is caused by ECM and popup the prompt to control the ECM mode manually. Returning the error event without error code might still works, but knowing the actual root cause will guarantee prompt popup at the right timming. Anyway the most critical thing is gaia should be able to regist callback to mobileConnection and handle the error event while connection setup.
Flags: needinfo?(schung)

Comment 31

5 years ago
QA can start to verify this user story.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
The phone call can not enter enter Emergency mode after hang up the emergency call in below build, but reference phone will enter emergency mode after hang up emergency call.

*Environment*
- Code version  
  Gaia:     45b79e60d1b15d53ff60348d812d732affb19cb6
    B-D     2013-09-09 03:32:39
  Gecko:    cd7158c6cd2756daca992b1dfbdcf9805ade7f0a
  BuildID   20130909062051
  Version   26.0a1
-
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi aknow, this patch did work on your gecko test gecko build, could you help investigate with this problem? Thanks.
Flags: needinfo?(szchen)
Created attachment 801511 [details]
wasabi radio log
Flags: needinfo?(szchen)
Created attachment 801514 [details]
android radio log
Anshul,
With the same sim card and network, we could enter ecm after dialing 911 on an android reference phone, but not on our cdma device (wasabi w/ qcril).

I have attach two radio logs (wasabi: attachment 801511 [details], android: attachment 801514 [details]). From wasabi log, I could not see any ecm related information. Is there any way to tell that whether the ril send out the ecm unsolicited response (RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE).
Flags: needinfo?(anshulj)
Flags: needinfo?(anshulj)
(In reply to Szu-Yu Chen [:aknow] from comment #36)
> Anshul,
> With the same sim card and network, we could enter ecm after dialing 911 on
> an android reference phone, but not on our cdma device (wasabi w/ qcril).
                                                                    ^^^^^
correct mozril

> I have attach two radio logs (wasabi: attachment 801511 [details], android:
> attachment 801514 [details]). From wasabi log, I could not see any ecm
> related information. Is there any way to tell that whether the ril send out
> the ecm unsolicited response (RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE).
Created attachment 801524 [details]
wasabi radio log 2
Hi Anshul,
For my previous question (Comment 36), I have attached a more detailed log (attachment 801524 [details]). Could we check whether the rild indeed sent out the RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE response after dialing an emergency call (911)? I didn't find any information in the log mentioned that.
Flags: needinfo?(anshulj)
Created attachment 802010 [details]
Emergency Callback.zip

Hey guys, graphic designer has revised the emergency callback mode icon. I've attached it in this bug. Please help to pass it to the related engineers. Thanks!

Updated

5 years ago
Component: General → RIL

Comment 41

5 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #39)
> Hi Anshul,
> For my previous question (Comment 36), I have attached a more detailed log
> (attachment 801524 [details]). Could we check whether the rild indeed sent
> out the RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE response after dialing an
> emergency call (911)? I didn't find any information in the log mentioned
> that.
Aknow, can you please attach the RILD log of android? Thanks.
(In reply to Ken Chang from comment #41)
> (In reply to Szu-Yu Chen [:aknow] from comment #39)
> > Hi Anshul,
> > For my previous question (Comment 36), I have attached a more detailed log
> > (attachment 801524 [details]). Could we check whether the rild indeed sent
> > out the RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE response after dialing an
> > emergency call (911)? I didn't find any information in the log mentioned
> > that.
> Aknow, can you please attach the RILD log of android? Thanks.

Ken,
Please see (attachment 801514 [details] : android radio log)
I have attached it before. The log looks good. I could find some ecm related lines shown in the log.
(In reply to Szu-Yu Chen [:aknow] from comment #42)
> (In reply to Ken Chang from comment #41)
> > (In reply to Szu-Yu Chen [:aknow] from comment #39)
> > > Hi Anshul,
> > > For my previous question (Comment 36), I have attached a more detailed log
> > > (attachment 801524 [details]). Could we check whether the rild indeed sent
> > > out the RIL_UNSOL_ENTER_EMERGENCY_CALLBACK_MODE response after dialing an
> > > emergency call (911)? I didn't find any information in the log mentioned
> > > that.
> > Aknow, can you please attach the RILD log of android? Thanks.
> 
> Ken,
> Please see (attachment 801514 [details] : android radio log)
> I have attached it before. The log looks good. I could find some ecm related
> lines shown in the log.

Is it the rild log you mentioned?
It is captured by "logcat -b radio"

Comment 44

5 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #43)
> 
> Is it the rild log you mentioned?
> It is captured by "logcat -b radio"
Yes, but it is strange. I don't see any RILD or RILC message in the log.
(In reply to Ken Chang from comment #44)
> (In reply to Szu-Yu Chen [:aknow] from comment #43)
> > 
> > Is it the rild log you mentioned?
> > It is captured by "logcat -b radio"
> Yes, but it is strange. I don't see any RILD or RILC message in the log.

I got the answer.
The reference android phone we used is a production HTC/verizon phone. Radio log is turn off and we could not enable it. So there is no RILD log. In addition, RILC log go through QC-QMI log tag.

Comment 46

5 years ago
ken, I confirmed that we do see the emergency callback mode on our test devices when the emergency call is ended. Please check with the OEM about this issue.
Flags: needinfo?(anshulj)

Comment 47

5 years ago
This feature is carrier dependent. Without OEM/Carrier's supports, we can not verify it in real network. After having partners for CDMA, we can do more verifications. Close it now.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 48

5 years ago
After confirming with both Mozilla China and TW's QA, Reference phone's android version cannot enter ECM. So QA cannot run all ECM test cases at current stage. But still bug 908004 and 908641 are found as well.
Depends on: 908614, 908004
Created attachment 802848 [details]
n970 android main + radio log

Ken,

I flash the wasabi (zte n970) back to the android and test the same scenario. There is no emergency callback notification after dialing 911. Note that it shows following line in log after I drop the call.

D/CDMA    (  857): [CdmaCallTracker] checkAndEnableDataCallAfterEmergencyCallDropped,inEcm=false

Check the reference android source code. That means after the call, system property PROPERTY_INECM_MODE is false [1]. This property will be set to true if it enter handleEnterEmergencyCallbackMode() [2].

[1] http://goo.gl/vPwCd2
[2] http://goo.gl/cPQFd6

So maybe the question is on this zte phone as Anshul's comment above.
status-firefox26: --- → fixed

Updated

5 years ago
Whiteboard: [ucid:CDMA11, FT:RIL, KOI:P1], [Test case ETA:8/19] → [ucid:CDMA11, FT:RIL, KOI:P1, POVB]

Updated

5 years ago
Assignee: nobody → itsay

Updated

5 years ago
Whiteboard: [ucid:CDMA11, FT:RIL, KOI:P1, POVB] → [ucid:CDMA11, FT:RIL, POVB, KOI:P1]

Comment 50

5 years ago
Due to modem problem, QA cannot verify this feature on Wasabi, change status to Verified Invalid but not sure if this is a problem status, feel free to correct me.
Status: RESOLVED → VERIFIED
Resolution: FIXED → INVALID
(Reporter)

Updated

5 years ago
Target Milestone: --- → 1.2 C4(Nov8)

Comment 51

5 years ago
Wrong status change, keep it in resolved fixed which since it's not able to be verified with Wasabi.
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.