unable to connect to dev ElasticSearch instance

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
I can't connect to the IT development ElasticSearch cluster at elasticsearch-zlb.dev.vlan81.phx.mozilla.com:9200; attempts to do so yield "couldn't connect to host".

Updated

5 years ago
Assignee: server-ops → server-ops-webops
Component: Server Operations → Server Operations: Web Operations
QA Contact: shyam → nmaul
I believe you need to be in the "vpn_elasticsearch" ldap group, but I could be wrong. I'm able to connect, but I'm in the admin group so it's difficult to say. You should probably submit a bug under the "Infrastructure: Openvpn" component.
(Reporter)

Comment 2

5 years ago
Is this just a VPN issue?  I also cannot connect to this address from one of our production servers, that used to be able to:  brasstacks1.dmz.scl3.mozilla.com
When was the last time you were able to connect? It may very well be a vpn issue. I know some of the vpn ldap groups were made pretty recently. I don't want to  get too fixated on blaming the vpn so I'll check to see if there were other changes that may have affected the flows.
(Reporter)

Comment 4

5 years ago
I last accessed it about a week ago.  There may be a VPN issue involved, but I can't access it from brasstacks1.dmz.scl3.mozilla.com either; would that also be caused by a VPN ldap group issue?
Ok. It sounds like there are multiple issues here. I'm going to check with netops to see if we have the right flows in place. In addition to that, you should request access to the vpn ldap group for elasticsearch if you're using the global vpn.

Updated

5 years ago
Depends on: 891528
(Reporter)

Updated

5 years ago
Blocks: 891831
Hello,

Just pinging to see if this bug has been resolved, or if it still requires further action.
Flags: needinfo?
(Reporter)

Comment 7

5 years ago
This is working now, except for VPN issues, which I'll file separately.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?
Resolution: --- → WORKSFORME
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.