The default bug view has changed. See this FAQ.

Remove "Revocation Lists" button from Advanced > Certificates options

RESOLVED FIXED in Thunderbird 25.0

Status

Thunderbird
Preferences
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rsx11m, Assigned: rsx11m)

Tracking

({dev-doc-needed, useless-UI})

Trunk
Thunderbird 25.0
dev-doc-needed, useless-UI

Thunderbird Tracking Flags

(thunderbird23 unaffected, thunderbird24+ fixed, thunderbird25 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #886099 +++

Bug 867465 removed the window that the button opens.
(Assignee)

Comment 1

4 years ago
Created attachment 773727 [details] [diff] [review]
Simple patch

Removes the non-functional button along with its JavaScript function.
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
Attachment #773727 - Flags: ui-review?(bwinton)
Attachment #773727 - Flags: review?(bwinton)
(Assignee)

Comment 2

4 years ago
Created attachment 773728 [details] [diff] [review]
Branch patch

Identical patch but without the changes to advanced.dtd as this will need to land for the 24.0 branch to avoid a useless UI sticking around.
(Assignee)

Updated

4 years ago
status-thunderbird23: --- → unaffected
status-thunderbird24: --- → affected
status-thunderbird25: --- → affected
Keywords: useless-UI
tracking-thunderbird24: --- → +
Comment on attachment 773727 [details] [diff] [review]
Simple patch

>+++ b/mail/components/preferences/advanced.js
>@@ -359,26 +359,16 @@ var gAdvancedPane = {
>   /**
>-   * Display a dialog which describes the user's CRLs.
>-   */
>-  showCRLs: function ()

Is this function used by any add-ons?  Should we do some sort of dev-doc or outreach to those authors?

>+++ b/mail/components/preferences/advanced.xul
>@@ -442,20 +439,16 @@
>           <hbox>
>             <button id="viewCertificatesButton"
>                     label="&viewCertificates.label;"
>                     accesskey="&viewCertificates.accesskey;"
>                     oncommand="gAdvancedPane.showCertificates();"
>                     preference="security.disable_button.openCertManager"/>
>-            <button id="viewCRLButton"
>-                    label="&viewCRLs.label;" accesskey="&viewCRLs.accesskey;"
>-                    oncommand="gAdvancedPane.showCRLs();"
>-                    preference="security.OCSP.disable_button.managecrl"/>
>             <button id="verificationButton"
>                     label="&validation.label;" accesskey="&validation.accesskey;"
>                     oncommand="gAdvancedPane.showOCSP();"/>
> #ifdef XP_MACOSX
>           </hbox>
>           <hbox>
> #endif
>             <button id="viewSecurityDevicesButton"

I think we should move the "Security Devices" button up into the previous hbox, which I think we can do by just removing the three "#ifdef XP_MACOSX" blocks.

Aside from that, I'm pretty happy with the patch, so r=me and ui-r=me with those changes.
Attachment #773727 - Flags: ui-review?(bwinton)
Attachment #773727 - Flags: ui-review+
Attachment #773727 - Flags: review?(bwinton)
Attachment #773727 - Flags: review+
(Assignee)

Comment 4

4 years ago
Created attachment 775378 [details] [diff] [review]
Patch for checkin

(In reply to Blake Winton (:bwinton) from comment #3)
> Is this function used by any add-ons?  Should we do some sort of dev-doc or
> outreach to those authors?

I don't know, but it's a Core feature that was removed. Thus, I'd think that it's somewhere mentioned in the documentation there, and leaving the function in without it doing anything wouldn't make much sense.

> I think we should move the "Security Devices" button up into the previous hbox,
> which I think we can do by just removing the three "#ifdef XP_MACOSX" blocks.

Done. I don't have a Mac to test if it fits, but I assume that you've done so or can otherwise estimate that it won't be a problem.
Attachment #773727 - Attachment is obsolete: true
Attachment #775378 - Flags: ui-review+
Attachment #775378 - Flags: review+
(Assignee)

Comment 5

4 years ago
Created attachment 775380 [details] [diff] [review]
Patch for comm-aurora

[Approval Request Comment]
Regression caused by (bug #): Bug 867465 (feature removal)
User impact if declined: User would see a non-functional button in prefpane
Testing completed (on c-c, etc.): tested on comm-central build
Risk to taking this patch (and alternatives if risky): very low
String changes: none in this patch (now redundant strings removed with 25.0)
Attachment #773728 - Attachment is obsolete: true
Attachment #775380 - Flags: approval-comm-aurora?
(Assignee)

Comment 6

4 years ago
Push of attachment 775378 [details] [diff] [review] on comm-central, please.
Keywords: checkin-needed, dev-doc-needed
https://hg.mozilla.org/comm-central/rev/7847008544a1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 25.0
Attachment #775380 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/08d90e7c36c4
status-thunderbird24: affected → fixed
status-thunderbird25: affected → fixed
You need to log in before you can comment on or make changes to this bug.