[l10n][Croatian][Calendar] Week view: header with two months is shown truncated

RESOLVED WONTFIX

Status

Mozilla Localizations
hr / Croatian
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: nkot, Unassigned)

Tracking

({l12y, uiwanted})

unspecified
ARM
Gonk (Firefox OS)
l12y, uiwanted
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [leo-triage])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 775262 [details]
screenshot

Description:
 Week view, header with two months is shown truncated in Croatian

Repro Steps:
1) Updated to Leo Build ID: 20130713070207
2) Set device to  language
3) Open Calendar app
4) Switch to the Week view
5) Swipe left or right to navigate to a week with days in two months (October 28 - November 1)
 
Actual:
 Header is shown as "Listopad Studeni..."

Expected:
 Header is not truncated

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f21152a848da
Gaia: 2e711c1fdd2441bda34703cd7d8d3c0f1cc2c396
Platform Version: 18.1

Notes:
See attached screenshot
(Reporter)

Updated

5 years ago
Blocks: 892075

Comment 1

5 years ago
On my Keon header isn't truncated. This probably affects only devices with lower screen resolution.

Unfortunately I can't shorten the translation. Those are full names of the months in Croatian.
Talked with localizer. 
We can't make month names shorter as it'll mess other parts of the UI where the same strings are being used.
No workaround was found for this case. Therefore nominating
blocking-b2g: --- → leo?
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: uiwanted

Comment 3

4 years ago
Flagging Rob since this affects Calendar. Please note that Rob is in Paris for a work week and that blocking bugs still have priority.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
leo triaging partners do not have this as a target launch market, leaving leo-triage to decide.
Whiteboard: [leo-triage]
At this point we're not taking more blockers unless they're partner-championed or critical security/regression.
blocking-b2g: leo? → -
Blocks: 902572

Comment 6

4 years ago
Flagging Eric on VxD recommendations generally, and Przemek to see if reducing the font size might be able to help here. We'll check current builds first to see if this is still an issue, as this bug is a bit dated due to the UX backlog focusing on blockers.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(pabratowski)
Flags: needinfo?(epang)
(In reply to Stephany Wilkes from comment #6)
> Flagging Eric on VxD recommendations generally, and Przemek to see if
> reducing the font size might be able to help here. We'll check current
> builds first to see if this is still an issue, as this bug is a bit dated
> due to the UX backlog focusing on blockers.

In today's unagi builde (2013-08-15) it looks like the string in the header has been updated to 'Kolovoz 2013', which is no longer truncated.  Can this bug be closed?
Flags: needinfo?(pabratowski)
Flags: needinfo?(epang)
(In reply to Eric Pang [:epang] from comment #7)
> (In reply to Stephany Wilkes from comment #6)
> > Flagging Eric on VxD recommendations generally, and Przemek to see if
> > reducing the font size might be able to help here. We'll check current
> > builds first to see if this is still an issue, as this bug is a bit dated
> > due to the UX backlog focusing on blockers.
> 
> In today's unagi builde (2013-08-15) it looks like the string in the header
> has been updated to 'Kolovoz 2013', which is no longer truncated.  Can this
> bug be closed?

sorry I was mistaken!  After speaking with Prezemek, is there anyway to use short forms of the month?  Such as Jan Feb and remove the year '2013'?  I'm flagging Victoria for feedback as well since she designed the calendar.  Victoria's what do you think?
Flags: needinfo?(vpg)

Comment 9

4 years ago
It is possible to shorten the months to Kol Srp etc, but from what Sasa said, it would lead to inconsistent naming in the localization.

I would say it is OK to use short forms only when displaying two months at once in the header. Sasa?

Also, a more general fix maybe? bug 898731

Comment 10

4 years ago
I can confirm that on Keon device (build id 20130712192650 - Croatian language) months text is showing properly.

On Unagi device (build id 20130812041203 - Croatian language), problem still persists in some cases (e.g. Rujan Listopad 20...).
Agree on the short forms for month, it is not an unusual solution.
Thanks!

(In reply to Eric Pang [:epang] from comment #8)
> (In reply to Eric Pang [:epang] from comment #7)
> > (In reply to Stephany Wilkes from comment #6)
> > > Flagging Eric on VxD recommendations generally, and Przemek to see if
> > > reducing the font size might be able to help here. We'll check current
> > > builds first to see if this is still an issue, as this bug is a bit dated
> > > due to the UX backlog focusing on blockers.
> > 
> > In today's unagi builde (2013-08-15) it looks like the string in the header
> > has been updated to 'Kolovoz 2013', which is no longer truncated.  Can this
> > bug be closed?
> 
> sorry I was mistaken!  After speaking with Prezemek, is there anyway to use
> short forms of the month?  Such as Jan Feb and remove the year '2013'?  I'm
> flagging Victoria for feedback as well since she designed the calendar. 
> Victoria's what do you think?
Flags: needinfo?(vpg)

Comment 12

2 years ago
We've stopped shipping Firefox OS for phones. Thus resolving this as WONTFIX.

Thank you for testing and reporting.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.