Closed Bug 894672 Opened 7 years ago Closed 6 years ago

[B2G][NFC][User Story]: Support NFC Pairing

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: skamat, Unassigned)

References

Details

(Keywords: feature, Whiteboard: [ucid:NFC1, 1.3:p2, ft:RIL])

Attachments

(2 files)

The user can initiate BT pairing via NFC. The most common use case is with BT enabled speakers or headsets.
1) The user can tap an NFC enabled BT device (e.g. BT speakers, BT headsets etc) to allow easy pairing with that BT device. No typical BT interactions (choosing a device to pair, entering pin codes) are necessary.
a) The above can happen at any point/screen on the mobile (as long as NFC is turned on).
b) If BT is turned off, the user will be prompted to turn on BT.
c) If music is already playing on the mobile, tapping on a NFC enabled BT speaker/headset to initiate a BT connection will lead to pairing, connecting the BT device and then transferring the music playback to the speaker/headset.
Duplicate of this bug: 894318
Duplicate of this bug: 894314
Summary: [B2G] [NFC User Story]: Support NFC Pairing → [B2G][NFC][User Story]: Support NFC Pairing
Blocks: b2g-nfc
Flags: in-moztrap?
QA Contact: wachen
Flags: in-moztrap? → in-moztrap?(wachen)
Whiteboard: [ucid:NFC1]
<Acceptance Criteria> (Proposal)
1. When NFC and BT are on, user can pair with BT headset or speaker without BT interaction
2. When NFC is on and BT is off, user can see a prompt for enabling BT before pairing
3. When NFC and BT and Music are on, after pairing, music can play in BT device.
Whiteboard: [ucid:NFC1] → [ucid:NFC1], [FT:RIL]
Blocks: 903305
No longer blocks: 903305
Depends on: 903305
Whiteboard: [ucid:NFC1], [FT:RIL] → [FT:RIL, v1.3, ucid:NFC1]
We only focus on pairing. 

Other questions include: 
1. What profiles need to be covered? 
2. What versions of BT profiles need to covered? 

Sandip? Can you help to clarify? Thanks!
Flags: needinfo?(skamat)
Depends on: webnfc
Depends on: 860907
Depends on: 897312
Depends on: 902051
Whiteboard: [FT:RIL, v1.3, ucid:NFC1] → [FT:RIL, NFCv1.3, ucid:NFC1]
We need to support the current BT profiles till 1.2. BT team has the latest but the wiki is here: https://wiki.mozilla.org/B2G/Bluetooth.

Also, please confirm which parts of the original user story we can't support in 1.2/1.3 if any?
Flags: needinfo?(skamat)
Sandip, thanks! I am thinking the same thing. 

By the way, since this pairing is a v1.3 feature, should we align with the scope of Bluetooth profiles and versions for Firefox OS v1.3? Or, we focus on the Bluetooth profiles in v1.2? Because Bluetooth is also in your plate, it would be great if you could share with us. Thanks!
Flags: needinfo?(skamat)
Correct, We should align with 1.3 BT profiles.
Flags: needinfo?(skamat)
blocking-b2g: --- → 1.3+
Confirmed that Firefox OS v1.3 won't support additional Bluetooth profile. So, the supported Bluetooth profiles are as the same as what we have in v1.2: 

https://wiki.mozilla.org/B2G/Bluetooth#Firefox_OS_v1.2_2
Whiteboard: [FT:RIL, NFCv1.3, ucid:NFC1] → [FT:RIL, 1.3:p1, ucid:NFC1]
Hi all,
The interaction spec uploaded, please refer to attachment.
Thanks,
Juwei
Blocks: b2g-nfc-ux
No longer blocks: b2g-nfc
Remove blocking-b2g flag from User Story bugs. Use whiteboard to indicate what FxOS version we target.
blocking-b2g: 1.3+ → ---
Whiteboard: [FT:RIL, 1.3:p1, ucid:NFC1] → [FT:RIL, 1.3:p2, ucid:NFC1]
Keywords: feature
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [FT:RIL, 1.3:p2, ucid:NFC1] → [ucid:NFC1, 1.3:p2, ft:RIL]
Close this bug so that QA can do verification.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Walter,
Can you update testing result according to the AC?
Flags: needinfo?(wachen)
This is not verified. It failed on my testing.
The design is different from UX spec.
Flags: needinfo?(wachen)
Depends on: 969277
Also, I suggest that we can add a switch for enabling or disabling the confirm step (step.2 in P.6~8).

Juwei, how do you think about this UX idea?
Flags: needinfo?(jhuang)
As I said in bug 969277, the confirm step can be discarded once everyone all agree with turning on BT without inform users at the moment of pairing BT speaker/headset.
Flags: needinfo?(jhuang)
Update spec due to bug 969277
Duplicate of this bug: 934909
Verified on
Gaia      2c6c413ed729d465c52d6c2d5d458e2eee79e956
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/d32649a24965
BuildID   20140714160201
Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.