Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Private Browsing information leak in openNewTabOrWindow()

RESOLVED FIXED in seamonkey2.21

Status

SeaMonkey
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.21

SeaMonkey Tracking Flags

(seamonkey2.20 fixed, seamonkey2.21 fixed, seamonkey2.22 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
From Bug 881083 Comment 5:
>>+      if (gPrivate)
>>+        openNewPrivateWith(href, doc);
>>+      else
>>+        openNewWindowWith(href, doc);
> I guess this really ought to land on branches...
(Assignee)

Comment 1

4 years ago
Created attachment 779164 [details] [diff] [review]
openNewTabOrWindow() patch for branches

[Approval Request Comment]
Regression caused by (bug #): N/A
Testing completed: on comm-central
User impact if declined: Privacy leak
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #779164 - Flags: review?(neil)
Attachment #779164 - Flags: approval-comm-beta?
Attachment #779164 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #779164 - Flags: review?(neil) → review+

Updated

4 years ago
See Also: → bug 899104

Updated

4 years ago
Attachment #779164 - Flags: approval-comm-beta?
Attachment #779164 - Flags: approval-comm-beta+
Attachment #779164 - Flags: approval-comm-aurora?
Attachment #779164 - Flags: approval-comm-aurora+
landed on c-b for you https://hg.mozilla.org/releases/comm-beta/rev/813007bcae07
(Assignee)

Comment 3

4 years ago
> landed on c-b for you https://hg.mozilla.org/releases/comm-beta/rev/813007bcae07
Pushed to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/6129078bfffc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.20: --- → fixed
status-seamonkey2.21: --- → fixed
status-seamonkey2.22: --- → unaffected
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.21
You need to log in before you can comment on or make changes to this bug.