"Open all in tabs" from a private browsing window opens tabs in main window instead

RESOLVED FIXED in seamonkey2.23

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: stephen, Assigned: neil)

Tracking

(Blocks 1 bug)

SeaMonkey 2.19 Branch
seamonkey2.23
x86
Windows XP
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.21 fixed, seamonkey2.22 fixed, seamonkey2.23 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19 (Beta/Release)
Build ID: 20130630011339

Steps to reproduce:

1.  Open a private browsing window
2.  Click Bookmarks
3.  Instruct the browser to open a folder of bookmarks as a set of tabs.  You can either right-click the folder and select Open all in tabs, or expand the folder and pick the Open all in tabs entry; not surprisingly, both produce the same behaviour.


Actual results:

The set of tabs open in the main (i.e. non-private) browser window.


Expected results:

The set of tabs should have opened in the private browsing window.
Confirmed on recent trunk build on Linux, all tabs open in a regular window which is opened new if only the private window is open. This may be covered by bug 896404 or may be a separate case, we'll see.
Blocks: 460895
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 896404
Ok, so this is not directly related to bug 896404. I've tested the 2.20 beta 3 candidate build which contains comm-beta changeset 813007bcae07 which fixes the other bug, and the issue is still reproducible as described.

(In reply to rsx11m from comment #1)
> which is opened new if only the private window is open.

Interestingly, when a non-private window is open already, it will be used to open all bookmarks in the selected folder in tabs (i.e., not part of the new private session just opened before selecting that folder); when no non-private window is available, a new window opens with all the tabs populating as observed, but it's a private window instead (i.e., all tabs should be part of the private session). I've missed this difference when initially testing.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #784322 - Flags: review?(iann_bugzilla)
Attachment #784322 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 784322 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: Can't open bookmarks in tabs in private windows
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #784322 - Flags: approval-comm-beta?
Attachment #784322 - Flags: approval-comm-aurora?
Attachment #784322 - Flags: approval-comm-aurora? → approval-comm-aurora+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.23
Attachment #784322 - Flags: approval-comm-beta? → approval-comm-beta+
Depends on: 918511
You need to log in before you can comment on or make changes to this bug.