Closed Bug 898083 Opened 8 years ago Closed 8 years ago

Exception running debugger statements in Scratchpad, no sources loaded in Debugger

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 813087

People

(Reporter: rcampbell, Unassigned)

References

Details

STR:
1. Open a Scratchpad.
2. Open the Debugger.
3. Enter "debugger;" in the scratchpad
4. Cmd-R (run)

Expected:

Debugger pauses, showing scratchpad's source

Actual:

Debugger pauses, shows loading...

Browser Debugger shows:
[14:42:04.268] Error loading: Scratchpad/1
Could not load the source for Scratchpad/1. @ chrome://browser/content/devtools/debugger-view.js:285
I believe this will be resolved by bug 637572.
Depends on: 637572
Yeah, we have a couple of bugs for that: bug 813087 and bug 816988.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813087
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.