Closed Bug 89903 Opened 23 years ago Closed 21 years ago

[UNC?] Slow Page Load With Cache on Remote Drive

Categories

(Core :: Networking: Cache, defect)

x86
Windows 98
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 74085
mozilla0.9.7

People

(Reporter: brian, Assigned: gordon)

References

()

Details

(Keywords: perf, relnote, verifyme)

Build ID:  0.9.x and 2001070808

My profile is stored on a remote drive (through Windows SMB).  If the cache is 
enabled, graphically intense sites such as www.cnn.com and especially 
us.buy.com can take up to 60sec to load (buy.com), and 3sec to load when the 
cache is disabled.  I had my profiles stored the same way in 4.x with no 
performance problem.  Any ideas?  Thanks!
Keyword Add.  System is a Dell Pentium 800 256MB Ram running on a T1 :)
Keywords: 4xp, perf
There maybe a difference in the composition of memory/cache.

Does performance improve if you turn off cache?

I've asked Profile about this configuration in bug 90682.


Keywords: relnote
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 89963 has been marked as a duplicate of this bug. ***
Does anyone think this should be relnote?
Why would you want your cache to be on a different computer than the one you're
browsing on?  See bug 74085 for making Mozilla default to always using a local
cache...
reporter: what does your cache directory for 4.x look like?  I'm wondering if it
might have effectively been disabled, which would have given it performance more
similar to the 6.x uncached time you reported.
Target Milestone: --- → mozilla0.9.6
Are you using a mapped drive or UNC for your cache directory?
Summary: Slow Page Load With Cache on Remote Drive → [UNC?] Slow Page Load With Cache on Remote Drive
The cache is on a mapped drive (on a SMB share on a Linux server).  I keep my 
profile on it, so I can switch between two windows machines here at home.  My 
main problem was that Mozilla wouldn't let me switch my cache to another 
directory.  I worked around the problem by just disabling the cache (which 
works fine since I'm sitting on a wireless connection that equates to about 2/3 
of a T1.  If you would like to put this one off for a bit in favor of more 
critical bugs, you're welcome to.  I'm working fine.  I do think others in the 
same situation as me might experience the problem in the future.  Thanks!
Ah, interesting.  In 4.x was your cache folder in you profile folder or was it
located elsewhere.  There is a pref availabe to specify the location of the
cache parent directory (browser.cache.disk.parent_directory), but there isn't
any UI to set it yet (bug 46490).
Blocks: 71668
Necko will be focusing on performance for 0.9.7.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
I just ran our page load tests against 4.7 on a Win98 machine, comparing local
and remote profiles.  The local profiles performed much better.  The remote
profiles (and remote cache directory) also performed worse on revisiting pages
over our fast network.  This result was expected and matches our findings with 6.x.

I was unable to reproduce the huge discrepancy reported between the cache being
enabled or disabled (60 sec vs. 3 sec).

We'll continue trying to improve cache performance, but I don't think we're
doing anything egregiously wrong with respect to remote cache directories.

Marking WONTFIX.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
REOPEN:
dupe of an open bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

*** This bug has been marked as a duplicate of 74085 ***
Status: REOPENED → RESOLVED
Closed: 22 years ago21 years ago
QA Contact: tever → cacheqa
Resolution: --- → DUPLICATE
Keywords: verifyme
Hardware: Other → PC
You need to log in before you can comment on or make changes to this bug.