Last Comment Bug 71668 - page loading performance issues
: page loading performance issues
Status: RESOLVED INCOMPLETE
: meta, perf
Product: Core Graveyard
Classification: Graveyard
Component: Tracking (show other bugs)
: Trunk
: All All
: -- normal with 26 votes (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
: chris hofmann
Mentors:
Depends on: 3246 21762 56854 57451 latemeta 72885 73624 82078 83757 86952 90723 91643 91956 92144 94587 96032 97299 97815 100588 100951 103649 103670 103671 deCOM 109181 124536 237842 359555 1279316 12234 27233 29338 30917 37779 39310 39573 41119 41412 42412 44678 52798 54542 54718 57636 60447 61478 62895 63750 64290 66516 67235 67692 ireflow 67756 68821 69010 69534 69931 70147 70211 70408 70995 71653 71857 72138 72163 72348 72380 72382 72540 73295 73497 74451 75083 75121 75988 76151 76722 76866 77002 77269 77458 77460 77540 77989 78015 78019 78300 78567 78695 78905 79726 81253 81480 82278 83545 83772 83840 84047 84466 86319 86947 87224 88166 89085 89903 90761 91363 93055 93561 93620 94828 95314 95652 96108 96633 98001 98275 99153 99636 100147 101870 102321 103097 103202 103432 104336 104627 104999 105000 105344 105705 108232 108660 109050 109415 109428 112209 114584 115787 115973 121269 124302 125260 142206 142631 slowGIF 143918 144533 154816 156253 162096 168638 180241 183168 185970 dns_perf 923458
Blocks: 71066 103712
  Show dependency treegraph
 
Reported: 2001-03-12 00:48 PST by Cathleen
Modified: 2016-07-15 12:13 PDT (History)
77 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Cathleen 2001-03-12 00:48:20 PST

    
Comment 1 Cathleen 2001-03-12 00:54:12 PST
tracking page loading performance related issues
Comment 2 Dimitrios 2001-03-12 09:28:55 PST
Suggesting meta keyword, OS = All.
Comment 3 Stephan Niemz 2001-03-13 07:31:11 PST
agreed
Comment 4 [:jesup] on pto until 2016/8/1 Randell Jesup 2001-03-13 13:34:55 PST
Added bug 71857 (related to bug 54542)
Comment 5 Markus Hübner 2001-10-19 01:19:54 PDT
see comment in bug 96633 - cpu usage 100% and making mozilla quite unusable.
Comment 6 [not reading bugmail] 2002-02-22 04:10:19 PST
2002-2-21-03 w2k, probably bug 122996, also bug 98252 (in 0.9.8) has contributed
to tiling and fixing several problems with scrolling.  not seeing any slow
scrolling anymore on many bugs.  Please confirm dependencies of this bug, Thanks.

Comment 7 Cathleen 2002-03-27 08:59:42 PST
moving tracking/meta bugs out of milestone pools. 
Comment 8 Dave 2002-04-25 19:36:08 PDT
Adding bug 109050: UI freezes for a few seconds loading pages on RedHat.com
(appears to also present at http://cnnfn.com http://www.nwa.com and
http://www.ussoccer.com, among others). IMO, it's worst at cnnfn.

I think it's a very annoying page loading perf issue, but if it's out of place
here, feel free to remove.
Comment 9 Markus Hübner 2002-05-29 05:34:19 PDT
Adding bug 143046 - causing various perf problems (see in depending bugs).
Comment 10 Nagarajan 2003-01-03 04:32:38 PST
Loading page takes nearly 2-5secs in an 233Mhz PC which has 256 MB RAM support.
The O.S used is Linux 7.2.
Is there any solution for this. If yes, Please suggest.
Comment 11 Dimitrios 2003-01-06 14:04:40 PST
Nagarajan, this is a meta bug, not a support forum. Suggesting to find an
appropriate testcase (i.e. a page that exhibits the slow load problem), ruling
out any bandwidth restriction. If testcase page loading is still slower than on
any other browser on the same machine/OS combination, then check the bugs
depended on this one (see list above). If none of them seems related, please
file a new bug.
Comment 12 bhaskar 2003-11-24 01:09:58 PST
Here is another testcase to reproduce this problem easily in netscape 7/mozilla 
browser on solaris/win2k/linux.
(This problem is appearing even without the animated gifs)
1. Goto this site: http://sandesh.vsnl.com
2. Login with userid: reddy password: reddy
3. Create a new html file in your harddisk like this:

<html>
<script>
function close()
{
 alert('Loaded')
}
</script>
<frameset col=* row=* onload="close()">
<frame src="http://sandesh.vsnl.com/en/mail.html?
sid=I/HutbYs9/4&lang=en&cert=false">
</frameset>
</html>

4. Replace the src value of the above html with the new url you got in step 2.
5. Open the html file created in steps 3&4 in netscape/mozilla browser, notice 
that throbber keep looping and it goes for ever. Status bar shows 
that "Transferring data from sandesh.vsnl.com..." for ever.

6. Now, instead of keeping the above url inside the frame do it like this:
   <html>
   <script>
   window.location="http://sandesh.vsnl.com/en/mail.html?
sid=I/HutbYs9/4&lang=en&cert=false"
   </script>
   </html>
  Note that: the window.location value should be replaced with the new URL 
generated in step 2 (after login)
7. Open the html edited in step 6 in netscape/mozilla browser.The problem is 
NOT reproducable.

Note: If we open the above said url inside the frame then throbber goes for 
infinite loop but if we open as said in step 6 this problem will not appear.
Comment 13 Peter van der Woude [:Peter6] 2004-03-02 10:06:40 PST
sorry if I spam, but i have had quite a few problems with pages where <script>
 was used i/o <script type="text/javascript">. It was like that in Firebird, and
still is.
Comment 14 Markus Hübner 2004-03-03 01:59:36 PST
Tricks is a TRACKING bug!
Please file a new bug about any specific problems.
Comment 15 Marco Castelluccio [:marco] 2011-12-03 03:52:13 PST
Maybe some of the bugs tracked are relevant for Snappy.
Comment 16 (dormant account) 2011-12-08 11:42:19 PST
I'll check this out for snappy issues
Comment 17 (dormant account) 2012-01-19 15:14:41 PST
Everything other than dns is too old to be useful
Comment 18 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2016-06-28 09:57:50 PDT
This bug is not being used to track/prioritize engineering work, so I'm going to close it to make that clear. Bugs filed in individual bugzilla components are still prioritized by those teams.
Comment 19 Worcester12345 2016-07-08 09:20:02 PDT
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #18)
> This bug is not being used to track/prioritize engineering work, so I'm
> going to close it to make that clear. Bugs filed in individual bugzilla
> components are still prioritized by those teams.

That's too bad, as this is a nice catch-all to see where things are at. Hopefully, they will at least add the "perf" keyword to those other bugs, to provide a way to watch performance overall trends.

Note You need to log in before you can comment on or make changes to this bug.