Page Load Extremely Slow With Javascript Enabled

VERIFIED DUPLICATE of bug 89903

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 89903
17 years ago
17 years ago

People

(Reporter: Brian Z, Assigned: asa)

Tracking

({perf})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Build Id: 2001070808

When loading the above URL (I assume the popup window is the problem), it takes 
mozilla forever to load.  If Javascript is disabled, the page loads in 
seconds.  IE has no problem loading this page (with javascript enabled) in just 
seconds.

P800 256MB (on T1) w/ JScript: 40-45 sec!!
w/o JScript: 5sec!
IE: 8-10sec!

Nominating this as blocker because it makes major ecommerace site use 
unacceptable on state of the art equipment!
(Reporter)

Comment 1

17 years ago
Adding Keyword Nomination
Keywords: 4xp, mozilla1.0, nsbeta1, nsCatFood, perf

Comment 2

17 years ago
WFM NT4 0.9.2

Comment 3

17 years ago
I'm getting no errors in the JavaScript Console. The JavaScript used at the
site doesn't involve any large arrays or logic conditions that would hold up
rendering. 

In fact, there is actually less JS processed at the site in 
Mozilla than in IE. Take a look at the included file
http://www.us.buy.com/retail/menu_sub.js :

//* Netscape check - DO NOT LET NS IN
var isMac = navigator.appVersion.indexOf("Mac")>-1
if(document.all && !isMac)
{
document.write ("<table ...   

        etc.  
        etc.



Similarly, this included JS file defines functions used in 
mouseovers at the site, and it similarly excludes non-IE browsers
(via document.all) http://www.us.buy.com/retail/menu.js 

// Build menu
function getMenu(deptName,menuName) {
		
 if(document.all && !mac) {		
   var top = 0;
   var left = 0;
   var thisDept;
			
   if(vizDept != null && vizMenu != null) {


             etc.
             etc.


For example, here is the mouseover definition for the "Computers" 
link at the site:

   <td id="computers" onmouseover="getMenu('computers', 'ComputerMenu')">

Because of the non-standard JavaScript, you will get a submenu 
under it in IE, but not in Moz/NN ...

Comment 4

17 years ago
Not a JS Engine bug. Reassigning to Browser-General component -
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 5

17 years ago
Have filed bug 89979 for the Evangelism issue - 

Comment 6

17 years ago
Resolving as WORKSFORME. Using Mozilla trunk binary 2001070906 WinNT.
The site loads for me in 4-7 seconds every time. 

Brian Z, could you try again with a more recent build and see if the 
problem is still happening for you. If not, please mark this bug "Verified".
If so, you can reopen it; thanks -
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Phil, I think I have this narrowed down.  It has something to deal with myself 
storing the profile on a network drive (through Windows SMB).  I've already 
shown there is a huge loss of speed when using the cache ( bug 89903 ).  
Javascript also falls victim.  Maybe these bugs are related?  This was NOT a 
problem in 4.x, there was no speed loss.  Is there a better way to share 
profiles than storing the files on a server?  Thanks!
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

17 years ago
change serverity to normal, remove of nsCatFood and nsBeta1.. this is a unique 
case.  :)  Perhaps both bugs are related, dupes, or blocking of eachother?
Severity: blocker → normal
Keywords: nsbeta1, nsCatFood

Comment 9

17 years ago
Wfm Build 2001062815 (Mozilla 0.9.2) & Win2k
Load time: 7 sec first, 5 sec reload
Athlon Tbird 850, 128mb

Comment 10

17 years ago
Last night's branch builds wfm on that page.  (my profile is on a network drive 
too)

Comment 11

17 years ago
dupping to 89903. Thats the underlying problem.

*** This bug has been marked as a duplicate of 89903 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
VERIFIED: same problem.
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking: Cache
You need to log in before you can comment on or make changes to this bug.