If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find bar overflows the responsive design view on small widths

RESOLVED FIXED in Firefox 52

Status

()

Firefox
Developer Tools: Responsive Design Mode
RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: Josh Tumath, Unassigned)

Tracking

Trunk
Firefox 52
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20130728 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130728030204

Steps to reproduce:

1. Open responsive design view
2. Open the find bar


Actual results:

The find bar is squashed inside the content area, rather than in it's original position below the navigation bar.

Comment 1

4 years ago
Hi Josh,
mine is Firefox/25.0, i opened in responsive design view and i am feeling the find bar looks fine, not squashed. 
Can you please upload an attachment with the screenshot please.
(Reporter)

Comment 2

4 years ago
Created attachment 784058 [details]
Screenshot of bug
The find in page bar looks actually wider than the width of many of the responsive design views that are built-in. What do you mean by squashed?  

I can type in the Find in page box, and I see the arrows for previous and next. The Highlight All and Match Case buttons do not always seem to get wider and shorter with the view, though.
Component: Untriaged → Developer Tools: Responsive Mode
Flags: needinfo?(josh)
(Reporter)

Comment 4

4 years ago
(In reply to Liz Henry :lizzard from comment #3)
> The find in page bar looks actually wider than the width of many of the
> responsive design views that are built-in. What do you mean by squashed?  
> 
> I can type in the Find in page box, and I see the arrows for previous and
> next. The Highlight All and Match Case buttons do not always seem to get
> wider and shorter with the view, though.

As in my screenshot, the find bar is contained in the responsive design viewport instead of being below the navigation bar and being as wide as the whole browser window.
Flags: needinfo?(josh)
Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0, build ID 20140317030202
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0

The issue is still reproducible on latest Nightly (30) and also release (27.0.1)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 8 → All
Hardware: x86_64 → All

Updated

3 years ago
Duplicate of this bug: 1052022
The problem is still the same in Nightly 38.0a1 (2015-01-29). I clarified the issue summary.

Sebastian
Summary: New find bar gets squashed in responsive design view → Find bar overflows the responsive design view on small widths
Duplicate of this bug: 1110058
Duplicate of this bug: 1153476
This bug appears to be fixed in the new RDM UI shipping in Firefox 52.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Depends on: 1305769
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
You need to log in before you can comment on or make changes to this bug.