buy.com - Submenus provided only for IE, not Mozilla/Netscape

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Phil Schwartau, Assigned: Arun Ranganathan)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Site provides submenus only for browsers that support document.all.
Here are two included JS files used at the site, showing the problem:

http://www.us.buy.com/retail/menu_sub.js :

//* Netscape check - DO NOT LET NS IN
var isMac = navigator.appVersion.indexOf("Mac")>-1
if(document.all && !isMac)
{
document.write ("<table ...   

        etc.  
        etc.



Similarly, this included JS file defines functions used in 
mouseovers at the site, and it similarly excludes non-IE browsers
http://www.us.buy.com/retail/menu.js 

// Build menu
function getMenu(deptName,menuName) {                
 if(document.all && !mac) {             
   var top = 0;
   var left = 0;
   var thisDept;
                        
   if(vizDept != null && vizMenu != null) {


             etc.
             etc.


For example, here is the mouseover definition for the "Computers" 
link at the site:

   <td id="computers" onmouseover="getMenu('computers', 'ComputerMenu')">

Because of the non-standard JavaScript, you will get a submenu 
under it in IE, but not in Moz/NN ...
Summary: Submenus provided only for IE, not Mozilla/Netscape → Submenus provided only for IE, not Mozilla/Netscape
(Reporter)

Comment 1

17 years ago
Priority --> P1 because of the commercial importance of this site.
Priority: -- → P1

Comment 2

17 years ago
*** Bug 89980 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
*** Bug 89981 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Can't find a technical contact for the site. Sending webmaster letter to
webmaster@buy.com
Status: NEW → ASSIGNED
Summary: Submenus provided only for IE, not Mozilla/Netscape → buy.com - Submenus provided only for IE, not Mozilla/Netscape
(Reporter)

Comment 5

17 years ago
Compare Bugscape bug:
 
                  http://bugscape/show_bug.cgi?id=5110

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
follow up with these sites by 0.9.5
Target Milestone: --- → mozilla0.9.5

Comment 8

17 years ago
-> 0.9.6, need to follow up on these asap
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 9

17 years ago
still not fixed, resetting bug
Status: ASSIGNED → NEW
Target Milestone: Nov → ---
Moving.  if buy.com ain't Ecommerce, I don't know what is :)
Assignee: bclary → aruner
Component: US General → US Ecommerce
QA Contact: zach → bclary
Some other interesting code:

if ((navigator.userAgent.indexOf("Netscape6/6.1") != -1) ||
(window.location.hostname.indexOf("netsagecentral.com") != -1) || mac) {
			displaySage = false

Comment 12

17 years ago
This isn't just about optional eyecandy (no-click fly-down menus), it's about
basic content. The buy.com site seems to be actively rejecting potential
customers who use the ``wrong'' web browser.

I can't even use Mozilla to log in
  https://www.us.buy.com/corp/support/login.asp
.

I think the culprit is this code:

  <form [...snip...]>
  [... lots of snippage ...]
  <a href="javascript:document.MoreTrackingInfo.submit()">
  <input type="image" src="https://....../btn_text_login2.gif" >
  </a>
  [...snip...]
  </form>

If I understand
  http://www.w3.org/TR/REC-html40/interact/forms.html
correctly, it would be simpler to do something like this:

  <form [...snip...]>
  [... lots of snippage ...]
  <BUTTON name="submit" value="submit" type="submit">
  <IMG src="https://....../btn_text_login2.gif" alt="login"></BUTTON>
  <input type="submit" value="Login">
  </form>

(Mozilla can handle this, right ?).

Updated

17 years ago
Keywords: evang500
http://www.nexgenmedia.net/evang/buy.com/default.asp.html

Fixed code, menu.js and menu_sub.js.

Anyone want to contact them?
marking fixed, no dhtml menus being used anymore in IE as well.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

15 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.