Getting e-mail for changes for both the locale and the reference (mainly english) versions of an article

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: sphinx_knight, Assigned: jezdez)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [specification][type:feature][LOE:5])

(Reporter)

Description

5 years ago
What problems would this solve?
===============================
Getting article changes by e-mail is a great way to keep track of it. However for l10n this is very useful to keep track of both the translated article and the original (most of the time english) article so that both article can be maintened efficiently.

Who would use this?
===================
Users of MDN, especially people that are translating pages (and that are aware of the "e-mail me article changes" button)

What would users see?
=====================
In the reference article (english one most of the time) : nothing more

In a translated article : either another button close to the "e-mail me" button or the same button offering the choice of having e-mails for locale only or locale + reference



What would users do? What would happen as a result?
===================================================
Click on the button / Click to choose between 'e-mail me locale article change only' / 'e-mail me both locale and reference page changes'

Is there anything else we should know?
======================================
(Reporter)

Updated

5 years ago
Component: General → Localization
OS: Other → All

Updated

5 years ago
Duplicate of this bug: 969422
Blocks: 895006
We could do this by adding a new watch for English emails, adding an option to the UI to subscribe to the English emails beside the current watch option, and optionally add a link to the English notification email taking you directly to the translation interface.

Rough estimate, without the custom email is 1 week.  We'll need input from PM if we want to do the customized email, too.
Severity: normal → enhancement
Flags: needinfo?(hoosteeno)
Whiteboard: [specification][type:feature] → [specification][type:feature][LOE:5]
We can use the existing email to fix this bug -- that means we can go with the LOE:5.
Flags: needinfo?(hoosteeno)
Priority: -- → P2
Proposed UX:

1. Add a "Watch this article" checkbox on the English side of the "Translate Article" page
2. Add a "Watch this translation" checkbox on the translation side "Translate Article" page

:shobson - what do you think?
Flags: needinfo?(shobson)
Hm. I'd rather keep the watch interface elements together. Could we add a second option to the drop down menu where "subscribe" is listed now? Indented a little to show the association.

Subscribe to this translation
  Subscribe to untranslated article

We could continue using "subscribe" on the original article.

I actually prefer the watch wording and would be happy to see us switch to that from subscribe.

Watch this translation
  Watch untranslated (English) article

On the original article page we would switch to 

Watch this article
Flags: needinfo?(shobson)
UX update: Add subscribe pathways in both areas.
Flags: needinfo?(shobson)
Going to stick with subscribe language because there's overlap with other stuff (for example: one "unsubscribes" from every kind of email we send).
needinfo? :jezdez - sanity check and think you can work on this week?
Flags: needinfo?(jezdez)
Update to the UX. Sounds like we have to assume the English is the original (there are very few cases where this is not true, and we can't identify them programmatically).

On English:

Subscribe to this article

On translated pages:

Subscribe to this article
  Subscribe to English version
(Assignee)

Comment 10

4 years ago
This seems reasonably easy after :shobson answered some questions on IRC:

<@jezdez> is this about adding notifications additional to the current per-page-notification?
<@jezdez> or should this be rolled into the same email?
<shobson> jezdez: In each wiki page the gear menu has a subscribe option
<@jezdez> shobson: yes
<shobson> jezdez: Right now, if you are on a translated page, you can subscribe only to that translated page.
<shobson> jezdez: To watch the English version you have to go to the ENglish page and subscribe from there
<shobson> jezdez: We want to add a option to that menu to subscribe to the English page if you are on a translated page.
<shobson> jezdez: So, no change to notifications.
<shobson> jezdez: Just an additional way to subscribe to a notification.
<@jezdez> shobson: to clarify, a user would have to click both the “subscribe to the english original” *and* the “subscribe to this page” link to get notifications for both notifications?
<shobson> jezdez: Yes
Assignee: nobody → jezdez
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(shobson)
Flags: needinfo?(jezdez)
Hah. I thought that PR was the finished feature and I was about to say you have a very underwhelming definition of "reasonably"

"This seems reasonably easy ..." <3-minutes-later> "Opened PR" ;)
Removing the P2 after a conversation with :teoli -- this bug is still valid and a PR for it will still be quite welcome, but we're not going to push to make it a priority in the remaining weeks of 2014.
Priority: P2 → --
(Assignee)

Comment 14

4 years ago
I'm confused, why was it P2 in the first place? Just a remnant from an old ticket triage?

Comment 16

4 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/621856679d62fb3817ea82bc273e0ccb9f56b3e1
fix bug 899665 - add change update subscription link for parents of translated pages

https://github.com/mozilla/kuma/commit/d6f4e0fd998988f074278508734a4248b930d186
Merge pull request #2838 from jezdez/bug899665

fix bug 899665 - add change update subscription link for parents of translated pages

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.