Submenus provided only for IE, not Mozilla/Netscape

VERIFIED DUPLICATE of bug 89979

Status

Tech Evangelism Graveyard
English US
VERIFIED DUPLICATE of bug 89979
17 years ago
3 years ago

People

(Reporter: Phil Schwartau, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Site provides submenus only for browsers that support document.all.
Here are two included JS files used at the site, showing the problem:

http://www.us.buy.com/retail/menu_sub.js :

//* Netscape check - DO NOT LET NS IN
var isMac = navigator.appVersion.indexOf("Mac")>-1
if(document.all && !isMac)
{
document.write ("<table ...   

        etc.  
        etc.



Similarly, this included JS file defines functions used in 
mouseovers at the site, and it similarly excludes non-IE browsers
http://www.us.buy.com/retail/menu.js 

// Build menu
function getMenu(deptName,menuName) {                
 if(document.all && !mac) {             
   var top = 0;
   var left = 0;
   var thisDept;
                        
   if(vizDept != null && vizMenu != null) {


             etc.
             etc.


For example, here is the mouseover definition for the "Computers" 
link at the site:

   <td id="computers" onmouseover="getMenu('computers', 'ComputerMenu')">

Because of the non-standard JavaScript, you will get a submenu 
under it in IE, but not in Moz/NN ...

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 89979 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: Submenus provided only for IE, not Mozilla/Netscape → Submenus provided only for IE, not Mozilla/Netscape
(Reporter)

Comment 2

17 years ago
Verified Duplicate - 
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.