Youtube Live is not supported

RESOLVED DUPLICATE of bug 577084

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 577084
4 years ago
2 years ago

People

(Reporter: sotaro, Unassigned)

Tracking

({compat})

Trunk
ARM
Gonk (Firefox OS)
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome])

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #877024 +++

STR
-[1] visit the URL
  http://www.youtube.com/live/all
-[2] Choose any Live video

RESULT
 Youtube web page shows "Live event playback is not supported on this client"
EXPECTED RESULT
 Can play youtube video

Updated

4 years ago
Component: General → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Updated

4 years ago
Blocks: 871910
No longer blocks: 877024
Open questions:

- Is this supported on Chrome for Android?

- Is this supported on Firefox for Android?
(Reporter)

Updated

4 years ago
Blocks: 877024
No longer blocks: 871910
(Reporter)

Comment 2

4 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> Open questions:
> 
> - Is this supported on Chrome for Android?
> 
> - Is this supported on Firefox for Android?

It is not supported on Chrome for Android nor Firefox for Android, but supported on Youtube app on Android.
Then this isn't a compatibility issue then, which makes this a WONTFIX - we don't track feature requests for external sites here.
No longer blocks: 877024
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

4 years ago
It is not the only other site's problem, but also a protocol implementation's problem. Android youtube app uses "http live streaming protocol to playback". Without the protocol's implementation. Youtube Live can not be playback. Firefox OS does not support "http live streaming protocol". So, even when Youtube does not block on this, Firefox OS can not playback the Youtube Live video.
Resolution: WONTFIX → FIXED
(Reporter)

Updated

4 years ago
Resolution: FIXED → WONTFIX
(Reporter)

Comment 5

4 years ago
I confirmed that chrome beta on android support youtube live.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> I confirmed that chrome beta on android support youtube live.

Okay. So that confirms that this is now a compatibility issue.

When you use YouTube live on Chrome beta for Android, what protocol is being used?

I'm bouncing this over to mobile as this is a general compatibility concern, not really an apps concern (right now, at least).
Blocks: 759982
Component: Preinstalled B2G Apps → Mobile
(Reporter)

Comment 7

4 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Sotaro Ikeda [:sotaro] from comment #5)
> > I confirmed that chrome beta on android support youtube live.
> 
> Okay. So that confirms that this is now a compatibility issue.
> 
> When you use YouTube live on Chrome beta for Android, what protocol is being
> used?

IIRC, youtube uses HTTP Live streaming protocol for android. Need to confirm about it.
(Reporter)

Comment 8

4 years ago
I reconfirm that chrome and chrome beta on android supports youtube live. I misunderstood about it, because some live streamings are not provided for mobile.
I will ask YouTube to confirm if they use the HTTP Live Streaming Protocol for this.
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Sotaro Ikeda [:sotaro] from comment #5)
> > I confirmed that chrome beta on android support youtube live.
> 
> Okay. So that confirms that this is now a compatibility issue.

Yes, but not necessarily an evangelism issue. If Firefox doesn't support the streaming protocol (c4) we need to fix that first. Do we know how YouTube determines that Firefox is not supported? (UA detection or feature detection)
 
> I'm bouncing this over to mobile as this is a general compatibility concern,
> not really an apps concern (right now, at least).

I think you're correct but given that the apps team already has a working relationship with YouTube, I think it's best to have them handle any request for YouTube.
cc Chris Double and Chris Pearce

Can either of you provide any more information about the HTTP Live streaming protocol and support in Firefox for Android and Firefox OS?
needinfo on Chris for comment 11
Flags: needinfo?(chris.double)
(Reporter)

Comment 13

4 years ago
I changed the UA of Firefox for PC to android's chrome one and accessed to the Live streming. In the net log I found the following. From "index.m3u8", it seems HTTP Live Streaming protocol.

http://www.youtube.com/api/manifest/hls/ns/yt-live/id/8pqr_D8PLqA?signature=5594B7FE061EBABA04ED175770D315368B9FB86D.B22B066793D8359B8CB5972487015F23F8B24925&key=yt1&fexp=909546%2C906397%2C929117%2C929121%2C929906%2C929907%2C925720%2C925722%2C925718%2C925714%2C929917%2C929919%2C912521%2C904492%2C904830%2C919373%2C904122%2C932216%2C908534%2C919387%2C936303%2C909549%2C900816%2C936301%2C912711&ipbits=0&sver=3&expire=1375311221&sparams=id%2Cip%2Cipbits%2Cns%2Cexpire&ip=0.0.0.0&upn=k5NKE7jbHeU&file=index.m3u8&cpn=DsSuO4PkCbdpIQ33
Okay. So if we confirm that HLS is not supported in our gecko platform, then this becomes a platform bug in the core video/audio component.
(Reporter)

Comment 15

4 years ago
I know HLS is not supported in gecko. There is a implementation of MPEG-DASH. It is incompatible to HLS.
http://en.wikipedia.org/wiki/Dynamic_Adaptive_Streaming_over_HTTP
(In reply to Sotaro Ikeda [:sotaro] from comment #15)
> I know HLS is not supported in gecko. There is a implementation of
> MPEG-DASH. It is incompatible to HLS.
> http://en.wikipedia.org/wiki/Dynamic_Adaptive_Streaming_over_HTTP

Okay. Looks like we know this is a platform compatibility issue then.
Component: Mobile → Video/Audio
Flags: needinfo?(chris.double)
Product: Tech Evangelism → Core

Updated

4 years ago
Keywords: compat

Updated

4 years ago
Whiteboard: [parity-chrome]
(Reporter)

Comment 17

4 years ago
Firefox for android and B2G uses MediaExtractor::Create() to create parser when using stagefright for video playback. It does not detect if the video is HLS.

http://androidxref.com/4.3_r2.1/xref/frameworks/av/media/libstagefright/MediaExtractor.cpp#53

In andrid, HLS is detected at the following.
http://androidxref.com/4.0.4/xref/frameworks/base/media/libmediaplayerservice/MediaPlayerService.cpp#583

In andrid, HLS data source is created at the following.
http://androidxref.com/4.0.4/xref/frameworks/base/media/libmediaplayerservice/nuplayer/NuPlayer.cpp#97
(Reporter)

Updated

4 years ago
Summary: Youtube Live is not supported on B2G → Youtube Live is not supported
(Reporter)

Updated

4 years ago
Depends on: 900093
(Reporter)

Updated

4 years ago
Depends on: 900095
(Reporter)

Comment 18

4 years ago
I created following bugs for each platform. On desktop, flash plugin is used for the live stream playback.
- Bug 900093 - HLS support on B2G
- Bug 900095 - HLS support on android

Comment 19

4 years ago
My understanding is that Media Source Extensions will be used to support the live streaming type functionality in the browser. Bug 778617 is where that is being tracked. Bug 881512 is the tracking bug for getting enough implemented for YouTube's demo player.

Comment 20

4 years ago
Also see bug 577084.
(Reporter)

Comment 21

4 years ago
Does someone know youtube use MSE for live streaming? If it is supported in the distant future, firefox mobile and B2G lacks support of this service.
Sounds like bug 577084 is tracking this then.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577084

Updated

4 years ago
No longer blocks: 759982
No longer depends on: 900093, 900095
You need to log in before you can comment on or make changes to this bug.