Implement enough of MSE to run the YouTube MSE player

RESOLVED FIXED in mozilla31

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: kinetik, Assigned: kinetik)

Tracking

(Depends on: 1 bug, Blocks: 2 bugs)

Trunk
mozilla31
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(17 attachments, 5 obsolete attachments)

1.86 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
11.72 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
11.18 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
4.78 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
20.50 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
2.31 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
8.55 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
1.23 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
1.58 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
4.23 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
2.03 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
10.64 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
2.29 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
9.31 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
2.68 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
2.05 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
5.54 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
(Assignee)

Description

4 years ago
At a minimum this requires support for multiple decoders and separate audio and video tracks.
(Assignee)

Updated

4 years ago
Depends on: 886196
(Assignee)

Updated

4 years ago
Depends on: 896888
(Assignee)

Updated

4 years ago
Depends on: 905513
(Assignee)

Updated

4 years ago
Depends on: 833023
(Assignee)

Updated

4 years ago
Depends on: 911059

Updated

4 years ago
Duplicate of this bug: 946372

Comment 2

4 years ago
Now that all depending bugs are fixed is this far off?
How come https://www.youtube.com/html5 shows all green except for "MSE & H.264"? Isn't the same system h.264 codec available with MSE?

Comment 3

3 years ago
Can we get an update on MediaSource in Firefox? ETA for release?

Updated

3 years ago
Depends on: 976037

Comment 4

3 years ago
(In reply to Feross Aboukhadijeh from comment #3)
> Can we get an update on MediaSource in Firefox? ETA for release?

From https://wiki.mozilla.org/Platform/MediaSourceExtensions :

"Timeline wise we are hoping to support enough of the spec to support the YouTube production player by the end of the year but will need to collaborate with YouTube to ensure that we're focussing on the right things. We also expect that dash.js compatibility will require a similar feature set."

Comment 5

3 years ago
That's what it said last year already... So actually youtube should work by now. (It doesn't)

Comment 6

3 years ago
(In reply to Feross Aboukhadijeh from comment #3)
> Can we get an update on MediaSource in Firefox? ETA for release?

It's still a work in progress. Bug 976037 comment 1 gives an update on what is playable and what isn't. Basically some 'DASH in JavaScript' implementations are working but the YouTube demo player is not yet.
(Assignee)

Comment 7

3 years ago
Created attachment 8401715 [details] [diff] [review]
bug881512_p1_v0.patch

First patch in a series, more coming soon.
(Assignee)

Updated

3 years ago
Depends on: 238041
(Assignee)

Comment 8

3 years ago
Created attachment 8406651 [details] [diff] [review]
p1: Add start (and rename end) time helper to TimeRanges.
Attachment #8406651 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 9

3 years ago
Created attachment 8406652 [details] [diff] [review]
p2: Allow a SourceBuffer to own multiple subdecoders.  Switch decoders on abort().
Attachment #8401715 - Attachment is obsolete: true
Attachment #8406652 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 10

3 years ago
Created attachment 8406653 [details] [diff] [review]
p3: Hide MediaSourceResource implementation details from HTMLMediaElement.
Attachment #8406653 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 11

3 years ago
Created attachment 8406654 [details] [diff] [review]
p4: Add hidden pref to ignore MIME type in AddSourceBuffer and IsTypeSupported.  For experimental/debugging use only.
Attachment #8406654 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 12

3 years ago
Created attachment 8406657 [details] [diff] [review]
p5: Start processing multiple decoders.
Attachment #8406657 - Flags: feedback?(cajbir.bugzilla)
(Assignee)

Comment 13

3 years ago
Created attachment 8406658 [details] [diff] [review]
p6: Switch video readers on EOF.
Attachment #8406658 - Flags: feedback?(cajbir.bugzilla)
(Assignee)

Comment 14

3 years ago
Created attachment 8406660 [details] [diff] [review]
p7: Crude attempt at segment parser for WebM.
Attachment #8406660 - Flags: feedback?(cajbir.bugzilla)
(Assignee)

Comment 15

3 years ago
The r? patches are ready, pending any review comments.  The f? patches have at least one known bug, so I expect to post updated versions soon.  There's probably at least one more patch to come, too.

Updated

3 years ago
Attachment #8406651 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8406652 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8406654 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8406658 - Flags: feedback?(cajbir.bugzilla) → feedback+

Updated

3 years ago
Attachment #8406653 - Flags: review?(cajbir.bugzilla) → review+

Comment 16

3 years ago
Comment on attachment 8406660 [details] [diff] [review]
p7: Crude attempt at segment parser for WebM.

Review of attachment 8406660 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/media/mediasource/SourceBuffer.cpp
@@ +111,5 @@
>    int64_t offset = (aTime / (double(mMediaDuration) / USECS_PER_S)) * length;
>    return offset;
>  }
>  
> +class ContainerParser {

Does this need a virtual destructor?
Attachment #8406660 - Flags: feedback?(cajbir.bugzilla) → feedback+

Updated

3 years ago
Attachment #8406657 - Flags: feedback?(cajbir.bugzilla) → feedback+
(Assignee)

Comment 17

3 years ago
Created attachment 8410095 [details] [diff] [review]
p5: Start processing multiple decoders.
Attachment #8410095 - Flags: review?(cajbir.bugzilla)
(Assignee)

Updated

3 years ago
Attachment #8406657 - Attachment is obsolete: true
(Assignee)

Comment 18

3 years ago
Created attachment 8410097 [details] [diff] [review]
p6: Switch video readers on EOF.
Attachment #8406658 - Attachment is obsolete: true
Attachment #8410097 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 19

3 years ago
Created attachment 8410098 [details] [diff] [review]
p7: Crude attempt at segment parser for WebM.
Attachment #8406660 - Attachment is obsolete: true
Attachment #8410098 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 20

3 years ago
Created attachment 8410099 [details] [diff] [review]
p8: Unpref Media Source Extensions (for WebM) in non-release builds.
Attachment #8410099 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 21

3 years ago
Created attachment 8410101 [details] [diff] [review]
p9: Temp fix: don't call mParentDecoder functions while SBD runs off decode thread.  Revert when SBD runs on state machine's task queue.
Attachment #8410101 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 22

3 years ago
Created attachment 8410102 [details] [diff] [review]
p10: Don't pretend the entire resource is always completely cached.
Attachment #8410102 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 23

3 years ago
Created attachment 8410103 [details] [diff] [review]
p11: Use the base video and audio queues.  Currently works by shifting media data from the sub-reader queues on each decode call.  Future work could allow the sub-readers to use the base queues directly.
Attachment #8410103 - Flags: review?(cajbir.bugzilla)

Updated

3 years ago
Attachment #8410097 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410098 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410099 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410101 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410102 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410103 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410095 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Comment 24

3 years ago
Created attachment 8410793 [details] [diff] [review]
p12: Remove useless static_casts.
Attachment #8410793 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 25

3 years ago
Created attachment 8410794 [details] [diff] [review]
p13: Don't mix refcounting with auto ptr use.  Rather than try to hang on to the reader, punch the appropriate holes through via the state machine class.
Attachment #8410794 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 26

3 years ago
Created attachment 8410795 [details] [diff] [review]
p14: Delay decoder initialization by indicating that we're waiting for subdecoders to be created.
Attachment #8410795 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 27

3 years ago
Created attachment 8410796 [details] [diff] [review]
p15: Fix bogus indexing of audio/video readers by ditching audio/video reader arrays and using the parent decoder directly.
Attachment #8410796 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 28

3 years ago
Created attachment 8410797 [details] [diff] [review]
p16: Explicitly initialize ReadMetadata's aTags parameter to null.  Also add some null deref tests.
Attachment #8410797 - Flags: review?(cajbir.bugzilla)

Updated

3 years ago
Attachment #8410793 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410794 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410795 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410796 - Flags: review?(cajbir.bugzilla) → review+

Updated

3 years ago
Attachment #8410797 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Updated

3 years ago
Depends on: 1000686
(Assignee)

Comment 29

3 years ago
Comment on attachment 8410099 [details] [diff] [review]
p8: Unpref Media Source Extensions (for WebM) in non-release builds.

Obsoleting pref change patch (p8), it has been moved to bug 1000686.
Attachment #8410099 - Attachment is obsolete: true
(Assignee)

Comment 30

3 years ago
Try push (also includes seeking patches from bug 1000608): https://tbpl.mozilla.org/?tree=Try&rev=533fd846f2b7
(Assignee)

Comment 31

3 years ago
Created attachment 8411625 [details] [diff] [review]
p17: Make sure any released decoders are destroyerd on the main thread.
Attachment #8411625 - Flags: review?(cajbir.bugzilla)

Updated

3 years ago
Attachment #8411625 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Comment 32

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=d75260ca4ed2

	44ad5896ff61	Matthew Gregan — Bug 881512 - Make sure any released decoders are destroyed on the main thread. r=cajbir
	15fe0db2ff8d	Matthew Gregan — Bug 881512 - Explicitly initialize ReadMetadata's aTags parameter to null. Also add some null deref tests. r=cajbir
	81403176036e	Matthew Gregan — Bug 881512 - Fix bogus indexing of audio/video readers by ditching audio/video reader arrays and using the parent decoder directly. r=cajbir
	6c69283f7713	Matthew Gregan — Bug 881512 - Delay decoder initialization by indicating that we're waiting for subdecoders to be created. r=cajbir
	1eddd13262de	Matthew Gregan — Bug 881512 - Don't mix refcounting with auto ptr use. Rather than try to hang on to the reader, punch the appropriate holes through via the state machine class. r=cajbir
	5fbc68a34f62	Matthew Gregan — Bug 881512 - Remove useless static_casts. r=cajbir
	199c040d09f0	Matthew Gregan — Bug 881512 - Use the base video and audio queues. Currently works by shifting media data from the sub-reader queues on each decode call. Future work could allow the sub-readers to use the base queues directly. r=cajbir
	c116a4499d82	Matthew Gregan — Bug 881512 - Don't pretend the entire resource is always completely cached. r=cajbir
	5ea033583b20	Matthew Gregan — Bug 881512 - Temp fix: don't call mParentDecoder functions while SBD runs off decode thread. Revert when SBD runs on state machine's task queue. r=cajbir
	a14f9763bf8f	Matthew Gregan — Bug 881512 - Crude attempt at segment parser for WebM. r=cajbir
	cf3e31d25944	Matthew Gregan — Bug 881512 - Switch video readers on EOF. r=cajbir
	59ffec98e96f	Matthew Gregan — Bug 881512 - Start processing multiple decoders. r=cajbir
	18754facd070	Matthew Gregan — Bug 881512 - Add hidden pref to ignore MIME type in AddSourceBuffer and IsTypeSupported. For experimental/debugging use only. r=cajbir
	f8ece490919d	Matthew Gregan — Bug 881512 - Hide MediaSourceResource implementation details from HTMLMediaElement. r=cajbir
	d978fe16633a	Matthew Gregan — Bug 881512 - Allow a SourceBuffer to own multiple subdecoders. Switch decoders on abort(). r=cajbir
	c570bcfd29b4	Matthew Gregan — Bug 881512 - Add start (and rename end) time helper to TimeRanges. r=cajbir
(Assignee)

Updated

3 years ago
Summary: Implement enough of MSE to run the YT demo player → Implement enough of MSE to run the YouTube MSE player
(Assignee)

Comment 33

3 years ago
Created attachment 8413148 [details] [diff] [review]
p18: Use MediaTaskQueue to run MSE tasks rather than a per-MSE thread.
Attachment #8413148 - Flags: review?(cajbir.bugzilla)

Updated

3 years ago
Attachment #8413148 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Comment 34

3 years ago
Comment on attachment 8413148 [details] [diff] [review]
p18: Use MediaTaskQueue to run MSE tasks rather than a per-MSE thread.

p18 was planned for a near future cleanup in a different bug, but it turned out to be needed to fix an orange on TBPL debug builds:

3587 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/mediasource/test/test_MediaSource.html | Assertion count 1 is greater than expected range 0-0 assertions.

...which didn't show up on try because the same test failed for a different (innocuous) reason.
Attachment #8413148 - Attachment description: p18: Use MediaTaskQueue to run MSE tasks rather than a per-MSE thread. r=cajbir → p18: Use MediaTaskQueue to run MSE tasks rather than a per-MSE thread.
(Assignee)

Comment 35

3 years ago
Landed p18: https://hg.mozilla.org/integration/mozilla-inbound/rev/30b52597454b
https://hg.mozilla.org/mozilla-central/rev/c570bcfd29b4
https://hg.mozilla.org/mozilla-central/rev/d978fe16633a
https://hg.mozilla.org/mozilla-central/rev/f8ece490919d
https://hg.mozilla.org/mozilla-central/rev/18754facd070
https://hg.mozilla.org/mozilla-central/rev/59ffec98e96f
https://hg.mozilla.org/mozilla-central/rev/cf3e31d25944
https://hg.mozilla.org/mozilla-central/rev/a14f9763bf8f
https://hg.mozilla.org/mozilla-central/rev/5ea033583b20
https://hg.mozilla.org/mozilla-central/rev/c116a4499d82
https://hg.mozilla.org/mozilla-central/rev/199c040d09f0
https://hg.mozilla.org/mozilla-central/rev/5fbc68a34f62
https://hg.mozilla.org/mozilla-central/rev/1eddd13262de
https://hg.mozilla.org/mozilla-central/rev/6c69283f7713
https://hg.mozilla.org/mozilla-central/rev/81403176036e
https://hg.mozilla.org/mozilla-central/rev/15fe0db2ff8d
https://hg.mozilla.org/mozilla-central/rev/44ad5896ff61
https://hg.mozilla.org/mozilla-central/rev/30b52597454b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
YouTube still says that the browser does not support Media Source Extensions even with the patched build. Is it YouTube's issue?
(Assignee)

Comment 38

3 years ago
The functionality is hidden behind a pref for now; opening that up (for WebM only) is bug 1000686.

Comment 39

3 years ago
With both media.mediasource.enabled and media.mediasource.ignore_codecs set to true, youtube videos just play for a few seconds and skip to the end, not sure if this is normal.
With media.mediasource.enabled set to true and media.mediasource.ignore_codecs set to false, they seem to play normally but only 360p/720p is available, which I guess is normal.

I'm using the latest nightly 31.0a1 (2014-04-27) on Arch Linux.

Comment 40

3 years ago
(In reply to AnAkkk from comment #39)
> With both media.mediasource.enabled and media.mediasource.ignore_codecs set
> to true, youtube videos just play for a few seconds and skip to the end, not
> sure if this is normal.
> With media.mediasource.enabled set to true and
> media.mediasource.ignore_codecs set to false, they seem to play normally but
> only 360p/720p is available, which I guess is normal.

If you right click on the video, choose "stats for nerds", do you see it using the Dash player and WebM?

Comment 41

3 years ago
With media.mediasource.ignore_codecs = true, DASH:yes, video/mp4 and it plays for exactly 3 seconds before skipping to the end.
With media.mediasource.ignore_codecs = false, DASH:no, video/mp4 and it works fine.

Comment 42

3 years ago
Sorry, it is only supposed to work on WebM videos?

Comment 43

3 years ago
Nevermind. On some videos it does show DASH: yes, video/webm and I have the exact same issue.
Filed https://bugzilla.mozilla.org/show_bug.cgi?id=1002019 because setting media.mediasource.enabled to true and enabling YouTube's HTML5 player causes Nightly to freeze/hang/quit responding.

Comment 45

3 years ago
(In reply to AnAkkk from comment #42)
> Sorry, it is only supposed to work on WebM videos?

The current implementation was built and tested with WebM. It is planned to improve support to MP4. It may work already on some platforms or combinations of decoder but I wouldn't expect it.
(Assignee)

Comment 46

3 years ago
(In reply to AnAkkk from comment #41)
> With media.mediasource.ignore_codecs = true, DASH:yes, video/mp4 and it
> plays for exactly 3 seconds before skipping to the end.

media.mediasource.ignore_codecs is for developer-only testing, please don't set it unless you have a good reason, and expect problems (but don't report them) when you do.

(In reply to AnAkkk from comment #43)
> Nevermind. On some videos it does show DASH: yes, video/webm and I have the
> exact same issue.

Please file a new bug and CC me.  Reporting new issues in a closed bug has a high probability of the issue being overlooked.
https://hg.mozilla.org/mozilla-central/rev/bc6a9d65b84f
(Assignee)

Comment 48

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #47)
> https://hg.mozilla.org/mozilla-central/rev/bc6a9d65b84f

Oops, that's actually for bug 1000686, but I forgot to fix the commit message when splitting the bugs.

Updated

3 years ago
Depends on: 1002404
Depends on: 1001952

Comment 49

3 years ago
(In reply to Matthew Gregan [:kinetik] from comment #46)
> Please file a new bug and CC me.  Reporting new issues in a closed bug has a
> high probability of the issue being overlooked.

This won't be necessary, my issue seem to be fixed with the latest nightly.

Updated

3 years ago
Depends on: 1005366

Comment 50

3 years ago
In my case, (Nightly 32.0a1, BuildID=20140505030202 )
before setting media.mediasource.enabled to true, 3/6 are green in https://www.youtube.com/html5 :
"HTMLVideoElement", "H.264" and "WebM VP8".

After setting media.mediasource.enabled to true, 5/6 are green :
all except for "MSE & H.264".
Is this expected?
Shouldn't the "MSE & H.264" be green now too?
(Assignee)

Comment 51

3 years ago
(In reply to Kostas from comment #50)
> Shouldn't the "MSE & H.264" be green now too?

MP4 (H.264, etc.) aren't supported in MSE yet.  We're concentrating on WebM on YouTube right now, other functionality will follow.

Comment 52

3 years ago
(In reply to Matthew Gregan [:kinetik] from comment #51)
> (In reply to Kostas from comment #50)
> > Shouldn't the "MSE & H.264" be green now too?
> 
> MP4 (H.264, etc.) aren't supported in MSE yet.  We're concentrating on WebM
> on YouTube right now, other functionality will follow.
Thanks for the quick reply.

Comment 53

3 years ago
So, the target milestone for this bug - Firefox 31 has been released, but MSE on YouTube still doesn't work properly. Seeking sometimes takes a lot of time, seeking back doesn't work at all and repeat also doesn't work.
I tried the latest Nightly, but it seems that it only got worse - sometimes seeking just hangs.
Is bug 1024858 the only reason why it's still broken or there're some other YouTube related bugs?
Flags: needinfo?(kinetik)
(Assignee)

Comment 54

3 years ago
Follow bug 1000686, which is tracking enabling this functionality by default in nightly builds.  This bug covered the initial implementation, but there are a number of bugs remaining which are being worked on now.
Flags: needinfo?(kinetik)
Blocks: 1027519

Comment 55

3 years ago
2 days ago youtube deprecated flash (now max 720p) and upped html5 functionality significantly, adding 60fps and super high resolutions to html5.

I think the slow approach to this needs changing I consider it now urgent to have fully working mp4 support on html5, the internet is plastered with "chrome only for 6ofps youtube"

It also works on IE11 in windows 8 although the internet is not making that clear its just saying it works on IE11 full stop but it does require windows 8.

Comment 56

3 years ago
I just switched from Firefox to Nightly and I manually enabled MSE & h264 so I can use YouTube.

The two biggest problems I have with it right now are:

- Seeking doesn't work. Seeking within the 'buffered range' is slow and takes ~10 seconds. Seeking beyond the buffered range doesn't work at all.

- Videos with inVideo branding (example: https://srv.tuxplace.nl/hosted/screenshots/2014-11-03-13-36-00.png , icon in the top right corner) will freeze at the exact moment the icon will appear.

Comment 57

3 years ago
I wanted to provide some help to anyone frustrated by this. Here is an article about a very helpful plugin that forces flash in HD to run in nightly instead of html5, but you can select between the two. http://www.ghacks.net/2014/10/20/force-flash-video-on-youtube-in-firefox/ and a link to the plugin http://barisderin.com/?p=2225 . For the time being, this makes everything run smoothly.

Comment 58

3 years ago
(In reply to DrDumbass from comment #57)
> I wanted to provide some help to anyone frustrated by this. Here is an
> article about a very helpful plugin that forces flash in HD to run in
> nightly instead of html5, but you can select between the two.
> http://www.ghacks.net/2014/10/20/force-flash-video-on-youtube-in-firefox/
> and a link to the plugin http://barisderin.com/?p=2225 . For the time being,
> this makes everything run smoothly.

This comment is not quite related but I want to say using Flash was obsoleted because of slowness and lag. I'd rather see 320p than using Flash on my slow computer.

Comment 59

3 years ago
(In reply to daniel.2345 from comment #58)
> (In reply to DrDumbass from comment #57)
> > I wanted to provide some help to anyone frustrated by this. Here is an
> > article about a very helpful plugin that forces flash in HD to run in
> > nightly instead of html5, but you can select between the two.
> > http://www.ghacks.net/2014/10/20/force-flash-video-on-youtube-in-firefox/
> > and a link to the plugin http://barisderin.com/?p=2225 . For the time being,
> > this makes everything run smoothly.
> 
> This comment is not quite related but I want to say using Flash was
> obsoleted because of slowness and lag. I'd rather see 320p than using Flash
> on my slow computer.

I'm on the opposite side. I have a fast laptop and I'm fed up being forced webm which doesn't use hardware acceleration. I'd much rather have Flash and h.264 with HW acceleration over webm eating battery life and burning my lap. Anyway, bugzilla isn't an Internet forum so let's end this.

Updated

3 years ago
Depends on: 1113776

Comment 60

3 years ago
Hi all, in bug #833023 Jan Gerber said that:

>> - http://www.youtube.com/html5 states that the latest Aurora does not
>> support "MSE & WebM VP9".
>For MSE support, check Bug 881512

And I came here, saw this bug is marked as "fixed", but in https://www.youtube.com/html5 it still shows "MSE & WebM VP9" not supported. (I'm using latest Nightly) 

How could I fix this or it has not been implemented into Firefox yet?
It is temporarily disabled (see bug 1097436 and bug 1108059).

Comment 62

2 years ago
On win7 youtubne reports all codecs available (without ignore_codecs) but when youtube tries to start playing it spins for ages and eventually falls back to non 60fps codec.

beta testers are reporting its been working fine and are astonished its not in the release version

so whast the issue with ff36?

code removed?
not working yet on windows?
You need to log in before you can comment on or make changes to this bug.