Closed Bug 9012 Opened 21 years ago Closed 15 years ago

Startup time for Address Book window is 1 second slower than 4.6

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED WONTFIX
Future

People

(Reporter: lchiang, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: nab-perf)

Startup time for Address Book window is 1 second slower than 4.6

Here are our automated results:
Address Book Startup Time
4.6: 7.347000 s
5.0: 8.414000 s

System and Build:
Win95, 166 MHz, 48mg RAM, LAN
Build Number: 1999062808

Methodology:
Measures the time it took to open up the Address Book window. No other
application is running except the QA Partner client and Agent [used for
automation].

Description

Address Book is started by picking up the Address Book menu item.. Timer is
started as soon as the menu item is selected and wait till Address Book window
is loaded completely. Timer is stopped at this moment and the elapsed time is
reported as the Address Book start up time.

Pls let me know if you need more details.  The difference between 4.6 and 5.0 is
not that great so I've categorized the severity as normal.
Whiteboard: [perf]
Paul or Candice, we don't have any disk I/O around opening an AB yet, right? If
that's true, I bet we get a bunch slower when we're actually reading the AB DB
when we open it.
Is there a difference between the first time you open and the second time? Most
of that difference could be due to the time it takes to load dlls. This time
should be reduced a lot when we start re-basing dlls correctly (see bug # 7249)
- note this is a windows only thing.
I'll find that out for you.
There is about a 1.2 second time difference with opening the address book two
consecutive times in the same apprunner session.  This is on the same machine
which these performance timings are on.  This is with today's release build.
Blocks: 9161
Status: NEW → ASSIGNED
Target Milestone: M9
Bringing up XUL windows in general is very slow.  I my machine the compose window
comes up even slower than the address book.  We need to work on the overall
performance of these dialogs.  I guess we should talk to the XP group and
possibly file a bug on their performance as well.
Target Milestone: M9 → M10
Have not had a chance to talk to the other groups about the speed.
What is the current status of the speed here.  Seamonkey is much faster today
than it was when this bug was written.  Is this still slower than 4.x?
Will check next week when performance tests are run again.
Target Milestone: M10 → M14
Moving to post PR1.
I think this needs to be retested again.  I'll ask Suresh to do so.
QA Contact: lchiang → suresh
Suresh - can you post your latest numbers here and retest as needed? Thanks.
Here are some numbers collected using 1999-12-20-09-M13 windows commercial
build.  Bindu's automation script just loads the addressbook window using
'mozilla -addressbook'.

NOTE: Slight change in the system tested. The system I tested is Win95, 166 MHz,
64 MB RAM. (Originally it states 48 MB RAM).

Method 1: Using 'mozilla -addressbook'.
Intial launch: 16.791 seconds
Re-launch: 15.643, 15.769, 15.768 seconds(3 runs).

Method 2: Using 'Task | addressbook' after loading the 3-pane mail window.
(This is done manually using a stop watch. So there can be little room for
error).
Initial launch: 3.28 seconds.
Re-launch: 1.75, 1.81, 1.81 seconds. (3 runs)
Keywords: perf
Bulk add of "perf" to new keyword field.  This will replace the [PERF] we were
using in the Status Summary field.
Target Milestone: M14 → M15
Bumping to M15
Can we time this again?  I would be interested in the current comparison.
Whiteboard: [perf]
Suresh - when you have a moment, can you get results for Paul?  We don't show 
this in our performance data. Thanks.
Using 2000-02-07-09-M14 windows commercial build.
Win95, 133 Mhz, 64 MB RAM.

 1. Startup time for Address Book, using Task | Messenger
       5.74, 5.39, 5.22 seconds. (3 runs)

 2. Startup time for Address Book, using mozilla -addressbook
     17.08, 16.30, 16.54 seconds. 
Mass moving to M17
Target Milestone: M15 → M17
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW
marking WONTFIX.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Target Milestone: M17 → Future
oops. that was supposed to get a future, not a wontfix.
reassigning to chuang.
Assignee: putterman → chuang
Status: REOPENED → NEW
Anything need to be done with this bug?
QA Contact: suresh → stephend
Blocks: 7251
I'd like to get this tested and worksforme/verified, but I need some additional
information.  Is this just testing a blank addressbook? If so, I can get this
done today.
This is fairly old bug!
I think testing an address book with entries would be good.  What is the size of
your address book?  I think Esther has an address book of 800 entries.
Only ~100 entries.  For testing this, do you remember the criteria (addressbook
size) for the 1st time we performance tested this?  Otherwise, there wouldn't be
a consistency, resulting in an inaccurate metric.
I cannot recall.  suresh?
Would running this on a P133 with 64 megs count?  With an empty address book?
(It's as close to the original filing/data that I think we can get.)
No longer blocks: 7251
Update, running a P133 with 64 megs of RAM, with no collected/personal address 
books on Windows 98 took 8.41 seconds to load using Tasks | Address Book.  
No longer blocks: 7251
*** Bug 89066 has been marked as a duplicate of this bug. ***
reassigning to cavin
Assignee: chuang → cavin

*** This bug has been marked as a duplicate of 117863 ***
Status: NEW → RESOLVED
Closed: 20 years ago18 years ago
Resolution: --- → DUPLICATE
Gag, I'm sorry.

Loading ! = startup.  Sigh.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
taking, as it's nab perf and I'm in there now.

donner, is 1 second correct?  what are you numbers on the test machine?
Assignee: cavin → sspitzer
Status: REOPENED → NEW
Whiteboard: nab-perf
I've uploaded the latest metrics to the url above
(http://www.mozilla.org/mailnews/performance/abookperf.html), but 4.7x shows us
at .57 seconds to launch from the Communicator menu (similar to our
implementation of the Tasks menu).  Outlook Express takes roughly 0.60 seconds.
 The latest build of 6.x (2002-02-17-08) takes 3 sec 28 mil.  I think we may be
closer on raw launch times (each component's executable, rather than from a menu
in our existing apps).  I'll report back with those figures, too.

I thought you could run the 4.7x client's address book as a standalone app 
under Win32, but I'm mistaken.  I also can't get data at the moment on our perf 
machine, because it has other profiles for perf (page load, etc) that I can't 
wipe out.  Anyways, their stand-alone app (OE 6) wab.exe, takes 0.67 seconds to 
launch.
Flags: blocking1.6b?
Flags: blocking1.6b? → blocking1.6b-
Product: Browser → Seamonkey
Assignee: sspitzer → mail
I'm marking this as wontfix as after discussion on IRC, there isn't too much
concern over this at the moment. If it starts looking bad we can always reopen.
Status: NEW → RESOLVED
Closed: 18 years ago15 years ago
Resolution: --- → WONTFIX
Verified (at least for now).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.