Codesighs is never run by buildbot, but is still enabled in mozconfigs

RESOLVED FIXED in mozilla26

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: standard8, Assigned: emorley)

Tracking

(Blocks 1 bug)

Trunk
mozilla26
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

6 years ago
Codesighs got removed from buildbot as part of bug 803736. However, its still enabled in the mozconfig files, and still being built.

If we're not using it, we should remove the option from the mozconfig files, and maybe even remove its code as well (similar to bug 823915).
Assignee

Comment 2

6 years ago
Posted patch Patch v1Splinter Review
Attachment #787065 - Flags: review?(gps)
Assignee

Updated

6 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Assignee

Updated

6 years ago
No longer blocks: 823915
Duplicate of this bug: 823915
Comment on attachment 787065 [details] [diff] [review]
Patch v1

Review of attachment 787065 [details] [diff] [review]:
-----------------------------------------------------------------

I don't know the full history of codesighs and don't know if it is appropriate to remove all of its code. We may no longer run codesighs on automation. However, automation is only one consumer of the tree. Is anyone else running codesighs? Does it deserve to die regardless?

Anyway, I just asked that question in #build and Ms2ger says it can die. That's enough of a second opinion for me, so, r+.
Attachment #787065 - Flags: review?(gps) → review+
Reporter

Updated

6 years ago
Blocks: 904010
https://hg.mozilla.org/mozilla-central/rev/2654301601dd
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
FWIW, codesighs's advantages over the tool in bug 659950 are:

 * it shows useful diffs explaining what changed

 * it adds up the data prior to some things that cause quantization, i.e., parts of the library having their sizes rounded up to some rounder size (although I'm not sure how big of an effect that is these days)

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.