[MP] Defect - URL textbox not showing in appbar in snapped

VERIFIED FIXED in Firefox 26

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: rsilveira, Assigned: rsilveira)

Tracking

Trunk
Firefox 26
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=defect c=tbd u=tbd p=2)

Attachments

(3 attachments, 1 obsolete attachment)

Assignee: nobody → rsilveira
Blocks: metrov1it12
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Summary: URL textbox not showing in appbar in snapped → Defect - URL textbox not showing in appbar in snapped
Whiteboard: feature=defect c=tbd u=tbd p=2

Updated

6 years ago
Duplicate of this bug: 904008
Blocks: metrov1it13
No longer blocks: metrov1it12
Posted patch Patch v1 (obsolete) — Splinter Review
This patch removes the contextual buttons in snapped view.

It also collapses the hidden buttons on start screen, making the url bar take the extra space.
Attachment #789269 - Flags: review?(ally)
The collapsing of the hidden buttons is for the full screen (not snapped) tracked by bug 903687. Fixed them together because it was the same css selector.

Updated

6 years ago
Whiteboard: feature=defect c=tbd u=tbd p=2 → feature=defect c=tbd u=tbd p=2, [preview]
Summary: Defect - URL textbox not showing in appbar in snapped → [MP] Defect - URL textbox not showing in appbar in snapped
Whiteboard: feature=defect c=tbd u=tbd p=2, [preview] → [preview] feature=defect c=tbd u=tbd p=2
Duplicate of this bug: 904427
So, from my memory of talks with Yuan about bug 903687, we don't want to have the urlbar cover the /entire width/ of the toolbar on either autocomplete or the start screen when we're not snapped. The existing behavior (with the fade between button states and the like) is somewhat more in line with the UX mockups.

However, the new snap view behavior proposed here is fantastic. :D
Yes, after seeing the comps at [1] I think it's better to not widen the url bar, I'll post another patch.

[1] http://people.mozilla.com/~shorlander/files/design-specs-metro/images-design-spec-sheets/Windows8-i03-DesignSpec-%28NavBar%29-i02.jpg
Posted patch Patch v2Splinter Review
Not messing with fullscreen urlbar width anymore.
Attachment #789269 - Attachment is obsolete: true
Attachment #789269 - Flags: review?(ally)
Attachment #789696 - Flags: review?(jwilde)
Attachment #789696 - Flags: review?(ally)
Comment on attachment 789696 [details] [diff] [review]
Patch v2

Review of attachment 789696 [details] [diff] [review]:
-----------------------------------------------------------------

Seems quite reasonable. jwilde, any objections?
Attachment #789696 - Flags: review?(ally) → review+
Comment on attachment 789696 [details] [diff] [review]
Patch v2

Review of attachment 789696 [details] [diff] [review]:
-----------------------------------------------------------------

Looks awesome to me.
Attachment #789696 - Flags: review?(jwilde) → review+
https://hg.mozilla.org/mozilla-central/rev/b8f0329613e6
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Posted image screenshot.png
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130827030201

WFM
Tested using latest Nightly for iteration #13. The URL bar is now visible while in snapped view, as shown in the attached screenshot.
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.