CTP icon disappears on mouse hover on retina displays

VERIFIED FIXED in Firefox 25

Status

()

Core
Plug-ins
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Felipe, Assigned: gfritzsche)

Tracking

Trunk
mozilla26
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ verified, firefox26+ verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
STR
 - open a page with Flash
 - hover over CTP blue icon in the urlbar

Result: icon disappears while mouse is over it
(Reporter)

Comment 1

5 years ago
If this is not an obvious dupe I'd bet it only affects Firefox running on a Mac retina screen
(Reporter)

Comment 2

5 years ago
Created attachment 788470 [details]
mouse-over-plugin-icon.png
(Assignee)

Comment 3

5 years ago
(In reply to :Felipe Gomes from comment #1)
> If this is not an obvious dupe I'd bet it only affects Firefox running on a
> Mac retina screen

It's fine for me on a non-retina screen, so it's possible.
(Assignee)

Comment 4

5 years ago
Created attachment 788890 [details]
testcase

I have no idea what could be causing this, a regression window would be great.
(Assignee)

Updated

5 years ago
Keywords: helpwanted, qawanted, regressionwindow-wanted
Priority: -- → P3
(Reporter)

Comment 5

5 years ago
Last good nightly: 2013-07-19
First bad nightly: 2013-07-20

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af4e3ce8c487&tochange=bf73e10f5e54
(Assignee)

Comment 6

5 years ago
Thanks :)

Candidates: bug 888292, bug 889788, bug 888908.
Likely suspect: bug 888292, which touched the style and icons for @2x themes.
Keywords: helpwanted, qawanted, regressionwindow-wanted
(Assignee)

Updated

5 years ago
Summary: CTP icon disappears on mouse hover → CTP icon disappears on mouse hover on retina displays
(Assignee)

Updated

5 years ago
Blocks: 888292
(Assignee)

Comment 7

5 years ago
Created attachment 788989 [details]
testcase

With layout.css.devPixelsPerPx;2 i can reproduce this for the non-hidden plugin case.
For non-"hidden" plugins, it ends up using the old blue plugin icon instead of the new, grey and flat, plugin icon.
Attachment #788890 - Attachment is obsolete: true
(Assignee)

Comment 8

5 years ago
Created attachment 789002 [details] [diff] [review]
Remove outdated 2dppx icon style

Looks like this is just being overwritten by a left-over & outdated 2dppx section.
Assignee: nobody → georg.fritzsche
(Assignee)

Comment 9

5 years ago
Comment on attachment 789002 [details] [diff] [review]
Remove outdated 2dppx icon style

Jaws, can you review this?

What happened here is that bug 888292 added a 2dppx list-style-image for #plugins-notification-icon at [1] but left an old one that overrides it at. This just removes the second, outdated, occurence.

[1] http://hg.mozilla.org/mozilla-central/annotate/9ab28833eda0/browser/themes/osx/browser.css#l3198
[2] http://hg.mozilla.org/mozilla-central/annotate/9ab28833eda0/browser/themes/osx/browser.css#l3259
Attachment #789002 - Flags: review?(jaws)
Attachment #789002 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/c0525bc05b74
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Comment 12

5 years ago
Comment on attachment 789002 [details] [diff] [review]
Remove outdated 2dppx icon style

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Plugin-doorhanger redesign.
User impact if declined: Visual only, plugin notification icon vanishing on mouse-over.
Testing completed (on m-c, etc.): on m-c for a while without incidents
Risk to taking this patch (and alternatives if risky): Very low, visual only removal of duplicate definition
String or IDL/UUID changes made by this patch: None.
Attachment #789002 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox24: --- → unaffected
status-firefox25: --- → affected
status-firefox26: --- → fixed
tracking-firefox25: --- → +
tracking-firefox26: --- → +

Updated

5 years ago
Attachment #789002 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Matt, can you please verify this is fixed?
Keywords: verifyme
QA Contact: mwobensmith
Duplicate of this bug: 918236
Confirmed broken on FF25 2013-08-01.
Verfied fixed on FF25, FF26 2013-09-23.
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
status-firefox26: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.