Closed Bug 903676 Opened 6 years ago Closed Last year

Long log messages in Console cause overflow (<file-name>:<line-number> is shifted over)

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: juber, Unassigned)

References

Details

Attachments

(1 file)

UA: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

STEPS TO REPRODUCE:
    * open console
    * run "new Array(500).join('x')"
    * observe that the blue <file-name>:<line-number> info is shifted way far right and you need to scroll over to read it

EXPECTED BEHAVIOR:
    * <file-name>:<line-number> info should always be visible
I do have a fix for this in bug 760876.
Depends on: console-output, 760876
Word wrapping causes performance issues. Fix for this bug has been reverted from bug 760876.
No longer depends on: 760876
Priority: -- → P3
Duplicate of this bug: 983253
It was impossible to find this bug using Bugzilla search.
Summary: Logging something large to the console causes <file-name>:<line-number> to be shifted over. → Long log messages in Console cause overflow (<file-name>:<line-number> is shifted over)
Duplicate of this bug: 944048
Product: Firefox → DevTools
we do wrap long strings now
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.