Closed Bug 904204 Opened 6 years ago Closed 6 years ago

[MP] Defect - Hover state on buttons (like the bookmark star, download) persists after you tap the button

Categories

(Firefox for Metro Graveyard :: App Bar, defect, P2)

26 Branch
x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 26

People

(Reporter: Samvedana, Assigned: jimm)

References

Details

(Whiteboard: [preview] feature=defect c=firefox_start u=metro_firefox_user p=1)

Attachments

(2 files)

Attached image app_bar state.png
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130812030209
Built from http://hg.mozilla.org/mozilla-central/rev/87c1796bc46c

STR
- Bookmark several pages by tapping the bookmark "Star"
- Tap on the "Download" button and open new tab
- Tap on the "Pin" several times 
- Tap the "Previous" and "Next" buttons when searching for text 

Actual result
To see actual result please open attached screenshot.

Expected result
I don't know exactly how it should look, but it looks like this can not be expected behavior.
Whiteboard: [preview-triage] feature=defect c=firefox_start u=metro_firefox_user p=0
This bug has following defects:
1. Download button- I see Blue ring in download button after downloading any file. This can be seen in new tab too. 
2. Bookmark button - When any site is bookmarked and unbookmarked, I see third state of icon. If I tap on screen to hide app bar and then again open appbar, the icon looks okay.
3.Pin button - This is also working same as bookmark button.
Blocks: metrov1backlog
No longer blocks: metrov1defect&change
Summary: Defect - Hover state on buttons (like the bookmark star, download) persists after you tap the button → [MP] Defect - Hover state on buttons (like the bookmark star, download) persists after you tap the button
Whiteboard: [preview-triage] feature=defect c=firefox_start u=metro_firefox_user p=0 → [preview] feature=defect c=firefox_start u=metro_firefox_user p=0
Depends on: 904980
Blocks: 904980
No longer depends on: 904980
We landed a fix for this down in widget that's still in place, we send a mouse move after the mouse up. Somewhere between that and the front end this regressed. I've confirmed moving the mouse in the window has the desired effect. Not sure what broke with the synthetic move even we send.
Attached patch fixSplinter Review
Don't think we need LogToPhys conversion on this since the mouse position is pretty random.
Attachment #790397 - Flags: review?(netzen)
Hey Jim, can you provide a point estimate.
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Flags: needinfo?(jmathies)
Priority: -- → P2
QA Contact: jbecerra
Attachment #790397 - Flags: review?(netzen) → review+
Flags: needinfo?(jmathies)
Whiteboard: [preview] feature=defect c=firefox_start u=metro_firefox_user p=0 → [preview] feature=defect c=firefox_start u=metro_firefox_user p=1
Duplicate of this bug: 904992
Duplicate of this bug: 904980
For download button, Where I can see blue ring due to defect, Regression window is as below:

Good
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20130802 Firefox/25.0
Build ID: 20130802030204
Built from http://hg.mozilla.org/mozilla-central/rev/76a944fa6b25

Bad
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20130803030205
Built from http://hg.mozilla.org/mozilla-central/rev/d0edf8086809

Regression window for the bookmark and pin button is different. I am still working on it.
Hi Jim, Do you need regression window for this?
Flags: needinfo?(jmathies)
(In reply to Samvedana (:Samvedana) from comment #9)
> Hi Jim, Do you need regression window for this?

No thanks, I think we're ok, we tracked down the problem. We can confirm this and the dupes once the fix here lands.
Flags: needinfo?(jmathies)
https://hg.mozilla.org/mozilla-central/rev/986f2f71d1b6
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130823030204
Built from http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result. Still sometime see issue for download button. Filing new bug for it.
Status: RESOLVED → VERIFIED
Blocks: 908890
Went through the following "defect" for iteration #13 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-27-03-02-01-mozilla-central/

- Went through the original test cases(s) from comment #0 without any issues
- Went through the original test case(s) from comment #1 without any issues

Bookmark Star:

- Tapped on the bookmark star several times (slowly & quickly) and ensured there was no middle state
- Ensured that the bookmarked websites appeared under "Bookmarks" in the awesome screen
- Ensured that when returning to a bookmarked website, the bookmark star appeared in the correct state
- Ensured tapping and removing the bookmark using the "Star", that the website was also removed from the "Bookmarks" under the awesome screen
- Ensured that going back and forth using the "Next/Previous" arrows didn't change the states
- Ensured that all of the above test cases worked in filled view

Downloads:

- Ensured that when the download is completed, it would remove the "blue" ring
- Ensured that the blue ring behaves correctly when downloading something (PDF, EXE's in this instance)
- Ensured that going to another tab while downloading carried over the progress without any issues
- Ensured that you can cancel before downloading without any issues (using both "X" & "Cancel")
- Ensured that once the download is completed, you can select to open the target folder where the download was placed in
- Ensured that all of the above test cases worked in filled view

Pin:

- Ensured that when tapping on the pin button, that you don't see any middle state of lightly being highlighted
- Ensured that you receive the "Pin to Star" window without any issues
- Ensured that when you dismiss the "Pin to Star" window, the web page doesn't get pinned and the "Pin" button is returned to its correct state
- Ensured that when you do select "Pin to Star", the correct website is pinned and the "Pin" button is using the correct state
- Ensured that if you unpin a website from windows start window, the "Pin" button is using the correct state (not highlighted)
- Ensured that all of the above test cases worked in filled view
Went through the following "defect" for iteration #14 testing with some issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-11-03-02-58-mozilla-central/

- Went through the original test case(s) from comment #0 without any issues
- Went through the original test case(s) from comment #1 without any issues

Bookmark Star:

- Went through the test cases from comment # 14 without any issues
- Bookmarked a website and left the navigation app bar visible, slide in the Windows Charm -> Settings -> Options and ensured that the navigation app bar was dismissed. Closed the Windows Charm and then slide the navigation app bar into view and ensured that the "Star" was still enabled without issues

Downloads:

- Went through the test cases from comment #14 without any issues
- Found several bugs with the download progress indicator and created new bugs

Pin:

- Went through the test cases from comment #14 with some issues
- Found an issue where the incorrect states are being used. Looks like the "middle" light gray state is occurring again. Attempting to narrow down the STR.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.