Last Comment Bug 906506 - cant write danish letters in the new version?
: cant write danish letters in the new version?
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 24 Branch
: x86_64 Windows 8
: -- normal (vote)
: Firefox 26
Assigned To: Jim Chen [:jchen] [:darchons]
:
:
Mentors:
: 907110 907405 910969 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 13:36 PDT by Ken Przybylak
Modified: 2016-07-29 14:34 PDT (History)
8 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
verified
fixed
verified
24+
+


Attachments
Firefox Beta (24) | Samsung Galaxy SIV (Android 4.3) (120.40 KB, image/png)
2013-08-18 14:15 PDT, Aaron Train [:aaronmt]
no flags Details
Nightly (26) | LG Nexus 4 (Android 4.3) (87.32 KB, image/png)
2013-08-19 07:30 PDT, Aaron Train [:aaronmt]
no flags Details
Properly commit onKeyMultiple() keys with unknown code (v1) (3.51 KB, patch)
2013-08-21 08:53 PDT, Jim Chen [:jchen] [:darchons]
cpeterson: review+
bajaj.bhavana: approval‑mozilla‑aurora+
bajaj.bhavana: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Ken Przybylak 2013-08-18 13:36:01 PDT
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I think it is in the new vertion of fireforx for android, on webpages I can't write æøåÆØÅ anny more in inputbox. I have testet the beta whit same result.
I have tryed on version 23 and 24. (don't think I can download 25 and 26 that is in your list in bug report)


Actual results:

lettes don't apears


Expected results:

I can write æøåÆØÅ
Comment 1 Aaron Train [:aaronmt] 2013-08-18 14:15:53 PDT
Created attachment 791874 [details]
Firefox Beta (24) | Samsung Galaxy SIV (Android 4.3)

Which device and which keyboard? Which Android version? Have you tried Nightly for Android (http://nightly.mozilla.org)? Can you report back with that information and if Nightly works out for you?

Using Firefox Beta and testing out Nightly on my Samsung Galaxy S4 with a simple text input data:text/html,<input/> this works fine for me. I am using the stock Google Keyboard in Android 4.3

See the screenshot for sample input with character selection available on my keyboard.

Can you provide better steps with the information described?
Comment 2 Ken Przybylak 2013-08-18 23:26:23 PDT
Hi There
I'm using Android 4.1.1 on a HTC one X.
I have now tested whit Firefox 23, beta and now nightly.
I'm using the stock keyboard QWERTY but have tested the number/phone keyboard whit same result.
The issue only appears in the body section not in address field.
I have tested HTML: <input> and <textarea>
I have no issue in crome or the other stock browser.
I can copy/paste æøå ind to the field but when pussing the butten nothing happens.
Regards
Kino
Comment 3 Aaron Train [:aaronmt] 2013-08-19 07:30:37 PDT
Created attachment 792208 [details]
Nightly (26) | LG Nexus 4 (Android 4.3)

I tried this out with the Dansk input language on the Google Keyboard and this worked out for me too (Android 4.3).
Comment 4 Jim Chen [:jchen] [:darchons] 2013-08-19 14:50:03 PDT
Hi Ken, can you try this Nightly version? http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-50499682bafd/try-android-x86/fennec-26.0a1.en-US.android-i386.apk

Thanks!
Comment 5 Aaron Train [:aaronmt] 2013-08-20 06:46:35 PDT
*** Bug 907110 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Brosnan [:kbrosnan] 2013-08-20 14:12:14 PDT
*** Bug 907405 has been marked as a duplicate of this bug. ***
Comment 7 Roman 2013-08-20 14:16:40 PDT
*** Bug 907405 has been marked as a duplicate of this bug. ***
Comment 8 Aaron Train [:aaronmt] 2013-08-20 16:51:02 PDT
Re-tested on my HTC One (seeing HTC as the commonality here) and was able to reproduce on Google. I enter accented characters such as àáâ, on insert the character is removed. I tested this on 24/25/26 (Android 4.2.2). Using system-language as English, and just invoking a long-tap on the letter to open a super menu with available accents.
Comment 9 Aaron Train [:aaronmt] 2013-08-20 17:37:08 PDT
Testing out Jim's try build fixed the issue for me (ARM-based build over at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-50499682bafd/try-android/fennec-26.0a1.en-US.android-arm.apk)
Comment 10 n.mussin 2013-08-21 08:52:41 PDT
(In reply to Aaron Train [:aaronmt] from comment #9)
> Testing out Jim's try build fixed the issue for me (ARM-based build over at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-
> 50499682bafd/try-android/fennec-26.0a1.en-US.android-arm.apk)

+1 on htc desire hd, android 2.3
Comment 11 Jim Chen [:jchen] [:darchons] 2013-08-21 08:53:57 PDT
Created attachment 793525 [details] [diff] [review]
Properly commit onKeyMultiple() keys with unknown code (v1)

When onKeyMultiple() is called with KEYCODE_UNKNOWN, we're supposed to commit that text. The proper way to commit the text is to call BaseInputConnection.commitText() on the IC thread. We don't call GeckoInputConnection.commitText() because it can send key events which will cause onKeyMultiple() to be called again, producing a loop.
Comment 12 Chris Peterson [:cpeterson] 2013-08-21 10:44:49 PDT
Comment on attachment 793525 [details] [diff] [review]
Properly commit onKeyMultiple() keys with unknown code (v1)

Review of attachment 793525 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Comment 13 Ryan VanderMeulen [:RyanVM] 2013-08-22 07:00:57 PDT
https://hg.mozilla.org/integration/fx-team/rev/00be252820b7

Any way to test this?
Comment 14 Ryan VanderMeulen [:RyanVM] 2013-08-22 12:38:47 PDT
https://hg.mozilla.org/mozilla-central/rev/00be252820b7
Comment 15 Jim Chen [:jchen] [:darchons] 2013-08-26 09:25:09 PDT
Comment on attachment 793525 [details] [diff] [review]
Properly commit onKeyMultiple() keys with unknown code (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 859452

User impact if declined: Cannot input any accented characters on HTC devices

Testing completed (on m-c, etc.): Locally; m-c

Risk to taking this patch (and alternatives if risky): Small; the code path is rarely used and only HTC devices should be affected

String or IDL/UUID changes made by this patch: None
Comment 16 bhavana bajaj [:bajaj] 2013-08-26 10:31:17 PDT
(In reply to Jim Chen [:jchen :nchen] from comment #15)
> Comment on attachment 793525 [details] [diff] [review]
> Properly commit onKeyMultiple() keys with unknown code (v1)
> 
> [Approval Request Comment]
> 
> Bug caused by (feature/regressing bug #): Bug 859452
> 
> User impact if declined: Cannot input any accented characters on HTC devices
> 
> Testing completed (on m-c, etc.): Locally; m-c
> 
> Risk to taking this patch (and alternatives if risky): Small; the code path
> is rarely used and only HTC devices should be affected

Please help QA with some testcases that may hit this codepath which can help them with some adhoc testing.Was the impact here limited to only Danish ? Would testing *only on* HTC devices be enough here?

> 
> String or IDL/UUID changes made by this patch: None
Comment 17 bhavana bajaj [:bajaj] 2013-08-26 10:32:01 PDT
Comment on attachment 793525 [details] [diff] [review]
Properly commit onKeyMultiple() keys with unknown code (v1)

Request to land this asap so this can get into today's Beta which is going to build shortly.
Comment 18 Jim Chen [:jchen] [:darchons] 2013-08-26 11:07:14 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/613bd234d030
Comment 19 Ken Przybylak 2013-08-26 11:52:50 PDT
I can test if you build a package.
Comment 20 Ryan VanderMeulen [:RyanVM] 2013-08-26 12:11:57 PDT
(In reply to Jim Chen [:jchen :nchen] from comment #18)
> https://hg.mozilla.org/releases/mozilla-beta/rev/613bd234d030

Were you planning to push this to Aurora still?
Comment 21 Jim Chen [:jchen] [:darchons] 2013-08-26 12:47:52 PDT
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #20)
> (In reply to Jim Chen [:jchen :nchen] from comment #18)
> > https://hg.mozilla.org/releases/mozilla-beta/rev/613bd234d030
> 
> Were you planning to push this to Aurora still?

Yes, pushed. I pushed to Beta early because the next Beta was going into build soon.

https://hg.mozilla.org/releases/mozilla-aurora/rev/7c2b0341e3de
Comment 22 Aaron Train [:aaronmt] 2013-08-27 16:06:45 PDT
Verified Fixed against the HTC One on latest m-b
Comment 23 Ken Przybylak 2013-08-29 04:50:58 PDT
working for me in 24 beta now
Comment 24 Kevin Brosnan [:kbrosnan] 2013-09-09 15:35:12 PDT
*** Bug 910969 has been marked as a duplicate of this bug. ***
Comment 25 Ken Przybylak 2013-09-10 11:47:46 PDT
btw. you ask if I have try Nightly, it don't work om my device. I know that is off topic.
Comment 26 Kevin Brosnan [:kbrosnan] 2013-09-11 15:47:50 PDT
Worth release noting? Something like.

Fixed an issue with non-Latin text entry with HTC keybord
Comment 27 Kevin Brosnan [:kbrosnan] 2013-09-11 15:48:45 PDT
Ken you should be able to install Firefox Beta from the Play Store, it will have the fix as well.
Comment 28 bhavana bajaj [:bajaj] 2013-09-13 16:26:43 PDT
(In reply to Kevin Brosnan [:kbrosnan] from comment #26)
> Worth release noting? Something like.
> 
> Fixed an issue with non-Latin text entry with HTC keybord

https://www-dev.allizom.org/en-US/mobile/24.0/releasenotes/ .Added it to the release notes, let me know if it needs any edit's.

Note You need to log in before you can comment on or make changes to this bug.