AWFY FxOS is down since Bug 897871 landed

RESOLVED DUPLICATE of bug 906595

Status

Firefox OS
Wifi
--
critical
RESOLVED DUPLICATE of bug 906595
5 years ago
5 years ago

People

(Reporter: nbp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Here is the log coming from the build service of AWFY[1], which is using marionette to setup the wifi to access benchmarks.  Any down time is usually a bad sign as nobody else is testing on B2G, and happen to be the time when regression are landed.  We need an urgent fix here.

Aug 19 15:57:13 hydra run-chroot.sh[2699]: running webserver on http://10.250.1.241:37723/
Aug 19 15:57:13 hydra run-chroot.sh[2699]: TEST-START test_bench_kraken.py
Aug 19 15:57:13 hydra run-chroot.sh[2699]: test_kraken (test_bench_kraken.TestBenchKraken) ... ERROR
Aug 19 15:57:13 hydra run-chroot.sh[2699]: ======================================================================
Aug 19 15:57:13 hydra run-chroot.sh[2699]: ERROR: test_kraken (test_bench_kraken.TestBenchKraken)
Aug 19 15:57:13 hydra run-chroot.sh[2699]: ----------------------------------------------------------------------
Aug 19 15:57:13 hydra run-chroot.sh[2699]: Traceback (most recent call last):
Aug 19 15:57:13 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/gecko/testing/marionette/client/marionette/marionette_test.py", line 123, in run
Aug 19 15:57:13 hydra run-chroot.sh[2699]: self.setUp()
Aug 19 15:57:13 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/perso/gaia-ui-tests/gaiatest/tests/browser/benchmarks/test_bench_kraken.py", line 19, in setUp
Aug 19 15:57:13 hydra run-chroot.sh[2699]: GaiaTestCase.setUp(self)
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/perso/gaia-ui-tests/gaiatest/gaia_test.py", line 454, in setUp
Aug 19 15:59:54 hydra run-chroot.sh[2699]: self.cleanUp()
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/perso/gaia-ui-tests/gaiatest/gaia_test.py", line 503, in cleanUp
Aug 19 15:59:54 hydra run-chroot.sh[2699]: self.data_layer.enable_wifi()
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/perso/gaia-ui-tests/gaiatest/gaia_test.py", line 250, in enable_wifi
Aug 19 15:59:54 hydra run-chroot.sh[2699]: result = self.marionette.execute_async_script("return GaiaDataLayer.enableWiFi()", special_powers=True)
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/gecko/testing/marionette/client/marionette/marionette.py", line 641, in execute_async_script
Aug 19 15:59:54 hydra run-chroot.sh[2699]: filename=os.path.basename(frame[0]))
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/gecko/testing/marionette/client/marionette/marionette.py", line 351, in _send_message
Aug 19 15:59:54 hydra run-chroot.sh[2699]: self._handle_error(response)
Aug 19 15:59:54 hydra run-chroot.sh[2699]: File "/home/awsa/unagi/B2G/gecko/testing/marionette/client/marionette/marionette.py", line 400, in _handle_error
Aug 19 15:59:54 hydra run-chroot.sh[2699]: raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
Aug 19 15:59:54 hydra run-chroot.sh[2699]: TEST-UNEXPECTED-FAIL | test_bench_kraken.py TestBenchKraken.test_kraken | ScriptTimeoutException: timed out
Aug 19 15:59:54 hydra run-chroot.sh[2699]: ----------------------------------------------------------------------
Aug 19 15:59:54 hydra run-chroot.sh[2699]: Ran 1 test in 68.904s 


Vincent Chang, any idea why the enableWifi function timeouts?

[1] http://arewefastyet.com/#machine=14
Flags: needinfo?(vchang)
Bug 897871 is backed out from b2g-inbound. It's not landed. 
I have updated the patch to that bug and also run the try server. 
The test results seem good in try server. Does you test also run in try server ? 
How can I perform the gaia test mentioned here ?
Flags: needinfo?(vchang)
Here is the try server result for the new patch on Bug 897871. https://tbpl.mozilla.org/?tree=Try&rev=e3e0d658a3c2

Looks like Bug 900855 is broken your gaia test. We have a patch in Bug 906595 to fix
the enable wifi problem. Can you try if it is work for you ?
(In reply to Vincent Chang[:vchang] from comment #1)
> Bug 897871 is backed out from b2g-inbound. It's not landed. 
> I have updated the patch to that bug and also run the try server. 
> The test results seem good in try server. Does you test also run in try
> server ? 

No, they are running on a local sever.

> How can I perform the gaia test mentioned here ?

Use the bench branch of https://github.com/nbp/gaia-ui-tests, after installing marionette as provided by Gecko.  You will need a bit of setup and to backup all your phone data.

(In reply to Vincent Chang[:vchang] from comment #2)
> Here is the try server result for the new patch on Bug 897871.
> https://tbpl.mozilla.org/?tree=Try&rev=e3e0d658a3c2
> 
> Looks like Bug 900855 is broken your gaia test. We have a patch in Bug
> 906595 to fix
> the enable wifi problem. Can you try if it is work for you ?

I will try.

FYI, AWFY is running on a Unagi.
(In reply to Nicolas B. Pierron [:nbp] from comment #3)
> (In reply to Vincent Chang[:vchang] from comment #1)
> > Looks like Bug 900855 is broken your gaia test. We have a patch in Bug
> > 906595 to fix
> > the enable wifi problem. Can you try if it is work for you ?
> 
> I will try.

I've tried with attachment 792134 [details] [diff] [review], but this did not solve the problem.  I still got the same error message from marionette.
Assignee: general → nobody
Component: JavaScript Engine → Wifi
OS: Linux → Gonk (Firefox OS)
Product: Core → Boot2Gecko
Hardware: x86_64 → ARM
> > I will try.
> 
> I've tried with attachment 792134 [details] [diff] [review], but this did
> not solve the problem.  I still got the same error message from marionette.

You should try the patch in Bug 906595. I'm success in below command with Unagi.

gaiatest --address localhost:2828 ./gaiatest/tests/settings/test_settings_wifi.py --testvars ./gaiatest/testvars_my.json
(In reply to Vincent Chang[:vchang] from comment #5)
> > > I will try.
> > 
> > I've tried with attachment 792134 [details] [diff] [review], but this did
> > not solve the problem.  I still got the same error message from marionette.
> 
> You should try the patch in Bug 906595. I'm success in below command with
> Unagi.
> 
> gaiatest --address localhost:2828
> ./gaiatest/tests/settings/test_settings_wifi.py --testvars
> ./gaiatest/testvars_my.json

I am testing right now, if it works with the harness.  But I do not want to maintain any patch on top of the tree to get the phone working, we should either land these fix or backout the regression.
(In reply to Nicolas B. Pierron [:nbp] from comment #6)
> (In reply to Vincent Chang[:vchang] from comment #5)
> > > > I will try.
> > > 
> > > I've tried with attachment 792134 [details] [diff] [review], but this did
> > > not solve the problem.  I still got the same error message from marionette.
> > 
> > You should try the patch in Bug 906595. I'm success in below command with
> > Unagi.
> > 
> > gaiatest --address localhost:2828
> > ./gaiatest/tests/settings/test_settings_wifi.py --testvars
> > ./gaiatest/testvars_my.json
> 
> I am testing right now

I applied both patches, and the benchmarks are running fine.
Can you land these fixes ASAP?
As RyanVM landed the patch of Bug 906595, and the harness of AWFY is now running again.
I will mark this bug as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906595
You need to log in before you can comment on or make changes to this bug.