Closed Bug 906595 Opened 7 years ago Closed 7 years ago

[Wifi] Can't re-enable Wifi on devices doesn't unload driver on wifi disabling.

Categories

(Firefox OS Graveyard :: Wifi, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+, firefox24 wontfix, firefox25 wontfix, firefox26 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

VERIFIED FIXED
1.1 QE5
blocking-b2g leo+
Tracking Status
firefox24 --- wontfix
firefox25 --- wontfix
firefox26 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: chucklee, Assigned: chucklee)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR:(On Unagi)
1. Enable Wifi
2. Disable Wifi
3. Enable Wifi

Expected:
Get scan result

Acutal:
Wifi hang in scan status.


This bug is caused by patch for bug 900855, I forget to handle the condition which wifi driver doesn't being unloaded while Disabing Wifi.
This bug is fixing regression caused by leo+ed bug.
blocking-b2g: --- → leo?
Comment on attachment 792059 [details] [diff] [review]
(mozilla-central) Fix check rules for devices doesn't unload WIFI driver.

Review of attachment 792059 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thank you.
Attachment #792059 - Flags: review?(vchang) → review+
blocking-b2g: leo? → leo+
Keywords: regression
Attachment #792059 - Attachment description: 0001. Fix check rules for devices doesn't unload WIFI driver. → (mozilla-central) Fix check rules for devices doesn't unload WIFI driver.
https://hg.mozilla.org/mozilla-central/rev/fed47be3907e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 906957
Verified fixed on unagi master:

Gecko  http://hg.mozilla.org/mozilla-central/rev/d136c8999d96
Gaia  aa22b7cfee556f704ca174ab608013eb469c83b1
BuildID 20130820170824
Version 26.0a1
Status: RESOLVED → VERIFIED
Issue No longer occurs on Leo device. 
Build ID: 20130828041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c3b4683d1360
Gaia: 518178ca234c98eb1ca0c0997b9d59faea640a85
Platform Version: 18.1
RIL Version: 01.01.00.019.205

WIFI connecting as expected.
You need to log in before you can comment on or make changes to this bug.