[Buri][Email] Localized folder names are not dynamically updated/re-localized on language change

RESOLVED DUPLICATE of bug 855198

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 855198
4 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

139.40 KB, image/x-png
Details
37.87 KB, application/x-zip-compressed
Details
(Reporter)

Description

4 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.184
 Firefox os  v1.1
 Mozilla build ID:20130806071254
 
 Created an attachment (id=494270)
 PIC1
 
 DEFECT DESCRIPTION:
 The folder list do not be translated when language is not Chinese
 
  REPRODUCING PROCEDURES:
 1.There have created a account 
 2.Go to Settings->Language->English->OK->press center key
 3.Go to Email->check folder list,you will find ”inbox sent draft..." do not be
 translated
 Notes:hotmail account is ok
  EXPECTED BEHAVIOUR:
 The word ”inbox sent draft..." should be translated
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 SWV176+ZZ
  USER IMPACT:
 mid
  REPRODUCING RATE:
 5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 792567 [details]
PIC1
(Reporter)

Comment 3

4 years ago
Clone from brother
(Reporter)

Comment 4

4 years ago
Created attachment 792568 [details]
logcat.log
Note that folder names are properly localized based on the language in use at startup; the bug is only about dynamic localizations.  (Well, bug 905869 and bug 905878 are still relevant for the gmail case; see bug 893458 for more discussion on that.)


In terms of our deficiencies for dynamic updating:

The front-end hands off a set of localized strings to the back-end when the back-end is started up.  They get passed via MailAPI.useLocalizedStrings.  We do not listen for the 'localized' event so we never push an updated set of strings into the back-end.

For this bug, I think the best thing to do is for us to stop trying to have the MailAPI transparently localize folder names via this dance.  We should probably just have the UI notice that they are special folders and set the appropriate data-l10n-id value onto the node in question so that the automatic re-localization occurs.

(We do still want to listen for the 'localized' event and push an updated set of strings into the back-end for other reasons, namely for message reply generation, but that shouldn't happen on this bug.)
Blocks: 906580
Priority: P2 → --
Summary: [Buri][Translation][Email]The folder list do not be translated → [Buri][Email] Localized folder names are not dynamically updated/re-localized on language change
Activity and discussion is happening on bug 855198.  Note that bug 1037266 is dealing with the other useLocalizedStrings stuff.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855198
You need to log in before you can comment on or make changes to this bug.