[Geeksphone][GPS] Speedup Geolocation response time, currently takes about 10 minutes

RESOLVED INVALID

Status

Firefox OS
Vendcom
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: Binyamin, Assigned: Geeksphone, NeedInfo)

Tracking

(Depends on: 1 bug, {perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=progress p= s=2014.02.14 u=])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

Steps to reproduce:

Check Geolocation API results in on system saved up or in Browser, example http://benwerd.com/lab/geo.php


Actual results:

Geolocation was unacceptable slow response time, about 10 minutes. Sometimes after retrying multiple times it may take about few seconds, but after the device restart the unacceptable response time returns.


Expected results:

Improve UX by speedup Geolocation API response till about half second.
(Reporter)

Updated

4 years ago
Summary: Speedup Geolocation response time, currently takes about 10 minutes → [GPS] Speedup Geolocation response time, currently takes about 10 minutes

Updated

4 years ago
Component: Gaia → Geolocation
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Comment 1

4 years ago
Thanks for the report.  what device?

also see: https://wiki.mozilla.org/B2G/Geolocation
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 2

4 years ago
(In reply to Doug Turner (:dougt) from comment #1)
> what device?
Tested on Geeksphone Peak devices.

Comment 3

4 years ago
(In reply to Binyamin from comment #2)
> (In reply to Doug Turner (:dougt) from comment #1)
> > what device?
> Tested on Geeksphone Peak devices.

As much as I love Geeksphone and think we are uncovering a ton of good and general bugs with those devices, in this case the bug is (very probably) completely on the side of Geeksphone. IIUC, we know that configuration of the "modem" chip is what has the biggest influence on geolocation time-to-get-a-GPS-fix, and Geeksphone probably needs to make adaptations there. We know that other devices are mostly faster, often within seconds.
(Reporter)

Comment 4

4 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> ... in this case the bug is (very probably) completely on the side of
> Geeksphone. IIUC, we know that configuration of the "modem" chip is what >
> has the biggest influence on geolocation time-to-get-a-GPS-fix ...
I hope Geeksphone could join this discussion.
(Assignee)

Comment 5

4 years ago
Geeksphone is here.

We know about this bug and the fix. We are working together with our providers to fix it as soon as possible, but all the possible solutions are not so easy as change a file :(.

There is a problem with the a-gps server and the certificates stored in the device. We need to update this certificate, but it's stored in the bootloader partition and a "normal" user cant update it easily, so we are searching for other methods to fix it.

We will update this bug when we have more info.

Updated

4 years ago
Component: Geolocation → Vendcom
Product: Core → Boot2Gecko
Version: Trunk → unspecified

Updated

4 years ago
Summary: [GPS] Speedup Geolocation response time, currently takes about 10 minutes → [GPS] Speedup Geolocation response time, currently takes about 10 minutes (on Geeksphone Peak)

Updated

4 years ago
Keywords: perf
Whiteboard: [c=progress p= s= u=]

Comment 6

4 years ago
So this is why it takes ages for HERE Maps to find my location. I'm quite a bit disappointed this wasn't communicated by Geeksphone clearly and that I had to figure out the cause through Google. Up until I read this I thought my Geeksphone Peak's GPS was defective. Can Geeksphone give any indication on how long it will take to find a solution? A smartphone which can't use GPS properly is useless for navigation.

Updated

4 years ago
Assignee: nobody → gp
Flags: needinfo?(gp)
(Assignee)

Comment 7

4 years ago
This info is in our forum and as you can see the info is here since september. I will explain what's exactly the problem so everyone can undestand it.

When the Peak and Keon was released, Firefox OS was using as agps server the one from Nokia. This one is working perfectly, but with the time this server was changed to another one. This new one needs a certificate from qualcomm to get the data, because is configured in a way that only qualcomm devices can use it.
To add this certificate we need to change the bootloader that only can be done using a windows app and is not for normal users, so with a ota or a fastboot flash we cant fix the problem. Our fault was not to add this certificate when we build our phones, but we dont know that this certificates will be used (really we dont know that them exists until Mozilla changes his agps server to a qualcomm restricted one)

So your chance is to change it to the nokia one (search our forums). It's tested and works ok.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(gp)
Resolution: --- → WONTFIX
(Reporter)

Comment 8

4 years ago
You have to provide a fix for it, on cooperating with Mozilla or in another way.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(gp)
Resolution: WONTFIX → ---

Comment 9

4 years ago
Thanks for the response Geeksphone, but it wasn't so helpful without a link to the forum topic in question. There are more topics about GPS on your forum, so it wasn't immediately clear to me which topic was meant. Even after finding the topic it wasn't clear to me what I had to do because I didn't know anything about adb. Nevertheless, I figured it out myself and shall describe here what I did in detail for others who need help:

1) The forum topic is http://forum.geeksphone.com/index.php?topic=5410.0
2) Download the Android Tools/SDK. On my Fedora 19 Linux box I openened a terminal, became root and then entered "yum install adb".
3) Connect the Geeksphone Peak to your PC with the USB cable.
4) Enter "adb devices" in the terminal, to me it returned "d0ad7088f488" which showed me my Peak was recognized.
5) See https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Changing_preferences and follow the commands necessary to download the user.js file from the phone.
6) Follow the instructions in http://forum.geeksphone.com/index.php?topic=5410.msg59587#msg59587 to change the settings for the A-GPS server in the user.js file.
7) After editing, follow the remaining steps in https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Changing_preferences to upload the modified user.js file to the phone.
8) Install the gpsDashboard app on your phone, walk outside and verify with this app that your phone can now get a GPS fix much faster. This worked for me on my Geeksphone Peak with Firefox OS 1.1. The first time I tried to get a fix with the new A-GPS server it still took a minute or so, long but a lot faster than the five or ten minutes with the old server. After that first time it took no more than two or three seconds to get a fix.

I'm inclined to believe Geeksphone that this issue is out of their control and that they got screwed by Mozilla, just like Mozilla screwed them with their refusal to allow Geeksphone to use the Firefox OS branding.

However, I feel Geeksphone also needs to step up its game with its communication. "There's a post about it in our forum, search for it yourself" is not customer friendly. When I was writing this guide to fix it I did Geeksphone's job. Geeksphone probably has e-mail adresses of everyone who ordered one of their Firefox OS devices, so they should actively approach their customers and inform them of this problem and how to fix it. Or put a news message on your website with that information. Waiting for your users to read an obscure forum topic or this even more obscure bug report is *not* cool!
this is a vendor issue, nothing that gecko/mozilla can do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 11

4 years ago
Why(In reply to Doug Turner (:dougt) from comment #10)
> this is a vendor issue, nothing that gecko/mozilla can do.

Why RESOLVED, WONTFIX? If it is Geeksphone related bug, then still it is relevant not fixed and must provide a fix.
Flags: needinfo?(doug.turner)
I wrote up a bit on how Firefox OS and geolocation works:
    https://wiki.mozilla.org/B2G/Geolocation

It might not help address the specific question, but I hope it helps give you some background on the matter.

To answer your specific question, I could mark this any number of ways.  I felt that WONTFIX is the most accurate because:  mozilla (I) can not fix this specific vender problem.  I could be wrong -- and that there might be something we could do to work around the vender problem, but a this point, there is no data suggesting that I can.  Please let me know if you have any other questions wrt to this.  My email address is above.
Flags: needinfo?(doug.turner)
(Assignee)

Comment 13

4 years ago
The problem with GP devices is that when Mozilla releases FFOS 1.0 they are using Nokia supl server that doesnt need any certificate and the GP devices comes out without any QC certificate, because it's not needed. But some time later Mozilla changes the supl server to a QC one that needs a certificate.

As you said in the wiki "The modem needs to be configured with TLS enabled and the certificate of the QC supl1 server. Mozilla does NOT have any way to configure the modem and OEMs are encouraged to discuss this with their chip manufacturer"

And this is what we did, and they said that to add this certificate we need to reflash all the bootloaders of all the devices we sell and this cant be done by a user. But if we had known that Mozilla was going to change the supl server to a closed one at the beginning, in the manufacturing we could add this certificate, but now we cant :(, so our only way is to change the supl server back to the Nokia one.

Ah, but Mozilla ask us to maintain the code as much as we can, because we sell developer devices, so we dont change this and only can give the users instructions of how to change it.

@Binyamin I hope that with this info (the Doug one and ours) the scenario is clear now. You have the info to change the supl server in our forums and any help you need, please ask there and we will happy to help you.
Flags: needinfo?(gp)
(Reporter)

Comment 14

4 years ago
Please provide a link to full instructions how anyone by himself can fix this issue and avoid this issue in next updates or rebuild.
Flags: needinfo?(gp)
(Assignee)

Comment 15

4 years ago
Is right above you in comment 9

http://forum.geeksphone.com/index.php?topic=5410.0
Flags: needinfo?(gp)

Comment 16

4 years ago
In reply to the most recent comment #14 and comment #13 I'd have to say that reading is an art. Binyamin, I have already given such instructions right here in this bug report. Read my comment #9 here for it.
(Reporter)

Comment 17

4 years ago
(In reply to Geeksphone from comment #15)
> Is right above you in comment 9
> 
> http://forum.geeksphone.com/index.php?topic=5410.0

Are you able to build single file script that runs the fix, and email it to all Peak and Keon customers?
Flags: needinfo?(gp)

Comment 18

4 years ago
(In reply to Binyamin from comment #17)
> Are you able to build single file script that runs the fix, and email it to
> all Peak and Keon customers?

It would be a good idea for Geeksphone to send e-mails with instructions to all who bought a Peak and Keon, but if you are asking for a script I think you are asking for too much. First of all, how is that script supposed to install the required Android SDK on the large variety of operating systems which are no doubt used by Geeksphone customers? If you don't understand something about the instructions feel free to send me an e-mail in private (use the e-mail address I use here on Bugzilla) and I'll help you. I don't think insisting that Geeksphone or Mozilla do more about it is going to be fruitful for you.
(Reporter)

Comment 19

4 years ago
I followed Geeksphone, Alexander and http://forum.geeksphone.com/index.php?topic=5410.msg59587#msg59587 suggestion and did:


adb pull /system/b2g/defaults/pref/user.js

edited user.js with a text editor, replacing:

pref("geo.gps.supl_server", "supl.izatcloud.net");
pref("geo.gps.supl_port", 22024);

with:

pref("geo.gps.supl_server", "test.supl.svc.ovi.com");
pref("geo.gps.supl_port", 7276);

and, finally:

adb remount
adb push user.js /system/b2g/defaults/pref/user.js
adb reboot


Unfortunately it did not improve my anything - GPS seems not responding at all - maybe the issue just on Nightly builds? Issue reported in https://bugzilla.mozilla.org/show_bug.cgi?id=955880
(Reporter)

Updated

4 years ago
Depends on: 955880
(Reporter)

Comment 20

4 years ago
GPS is not working anymore.
(Reporter)

Updated

4 years ago
See Also: → bug 955880

Comment 21

4 years ago
Confirmed, it stopped working for me as well; placed my comment at bug #955880.
(Reporter)

Comment 22

4 years ago
With yesterdays Nightly image update, GPS/Geolocation seems now working. The GPS connection still is very slow (waiting for 5 minutes or more), accuracy of 500 - 50 meters. But at least has some respond.

Geeksphone, could you fix the response time and GPS accuracy?
(Reporter)

Comment 23

4 years ago
Apply https://bugzilla.mozilla.org/show_bug.cgi?id=955880 suggestions in order to improve the GPS response time:

1. create a cert for google SUPL server http://blog.cryptomilk.org/2012/07/24/how-to-create-a-suplrootcert-for-supl-google-com/
   openssl x509 -inform PEM -in thawte_Premium_Server_CA.pem -outform DER -out SuplRootCert
   openssl x509 -inform DER -in SuplRootCert -text
2. /etc/gps.conf
   QUIPC_ENABLED = 1
3. /system/b2g/defaults/pref/user.js
   pref("geo.gps.supl_server", "supl.google.com");
   pref("geo.gps.supl_port", 7276);
4. /etc/gps.conf apply with regional settings like
   NTP_SERVER=th.pool.ntp.org
   NTP_SERVER=0.th.pool.ntp.org
   NTP_SERVER=1.th.pool.ntp.org
   NTP_SERVER=2.th.pool.ntp.org
   NTP_SERVER=3.th.pool.ntp.org
   NTP_SERVER=asia.pool.ntp.org
   NTP_SERVER=0.asia.pool.ntp.org
   NTP_SERVER=1.asia.pool.ntp.org
   NTP_SERVER=2.asia.pool.ntp.org
   NTP_SERVER=3.asia.pool.ntp.org
   XTRA_SERVER_1=/data/xtra.bin
   AGPS=/data/xtra.bin
   AGPS=http://xtra1.gpsonextra.net/xtra.bin
   XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
   XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
   XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
   DEFAULT_AGPS_ENABLE=TRUE
   DEFAULT_USER_PLANE=TRUE
   REPORT_POSITION_USE_SUPL_REFLOC=1
   QOS_ACCURACY=50
   QOS_TIME_OUT_STANDALONE=60
   QOS_TIME_OUT_agps=89
   QosHorizontalThreshold=1000
   QosVerticalThreshold=500
   AssistMethodType=1
   AgpsUse=1
   AgpsMtConf=0
   AgpsMtResponseType=1
   AgpsServerType=1
   AgpsServerIp=3232235555
   INTERMEDIATE_POS=1
   C2K_HOST=c2k.pde.com
   C2K_PORT=1234
   SUPL_HOST=FQDN
   SUPL_HOST=lbs.geo.t-mobile.com
   SUPL_HOST=supl.google.com
   SUPL_PORT=7276
   SUPL_SECURE_PORT=7275
   SUPL_NO_SECURE_PORT=3425
   SUPL_TLS_HOST=FQDN
   SUPL_TLS_CERT=/etc/SuplRootCert
   ACCURACY_THRES=5000
   CURRENT_CARRIER=common
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(nhirata.bugzilla)
Resolution: WONTFIX → ---
Summary: [GPS] Speedup Geolocation response time, currently takes about 10 minutes (on Geeksphone Peak) → [GPS] Speedup Geolocation response time, currently takes about 10 minutes
(Reporter)

Updated

4 years ago
Depends on: 965191
Please open a new bug instead of morphing the bug.  Morphing causes too much confusion as the title no longer matches comment 0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
No longer depends on: 965191
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 965191
Oops. sorry.  This was about slow time.  I mistook it for the other bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
There's still some configs that are missing from your settings.

Please see the configs in the attachment for https://bugzilla.mozilla.org/show_bug.cgi?id=965191#c6
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: [c=progress p= s= u=] → [c=progress p= s=2014.02.14 u=]

Comment 27

4 years ago
(In reply to Geeksphone from comment #15)
> Is right above you in comment 9
> 
> http://forum.geeksphone.com/index.php?topic=5410.0

I would like to know that whether all peaks and keons have the right to modify the agps server to point at google's?

I have read that it may be in violation against google if oem(in this case gp) is not authorized.
Any info about the gps issue, it seems all gp devices with b2g are unable to use gps without edited.
> I would like to know that whether all peaks and keons have the right to modify the agps server to point at google's?

You will have to ask GP.  Mozilla was not involved in any of this.

I recently started pointing default builds at Mozilla Location Service.  GP can ask us for a key for their devices, and we can provide service/support.
(Reporter)

Comment 29

3 years ago
(In reply to Doug Turner (:dougt) from comment #28)
> > I would like to know that whether all peaks and keons have the right to modify the agps server to point at google's?
> 
> You will have to ask GP.  Mozilla was not involved in any of this.
> 
> I recently started pointing default builds at Mozilla Location Service.  GP
> can ask us for a key for their devices, and we can provide service/support.

Unfortunately Geeksphone does not seems me interested in any participating to solve this issue.
Can you raise the issue priority? This issue is related from the begging Geeksphone Firefox OS devices and still does not work on Peak, Keon and Revolution. I meant not just needed performance improvement, but GPS does not work at all.
(Reporter)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 30

3 years ago
Sorry, this is Mozilla's Bugzilla, and the bug is on Geeksphone's side, only they can fix it and we cannot. Therefore, it is "invalid" in here, it is valid on wherever Geeksphones tracks issues with their phones only. Please complain to them, but nobody at Mozilla can solve it, unfortunately.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → INVALID
Summary: [GPS] Speedup Geolocation response time, currently takes about 10 minutes → [Geeksphone][GPS] Speedup Geolocation response time, currently takes about 10 minutes
Duplicate of this bug: 953214
You need to log in before you can comment on or make changes to this bug.