[GPS] GPS is not working anymore

UNCONFIRMED
Unassigned

Status

Firefox OS
General
UNCONFIRMED
3 years ago
2 years ago

People

(Reporter: Binyamin, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36



Actual results:

No GPS respond. Tested on Geeksphone Peak.
(Reporter)

Updated

3 years ago
Summary: [GPS] GPS no more working in Nightly images → [GPS] GPS does not works
(Reporter)

Comment 1

3 years ago
Tested on Nightly builds with Geeksphone Peak with /system/b2g/defaults/pref/user.js defaults and Geeksphone suggested GPS response improvement https://bugzilla.mozilla.org/show_bug.cgi?id=908151#c19

While approving GPS Share permissions (enabling also in System settings) and testing Geolocation in whatever app, it does not show up the GPS Share icon on System top status bar (icon like can see in http://firefoxadvices.com/wp-content/uploads/2013/11/EverNav-App.png) and does not return any GPS respond - http://html5demos.com/geo "checking..." will hang for forever.
(Reporter)

Updated

3 years ago
Summary: [GPS] GPS does not works → [GPS] GPS is not working anymore
(Reporter)

Updated

3 years ago
Flags: needinfo?(gp)
(Reporter)

Updated

3 years ago
Blocks: 908151
(Reporter)

Updated

3 years ago
See Also: → bug 908151

Comment 2

3 years ago
I can confirm this. GPS used to work reasonably well (but still a bit slow) for me after implementing the fix mentioned in bug #908151 but since a week or so ago it no longer works at all. No matter how long I wait, even ten minutes, my Geeksphone Peak just doesn't get a fix. I was going to post a new topic about this on the Geeksphone forum, but Binyamin already beat me to it with this bug report. Glad to hear I'm not the only one affected. I'll post to the Geeksphone forum anyway to direct other victims towards this bugreport.

Comment 3

3 years ago
I posted a topic here:

To provide more info at Geeksphone's request, I'm running Boot2Gecko 1.1.1.0-hd-GP. Before GPS stopped working I hadn't downloaded any updates which could have overwritten the settings in the user.js file. I just downloaded that file from my Peak again to verify it has the correct settings. It still has the same:

pref("geo.gps.supl_server", "test.supl.svc.ovi.com");
pref("geo.gps.supl_port", 7276);

Should any more info be necessary I'll gladly provide it.

Comment 4

3 years ago
Forgot to provide the link to the topic: https://forum.geeksphone.com/index.php?topic=5886.0
(Reporter)

Comment 5

3 years ago
> telnet test.supl.svc.ovi.com 7276
Connecting To test.supl.svc.ovi.com...Could not open connection to the host, on port 7276: Connect failed

Comment 6

3 years ago
This is what i suspect :( Nokia has closed this supl server (or at least the port).

You can try with:

supl.nokia.com:7275
supl.google.com:7275
test.supl.svc.ovi.com:7275
Flags: needinfo?(gp)
(Reporter)

Comment 7

3 years ago
(In reply to Geeksphone from comment #6)
> This is what i suspect :( Nokia has closed this supl server (or at least the
> port).
> 
> You can try with:
> 
> supl.nokia.com:7275
> supl.google.com:7275
> test.supl.svc.ovi.com:7275

I just tested. It does not work either. GPS not responding on Peak device, Firefox OS, Nightly images.
Flags: needinfo?(gp)

Comment 8

3 years ago
Please, dont test with nightly images, they may have bugs and can broke the tests.
Flags: needinfo?(gp)
(Reporter)

Comment 9

3 years ago
(In reply to Geeksphone from comment #8)
> Please, dont test with nightly images, they may have bugs and can broke the
> tests.

I just tried with stabile images v1.3 http://downloads.geeksphone.com/peak/v1.3/latest_v1.3.html and still no GPS respond.
Flags: needinfo?(gp)

Comment 10

3 years ago
Please could you take a log with logcat so we can see if there is any problem?
Flags: needinfo?(gp)
(Reporter)

Comment 11

3 years ago
Created attachment 8364243 [details]
adb logcat > logcat.txt

Attached logcat after applied Geeksphone provided /system/b2g/defaults/pref/user.js settings

pref("geo.gps.supl_server", "supl.nokia.com");
pref("geo.gps.supl_port", 7275);

and checking Geolocation in Browser http://epx.com.br/ctb/gps/ -
it stays forever on status "Waiting for GPS". Tested on other apps, and the same failed result.

Does not matter which geo.gps server, port and Geeksphone Firefox OS provided image I use - the same result - Waiting till Timeout if set.

Please test on your Geeksphone Peak and Keon devices and provide the fix as soon as possible https://bugzilla.mozilla.org/show_bug.cgi?id=908151#c17!
Flags: needinfo?(gp)

Comment 12

3 years ago
Change /etc/gps.conf to

NTP_SERVER=th.pool.ntp.org
NTP_SERVER=0.th.pool.ntp.org
NTP_SERVER=1.th.pool.ntp.org
NTP_SERVER=2.th.pool.ntp.org
NTP_SERVER=3.th.pool.ntp.org
NTP_SERVER=asia.pool.ntp.org
NTP_SERVER=0.asia.pool.ntp.org
NTP_SERVER=1.asia.pool.ntp.org
NTP_SERVER=2.asia.pool.ntp.org
NTP_SERVER=3.asia.pool.ntp.org
XTRA_SERVER_1=/data/xtra.bin
AGPS=/data/xtra.bin
AGPS=http://xtra1.gpsonextra.net/xtra.bin
XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
DEFAULT_AGPS_ENABLE=TRUE
DEFAULT_USER_PLANE=TRUE
REPORT_POSITION_USE_SUPL_REFLOC=1
QOS_ACCURACY=50
QOS_TIME_OUT_STANDALONE=60
QOS_TIME_OUT_agps=89
QosHorizontalThreshold=1000
QosVerticalThreshold=500
AssistMethodType=1
AgpsUse=1
AgpsMtConf=0
AgpsMtResponseType=1
AgpsServerType=1
AgpsServerIp=3232235555
INTERMEDIATE_POS=1
C2K_HOST=c2k.pde.com
C2K_PORT=1234
SUPL_HOST=FQDN
SUPL_HOST=lbs.geo.t-mobile.com
SUPL_HOST=supl.google.com
SUPL_PORT=7276
SUPL_SECURE_PORT=7275
SUPL_NO_SECURE_PORT=3425
SUPL_TLS_HOST=FQDN
SUPL_TLS_CERT=/etc/SuplRootCert
ACCURACY_THRES=5000
CURRENT_CARRIER=common


(set your region and country instead of asia.pool.ntp.org and th.pool.ntp.org)

and set supl server settings in /system/b2g/defaults/pref/user.js  to

pref("geo.gps.supl_server", "supl.google.com");
pref("geo.gps.supl_port", 7276);


then reboot the device works for me.

Comment 13

3 years ago
Thank you so much for your help Alex! I tried you solution just now and I can report it works for me to, my Peak gets a GPS fix within a second or two.
(Reporter)

Comment 14

3 years ago
Alex, I tried your suggestion and it did not fix anything. Still the same infinite Waiting... status.
Flags: needinfo?(al.zhukoff)
(Reporter)

Comment 15

3 years ago
Created attachment 8365578 [details]
"adb logcat > logcat.txt" after https://bugzilla.mozilla.org/show_bug.cgi?id=955880#c12 suggestion

E/LocSvc_eng(  124): I/===> void loc_eng_agps_init(loc_eng_data_s_type&, AGpsCallbacks*) line 833
E/LocSvc_eng(  124): I/<=== status_cb line 762 GPS_STATUS_SESSION_BEGIN
E/LocSvc_eng(  124): I/<=== agps_cb line 661 GPS_REQUEST_AGPS_DATA_CONN
E/LocSvc_eng(  124): I/<=== status_cb line 762 GPS_STATUS_SESSION_END
E/LocSvc_eng(  124): I/<=== status_cb line 762 GPS_STATUS_ENGINE_OFF
(Reporter)

Comment 16

3 years ago
GPS failed also to others https://twitter.com/oxodesign/status/428092735523151872

Comment 17

3 years ago
The fix from Alex works for me on Geeksphone Peek with 1.3 (build-ID: 20140128101127).
Only problem is that the GPS signal is very bad at my home so I only can test it if I am outside...

Comment 18

3 years ago
Of course you should be outdoors, because GPS doesn't work inside buildings or works incorrect (http://science.opposingviews.com/doesnt-gps-work-inside-building-18659.html)

But, it is said that nokia supl server (supl.nokia.com) provides a way to get your coordinates indoors (http://developer.nokia.com/community/discussion/showthread.php/172039-Location-Api-without-GPS). But i didn't try it and i'm not sure that it works on Geeksphone.
Flags: needinfo?(al.zhukoff)
You'll also need to create a cert for the google SUPL server : 
http://blog.cryptomilk.org/2012/07/24/how-to-create-a-suplrootcert-for-supl-google-com/
Alex, I think you might need : 
QUIPC_ENABLED = 1

in the /etc/gps.conf in order for indoor positioning to work?  I could be wrong.  Having said that I'm not sure that will work because you also need to configure the QUIPC if it's capable... quipc.conf
(Reporter)

Comment 21

3 years ago
With yesterdays Nightly image update, GPS/Geolocation seems now working. The GPS connection still is very slow (waiting for about 5 minutes), accuracy of 500 - 50 meters, but it at least has some respond.
May have had to do with : https://bugzilla.mozilla.org/show_bug.cgi?id=955906
Binyamin, also see : https://bugzilla.mozilla.org/show_bug.cgi?id=965191#c6

In any cases, can we close this now, Binyamin, since it's working for you?
(Reporter)

Comment 23

3 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #22)
> May have had to do with : https://bugzilla.mozilla.org/show_bug.cgi?id=955906
> Binyamin, also see : https://bugzilla.mozilla.org/show_bug.cgi?id=965191#c6
> 
> In any cases, can we close this now, Binyamin, since it's working for you?

Closing this bug. Still we have to improve the response time and GPS accuracy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Blocks: 965191
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Flags: needinfo?(gp)

Updated

3 years ago
No longer blocks: 965191
(Reporter)

Comment 24

3 years ago
GPS still does not work on any Geeksphone device, Keon, Peak or Revolution.
Flags: needinfo?(gp)
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

3 years ago
See Also: → bug 989678

Comment 25

3 years ago
Its working on peak with nightly, not working on 1.3.
You need to log in before you can comment on or make changes to this bug.