Closed Bug 908485 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Browser] Some links require opening new tabs, eventually causing a device crash

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: ckreinbring, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Description:
Selecting links on some sites will force the user to open new tabs in order to continue.  After 3 or 4 tabs are open, the device crashes.

Repro Steps:
1) Updated Buri to Build ID: 20130822040202
2) Launch the Browser and navigate to a site with a list of links (eg youtube.com or yahoo.com).
3) Once the page loads, select a link and observe the appearance of the "Open link in new tab" option.
4) Tap the button and navigate to the newly opened page.
5) Repeat steps 3 and 4.

Actual:
After about 3 or 4 new tabs are created, the device crashes. 

Expected:
The selected links cause the pages to be loaded with no requirement to open new tabs.  All pages load with no errors.

Environmental Variables
Build ID: 20130822040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/2ab07dec6404
Gaia: abd81ff5e49bf0c9479cdc5c5eb6975cc776f632
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
Crash ID: bp-1db0448e-790f-4126-8a4a-533a92130822
Request escalation due to phone crash impact on end-user.
blocking-b2g: --- → koi?
Component: Gaia::Browser → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk
This needs better STR with an actual site. I don't think the STR in comment 0 is the correct way to reproduce this.
Keywords: steps-wanted
Bug 900012 has the signature for this crash, but even though it is resolved fixed it is clear that there are still some other bugs tracking similar signatures - bug 902927 is one of them that is already nominated.
If part of the STR for this bug are that "clicking on links is broken" then that is bug 907977 and will be fixed shortly. As Fabrice said in bug 907977 comment 0, he was using long-tap and then "open in new tab" to navigate links, which is a workaround until that patch lands. If that is what ckreinbring was doing in comment 0 then that may be triggering some other crash that I know nothing about.
QA Contact: dsubramanian
When the user has 3-6 open tabs on the browser and tries to open the tabs, FFOS crashes. This issue is found when user follows the steps below.

Steps to reproduce:
1. Go to www. youtube.com 
2. Press hold on the videos listed from the "Popular on youtube" videos list to open link in a new tab
(In this case the links used where,  
http://www.youtube.com/watch?v=wFHcl1d-mGg
http://www.youtube.com/watch?v=MJIXdF1vDPk
http://www.youtube.com/watch?v=Cdp5yCRHwKo)
3. Go to tabs and open the videos 
 
Buri Build ID: 20130821050136
Gecko: http://hg.mozilla.org/mozilla-central/rev/b2486721572e
Gaia: 70033ba9cbac65551f68fcb3a28f7daf3105e6ff
Platform Version: 26.0a1
RIL Version: 01.01.00.019.190 

Also, I was able to find a regression window for this bug. The crash started occurring on build from 08/21. Tested all the way to the build 8/11 where the user is able to to see a white screen with a progress bar when, selecting some links from the open tabs. This can be possibly related to the issue mentioned in comment 4.
QA Contact: dsubramanian
Not a smoketest blocker.
No longer blocks: b2g-central-dogfood
Keywords: smoketest
Duplicate of this bug: 910084
This bug also happens on v1.2 Nexus4 with Android 4.3. The ENV is as below.

[Version Info]
Gaia:     14f47e5390f6fb9b0c4c841f34024870b7052cfb
  B-D     2013-08-23 14:27:51
Gecko:    e4a2844f7941ce2c797fccdfdb03761f1f333a6a
BuildID   20130823142744
Version   26.0a1
Kernel    4.3
This hasn't reproed on Buri 1.2 mozilla RIL since the 8/26 build.

Build ID: 20130826163255
Gecko: http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e
Gaia: 23343e6ea3cc59c3ab0ac9188aaa657bd11da4fd
Platform Version: 26.0a1
Okay. Closing as works for me then.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
Still unable to repro the issue, selecting a YouTube or Yahoo link causes that page to load without requiring a new tab to be opened.  Verifying as Worksforme.

Environmental Variables
Build ID: 20130903040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia: c6d58088f207829d96e7bb33ddacf990e90752fb
Platform Version: 26.0a1
Status: RESOLVED → VERIFIED
No longer blocks: GFXB2G1.2
You need to log in before you can comment on or make changes to this bug.