Closed Bug 909227 Opened 9 years ago Closed 8 years ago

[lg] Test failure "The text on the page has been highlighted - '' should equal 'community'" in /testFindInPage/testFindInPage.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox30 fixed, firefox31 fixed, firefox32 fixed, firefox33 unaffected, firefox-esr17 wontfix, firefox-esr24 wontfix)

RESOLVED FIXED
Tracking Status
firefox30 --- fixed
firefox31 --- fixed
firefox32 --- fixed
firefox33 --- unaffected
firefox-esr17 --- wontfix
firefox-esr24 --- wontfix

People

(Reporter: andrei, Unassigned)

References

()

Details

(Keywords: reproducible, Whiteboard: [mozmill-test-failure][mozmill-test-skipped][Blocked by bug 913396])

Attachments

(1 file, 2 obsolete files)

Module:    testFindInPage
Test:      /testFindInPage/testFindInPage.js    
Failure:   The text on the page has been highlighted - '' should equal 'community'
Branches:  mozilla-beta
Platforms: OSX

Possibly a localization problem: fails on the lg locale.
http://mozmill-release.blargon7.com/#/functional/report/6d53b7d749a60e65551b4b1d19227443
This is reproducible.

However locally the fail message I see is:
> Timeout exceeded for waitForElement Lookup: /id(\"main-window\")/id(\"tab-view-deck\")/[0]/id(\"browser\")/id(\"appcontent\")/id(\"content\")/anon({\"anonid\":\"tabbox\"})/anon({\"anonid\":\"panelcontainer\"})/{\"id\":\"panel1377872377015\"}/anon({\"class\":\"browserSidebarContainer\"})/anon({\"class\":\"browserContainer\"})/[0]/anon({\"anonid\":\"findbar-container\"})/anon({\"anonid\":\"findbar-textbox-wrapper\"})"

Not sure why the dashboard-reported error is different.

All branches are affected (except nightly: no builds for 'lg'), does look like a localization issue.
Summary: Test failure "The text on the page has been highlighted - '' should equal 'community'" in /testFindInPage/testFindInPage.js → [lg] Test failure "The text on the page has been highlighted - '' should equal 'community'" in /testFindInPage/testFindInPage.js
On mozilla-central we do no l10n work anymore. So nothing can be seen with that branch.
Keywords: reproducible
Priority: P3 → P1
Assignee: nobody → mario.garbi
The "findbar-container" element is being generated when we call it with Ctrl/Cmd + F which on 'lg' locale isn't working. This is because on 'lg' locale the findOnCmd.commandkey is set to 'n' which opens a new window (tested this manually). 

http://mxr.mozilla.org/l10n-mozilla-aurora/source/lg/browser/chrome/browser/browser.dtd#589
Please open a bug against the localisation to get this conflict fixed.
Depends on: 913396
Is it possible to disable this test for this locale until bug 913396 is resolved?
Attached patch skip_1109.patch (obsolete) — Splinter Review
Skip patch for 'lg' locale only. The test hasn't been skipped in manifest since we want to run it with the regular locales.
Attachment #802819 - Flags: review?(andrei.eftimie)
Attachment #802819 - Flags: review?(andreea.matei)
(In reply to mario garbi from comment #6)
> Skip patch for 'lg' locale only. The test hasn't been skipped in manifest
> since we want to run it with the regular locales.

This is not how its going to work, Mario! We can't leave out the manifest file for that. We will have Mozmill 2 soon and it would run this test. We can only skip completely or not, as long as we cannot disable tests via the locale in manifests.
Attached patch skip_1109.patch (obsolete) — Splinter Review
Updated the manifest to disable the test.
Attachment #802819 - Attachment is obsolete: true
Attachment #802819 - Flags: review?(andrei.eftimie)
Attachment #802819 - Flags: review?(andreea.matei)
Attachment #802834 - Flags: review?(hskupin)
Attachment #802834 - Flags: review?(andrei.eftimie)
Attachment #802834 - Flags: review?(andreea.matei)
Comment on attachment 802834 [details] [diff] [review]
skip_1109.patch

Review of attachment 802834 [details] [diff] [review]:
-----------------------------------------------------------------

As said, we have to skip it completely or not at all. This approach will not work. Also I would like to see this discussed first.
Attachment #802834 - Flags: review?(hskupin)
Attachment #802834 - Flags: review?(andrei.eftimie)
Attachment #802834 - Flags: review?(andreea.matei)
Attachment #802834 - Flags: review-
Attached patch skip_1109.patchSplinter Review
Full skip for the test as requested.
Attachment #802834 - Attachment is obsolete: true
Attachment #802842 - Flags: review?(hskupin)
Attachment #802842 - Flags: review?(andrei.eftimie)
Attachment #802842 - Flags: review?(andreea.matei)
Comment on attachment 802842 [details] [diff] [review]
skip_1109.patch

Review of attachment 802842 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled on all affected branches (nightly is not since there's no 'lg' locale there):

http://hg.mozilla.org/qa/mozmill-tests/rev/923455683131 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/d57dd6a76c94 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/fcbb32f082b0 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/8a19fbfac7a4 (esr17)
http://hg.mozilla.org/qa/mozmill-tests/rev/488e77d6b86a (esr24)
Attachment #802842 - Flags: review?(hskupin)
Attachment #802842 - Flags: review?(andrei.eftimie)
Attachment #802842 - Flags: review?(andreea.matei)
Attachment #802842 - Flags: review+
Status: NEW → ASSIGNED
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
It's bad to see that we had to skip this given that only a single locale is affected. Lets get the dependencies filed and fixed so we can really skip by locale and application version.
According to Francesco on bug 913396 comment 4, this will remain unfixed until new volunteers offer to help on that locale. 

Lets try to get the specific locale skip work done so we can unskip this test from all the others locales that are not affected.
Assignee: mario.garbi → nobody
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure][mozmill-test-skipped][Blocked by bug 913396]
Hm, I wanted to check this locale and I couldn't seem to find it. Francesco helped me with bug 958703 where this has been removed, so we should be able to unskip this test if it's not affected by other failure as I knew before. Checking this.
Actually this was unskipped by another bug, only esr24 remained, which fails due to bug 835739. We said that we won't want the fix in esr24, so we will wait for the new esr. 
In regards of this bug's failure, it is fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.