Closed Bug 910055 Opened 6 years ago Closed 5 years ago

[B2G][Helix][Setting][shijinde]Can't change multimedia volume when no multimedia is playing

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2, major)

Tracking

(Not tracked)

RESOLVED FIXED
2.0 S1 (9may)

People

(Reporter: lecky.wanglei, Assigned: dkuo)

References

Details

(Whiteboard: [p=1])

Attachments

(2 files)

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、go to setting screen
2、enter volume key


Actual results:

the multimedia volume was changed


Expected results:

if no multimedia is playing, you can't change the multimedia volume
Severity: normal → major
blocking-b2g: --- → hd?
Priority: -- → P2
Hi, what is the result about this problem? 

if you can't resolve in v1.1, please give me the information in the bug.

or if you can resolve in v1.1, also please give me the plan.

Thanks
Hi Wayne :
 Please help us to push to merge this case into V1.1 HD. It blocked the Helix Device .If you can not resolve it , please get the authorization from carrier.
hi beatriz:
Could you accept this issue? if you could not accept it on V1.1HD, could you help us to push it to be solved?There is no response for about 2 weeks
blocking-b2g: hd? → ---
Flags: needinfo?(brg)
(In reply to lecky from comment #3)
> hi beatriz:
> Could you accept this issue? if you could not accept it on V1.1HD, could you
> help us to push it to be solved?There is no response for about 2 weeks
This is not a bug. This is working as designed.
Flags: needinfo?(brg)
Flags: needinfo?(ofeng)
See Bug 991026 for the Sound UX spec update.
Flags: needinfo?(ofeng)
Assignee: nobody → dkuo
Arthur,

This is the first bug that bug 991026 is trying to solve, the patch added a media slider in the sound region so the user is able to adjust the content volume without launching any media app or playing some audio/video, would you please review this, or redirect it to the other peer who has shorter review queue? thanks.
Attachment #8409583 - Flags: review?(arthur.chen)
Omega, here is the screenshot of the patch, would you please review the ui part? thanks.
Attachment #8409587 - Flags: ui-review?(ofeng)
Comment on attachment 8409587 [details]
Screenshot - media slider in the sound region of settings

UX is ui-review+.
Carol will update the 6 icons and let you know the link then.
Attachment #8409587 - Flags: ui-review?(ofeng) → ui-review?(chuang)
Comment on attachment 8409583 [details] [review]
Add media slider to the sound region

r=me. Thank you for working on this.
Attachment #8409583 - Flags: review?(arthur.chen) → review+
Thanks for the speedy review, Arthur!

And I will file a new bug to trace the visual update in comment 8 because the styles are still under reviewing, let's fix this bug then update the images later.
Landed on master: 573a49f9637bcb8e455a6b695cc3dadea13d29a5

And the followup is filed in bug 998911.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8409587 [details]
Screenshot - media slider in the sound region of settings

Clear ui-review and move to bug 998911.
Attachment #8409587 - Flags: ui-review?(chuang)
feature-b2g: --- → 2.0
feature-b2g: 2.0 → ---
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.