[e.me][feature] Equalize size of Evme and Grid icon’s

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sonmarce, Assigned: evyatar)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Blocks: 910302
Additional information:
In v1.2 Evme results are a more integral part of the homescreen. It makes sense that grid icons and Evme result icons have the same look and feel.

Initially we'd like to make them the same size. Probably going to resize the Evme results.
Duplicate of this bug: 910353
Assignee: nobody → evyatar
Status: NEW → ASSIGNED
Evyatar, the psd resides here https://www.dropbox.com/s/z4vjy4ypfed9dec/A01_v1.2%20%28Balanced%29.psd
Notice the icon sizes and spacings.
on branch *results-design*

Commit: 6b0943b031d9b911e541d17f1a8fba94f4136015
https://github.com/EverythingMe/gaia/commit/6b0943b031d9b911e541d17f1a8fba94f4136015


NOTE this will not fix the apps ABOVE the line (pinned apps) since this was fixed in a different ticket (911772).
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Duplicate of this bug: 911772
To note, we have 3 sets of sizes for icons which are dictated by part of our build script for gaia (which in turn depends on the device).  Is it possible to have various images depending on screen resolution/size for e.me so that the icons won't get pixelated/stretched, etc?
Blocks: 905455
Sure. Every Collection icon has a manifest "collection.manifest" which defines icon sizes and corresponding image paths, just like apps do.

This will be addressed in Bug 910338
Ah.  Thanks!  I missed seeing that bug.
Created attachment 811971 [details]
Patch - redirect to github PR
Attachment #811971 - Flags: review?(crdlc)
Comment on attachment 811971 [details]
Patch - redirect to github PR

I added some comments on github for homescreen part. Please Ran review evme code. Thx
Attachment #811971 - Flags: review?(ran)
Attachment #811971 - Flags: review?(crdlc)
Attachment #811971 - Flags: review+
The semi-transparent circular background layer is part of the rendered image.
This creates a few design quirks in edit mode:
1. The background pulsates and overlaps the icon's circular border.
2. When dragging an an app icon the rendered image shrinks, exposing a gap between the background and the border.
3. The gap gets bigger when dragging an app over a Collection icon.

Imo it's a quirk. Might be by design.
Flags: needinfo?(evyatar)
I was testing this patch and my collection icons are not updated after drop an application. Am I doing something wrong?
Inside a collection, if I enter in edit mode the ace to delete apps seem to be placed wrongly according to grid
Cristian, the app drop does work - only you might not see the icon updating because it's added last. Open the collection - you'll see the app there.

This will change in Bug 921092.
Yes, icons are saved perfectly I know. I expected that the icon changes, alright, I can see the other bug ;) Thx
Evyatar, I agree with Cristian that the X (delete button) is now mispositioned in Collection results. I assume it's because of icon size changes?
Addressed and pushed both issues - Remove button position and the dark underlay (moved it to be the background of the border element).
Flags: needinfo?(evyatar)
Attachment #811971 - Flags: review?(ran) → review+
landed in master
b8cc3a7dfe6a7a78f48533e1712c7d5c0479f074

https://github.com/mozilla-b2g/gaia/commit/b8cc3a7dfe6a7a78f48533e1712c7d5c0479f074
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
blocking-b2g: --- → koi?
No longer blocks: 924843
removing koi? since e.me 1.2 features are delayed for future version
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.