[e.me][feature] Configurable features (collections, order, translations)

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sonmarce, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Blocks: 910302
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Additional information:
Now that Evme Collections are another type of grid icons, it should be possible to configure them in the manner that apps are configured.

I attached our proposition. It handles Collection title l10n as well.
Created attachment 797127 [details]
FXOSCollectionCustomization.pdf
(Assignee)

Updated

5 years ago
Depends on: 911958
(Assignee)

Updated

5 years ago
blocking-b2g: --- → koi?
(Assignee)

Updated

5 years ago
Depends on: 911959
(Assignee)

Updated

5 years ago
Depends on: 911961
(Assignee)

Updated

5 years ago
No longer depends on: 911961
(Assignee)

Updated

5 years ago
Depends on: 911961
Cristian, will this work with the single variant preload capabilities as defined in bug 893800?

Also, Yuren, for your grid layout tool, you may need to account for the ability to create such collections.
Flags: needinfo?(yurenju.mozilla)
Flags: needinfo?(crdlc)
(Assignee)

Comment 4

5 years ago
Theoretically it will work with single variant preload capabilities implemented by Carmen. The code is almost ready but I need that the bug 910316 is landed on master to update this one which will be reviewed by Vivien. Thanks
Flags: needinfo?(crdlc)
got it.
Flags: needinfo?(yurenju.mozilla)
Gregor plz take a look at the attached guidelines for the configuration changes.
Let us know if you have any feedback.
(Assignee)

Comment 7

5 years ago
Hi Gregor,

   This is the current implementation 

https://github.com/mozilla-b2g/gaia/pull/11948

   If you want to take a look to application-data file

https://github.com/mozilla-b2g/gaia/pull/11948/files#L19R91
(Assignee)

Updated

5 years ago
Depends on: 914115
(Assignee)

Updated

5 years ago
No longer depends on: 914115
(Assignee)

Updated

5 years ago
Blocks: 910316
No longer blocks: 910302
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 910328
(Assignee)

Updated

5 years ago
No longer blocks: 910316
Depends on: 910316
Hi Cristian, what's the state here? Do we have to uplift anything?
Flags: needinfo?(crdlc)
(Assignee)

Comment 10

5 years ago
Hi Gregor, actually we have to uplift this bug 911958, but it depends on 910316
Flags: needinfo?(crdlc)
blocking-b2g: koi? → koi+
(Reporter)

Updated

5 years ago
No longer depends on: 910316
(Reporter)

Updated

5 years ago
Blocks: 910316
Clearing nom - we're no longer taking e.me 1.2 feature changes to 1.2.
blocking-b2g: koi+ → ---
This is important to deliver with collections.  Nom'ing for 1.3.
blocking-b2g: --- → 1.3?
This is targeted feature for 1.3, not committed, so we don't need to block on this.
blocking-b2g: 1.3? → -
You need to log in before you can comment on or make changes to this bug.