Nightly crashes after being killed in the background

RESOLVED FIXED in Firefox 26

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bnicholson, Assigned: lucasr)

Tracking

Trunk
Firefox 26
All
Android
Points:
---

Firefox Tracking Flags

(fennec26+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:
1) Open Nightly
2) Push home and make Nightly be background-killed (using oom-fennec or opening several other apps)
3) Open Nightly

09-03 17:26:48.323 29969 29969 E GeckoAppShell: >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
09-03 17:26:48.323 29969 29969 E GeckoAppShell: java.lang.ClassCastException: android.view.ViewStub cannot be cast to android.view.ViewGroup
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:901)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1088)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1070)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.support.v4.app.FragmentManagerImpl.dispatchActivityCreated(FragmentManager.java:1861)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.support.v4.app.FragmentActivity.onStart(FragmentActivity.java:547)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.Instrumentation.callActivityOnStart(Instrumentation.java:1163)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.Activity.performStart(Activity.java:5068)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2109)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2174)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.ActivityThread.access$700(ActivityThread.java:141)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1267)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.os.Handler.dispatchMessage(Handler.java:99)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.os.Looper.loop(Looper.java:137)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at android.app.ActivityThread.main(ActivityThread.java:5059)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at java.lang.reflect.Method.invokeNative(Native Method)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at java.lang.reflect.Method.invoke(Method.java:511)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:792)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:555)
09-03 17:26:48.323 29969 29969 E GeckoAppShell: 	at dalvik.system.NativeStart.main(Native Method)
(Reporter)

Updated

6 years ago
Summary: Nightly crashes after killed in the background → Nightly crashes after being killed in the background
Duplicate of this bug: 912354
(Assignee)

Updated

6 years ago
Duplicate of this bug: 911490
(Assignee)

Updated

6 years ago
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
Comment on attachment 799476 [details] [diff] [review]
HomePager's stub and view should not share the same id

Review of attachment 799476 [details] [diff] [review]:
-----------------------------------------------------------------

Is this trivial enough to just land today with my r+? I'd very much like to verify this fix in Nightly, not Aurora...
Attachment #799476 - Flags: review+
(Assignee)

Comment 6

6 years ago
Comment on attachment 799476 [details] [diff] [review]
HomePager's stub and view should not share the same id

This is a kinda urgent fix. Pushed with rnewman's r+.
Attachment #799476 - Flags: review?(sriram)
https://hg.mozilla.org/mozilla-central/rev/ead32b24b522
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
This hasn't appeared in a nightly yet, because of bug 913842.
You need to log in before you can comment on or make changes to this bug.