Choosing an entry from the form history dropdown sometimes closes the dropdown without autocompleting

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P5
normal
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: MattN, Assigned: Margaret)

Tracking

({regression, reproducible})

unspecified
All
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox27 affected, fennec+)

Details

+++ This bug was initially created as a clone of Bug #912306 +++

STR:
0) Make sure there are no form history dropdowns showing
1) Load https://mail.mozilla.com
2) Type some letters from a previous entry.
3) Choose an entry from the dropdown.

Expected result:
Form history dropdown closes and the chosen entry is filled into the input

Actual result:
Form history dropdown closes without filling the selected entry into the input
It seems like it works on subsequent tries on the same page load.

Nightly 26 on Asus Transformer TF101.
I think this is a somewhat recent regression.
Summary: Choosing a form history dropdown sometimes closes the dropdown without autocompleting → Choosing an entry from the form history dropdown sometimes closes the dropdown without autocompleting
(Assignee)

Updated

5 years ago
tracking-fennec: --- → ?
Keywords: regressionwindow-wanted
The regression window is:

mozilla-central
good build: 22.05.2013 
bad build: 23.05.2013 
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c21ef3664c67&tochange=00b264c7cced
The tinderbox inbound builds are missing since the issue is older than one month.
Margaret Bug 873429?
Flags: needinfo?(margaret.leibovic)
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 24+
Keywords: regressionwindow-wanted

Updated

5 years ago
Status: NEW → ASSIGNED
Issue is reproducible on Firefox Mobile 24 beta 10 on the Asus Transformer (Android 4.0.3 )
status-firefox24: --- → affected
status-firefox25: --- → affected
(Assignee)

Comment 6

5 years ago
(In reply to Kevin Brosnan [:kbrosnan] from comment #4)
> Margaret Bug 873429?

That does look like the most relevant bug in that regression range. I'll look into it.
Flags: needinfo?(margaret.leibovic)
(Assignee)

Comment 7

5 years ago
(In reply to Teodora Vermesan (:TeoVermesan) from comment #5)
> Issue is reproducible on Firefox Mobile 24 beta 10 on the Asus Transformer
> (Android 4.0.3 )

Is this issue also present on 23? The bug kbrosnan mentioned was uplifted to 23, so I would expect this issue to be there as well (unless there's some other patch causing a bad interaction on 24 but not 23).
Yes, the issue is also reproducible on Firefox for Android 23.
status-firefox23: --- → affected
(Assignee)

Comment 9

5 years ago
I can reproduce this on https://mail.mozilla.com, but not on the test pages we often use for development:
http://people.mozilla.org/~mwargers/tests/autocomplete_forms/

Has anyone seen this on any other sites? Luckily, if it's just related to something Zimbra is doing it won't affect as many users. We should try to make a reduced testcase.
Stripped away to a form here from Zimbra http://people.mozilla.org/~atrain/mobile/tests/automissing.html

I can reproduce this on my Nexus 4 (Android 4.3)
tracking-fennec: 24+ → ?
status-firefox27: --- → affected
Keywords: reproducible
tracking-fennec: ? → +
filter on [mass-p5]
Priority: -- → P5
(Assignee)

Comment 12

4 years ago
I decided to go through some old bugs and just tried to reproduce this, but I couldn't reproduce with Aaron's test page from comment 10 (N4 running 5.0).
(Assignee)

Comment 13

3 years ago
Still can't reproduce.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.